Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Component reset, caused by a simple setup (Demo project included)

Animation of skeletal mesh is working in Editor window and Standalone mode, but not in packaged game. Tested with Shipping and Development configurations, on 4.6.1 and 4.5.1. Pure blueprint project. How to reproduce:

  1. Import some skeletal model and at least one animation, create a simple Animation Blueprint that plays this animation.

  2. Create "Person" blueprint from Character parent class. Select previously created animation blueprint in its Defaults tab / Animation.

  3. Create "Player1" class that is child of previously created "Person" class. Select imported skeletal mesh in its Defaults tab / Mesh. Drag him into level.

  4. Create "TEST" blueprint from Actor parent class. Make "Test1" function inside it and put [Get Player Character] -> [Cast To "Player1"] nodes there, connected to the function input. ... OR CREATE REFERENCE TO ANY OTHER BLUEPRINT THAT HAS VARIABLE OF "PLAYER1" TYPE, FOR EXAMPLE CUSTOM PLAYER CONTROLLER WITH "MYPLAYER" VARIABLE OF "PLAYER1" TYPE.

  5. In "Person" blueprint, create variable "testVar" of "TEST" type.

I've created a simple project demonstrating this bug, in 4.6.1: Bug Demo Project

I need to find some workaround to get animation working, do you have any ideas? BTW. This bug came out of THIS topic as a result of my troubleshooting.

Product Version: Not Selected
more ▼

asked Jan 13 '15 at 06:51 PM in Bug Reports

avatar image

2k 157 153 210

avatar image Slavq Jan 15 '15 at 09:49 AM

Update: It's not animation-only problem, looks like it resets whole Mesh properties to default when packaging! To reproduce:

In Components tab of "Person" blueprint, change Mesh position and rotation (for example -90 on z axis), so the mesh will sit on the ground. Package the project. Result - mesh position and rotation are reset to default (0) + no animation.

avatar image Slavq Jan 15 '15 at 10:08 PM

I've just tested it again, and this bug occurs only when using CharacterMovement component. I've found a workaround - instead of assigning Animation Blueprint and Skeletal Mesh through Defaults tab, i've made public variables of AnimBP and Skeletal Mesh type. Then i assign them to the actual SkelMesh and animation instance class in Construction Script. But the bug is still there.

avatar image Slavq Jan 20 '15 at 01:49 AM

I've made a few changes and this bug shown up again. But now it resets my custom "AnimBP" variable on my player, that i set via Defaults tab. It's a variable of AnimInstance Class type. It occurs under the same circumstances - this weird variable/object (circular?) reference. But now it occurs even when i restart editor, no packaging needed.

avatar image CodeSpartan Jan 28 '15 at 03:07 PM

Checked your previous thread - very good job on investigating this bug! I have a very similar (probably the same) issue, so really hope this one will get fixed. Upvoted.

avatar image Slavq Jun 29 '15 at 12:10 PM

Hey CodeSpartan, just a heads up, probably we're facing the same bug again.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Hi Slavq,

I've been actively working on this issue. I do have an engine code change that fixes this, we are still discussing several possible approaches but I do believe with some confidence that this will be fixed next release.


more ▼

answered Jan 28 '15 at 08:49 PM

avatar image

zeroexception STAFF
1k 18 16 39

avatar image Slavq Jan 28 '15 at 08:56 PM

That's good to hear :) Thanks

avatar image zeroexception STAFF Jan 29 '15 at 02:08 AM

I downloaded your project and also confirmed that my fix works. Thanks for the info and for providing a test project!

avatar image Theololz Feb 25 '15 at 06:47 PM

Hi, this hasn't been fixed in 4.7 release, right? Or I am having another bug which is due to be reported.



avatar image Slavq Mar 03 '15 at 10:31 AM

I haven't tested yet if this particular bug is fixed in 4.7.1, but a quite similar, new bug appeared (this one was resetting anim bp, and the new one is resetting ALL variables: https://answers.unrealengine.com/questions/179108/problem-with-default-values-of-variables-being-res.html )

avatar image morph208 May 07 '15 at 02:56 PM

You might want to check 4.8. I had the kind of problem in my project and the first preview of 4.8 fixed it!

avatar image Slavq May 07 '15 at 07:32 PM

Good to hear that! I'll wait until official 4.8 release and also test it on my project.

avatar image Slavq Jun 29 '15 at 12:00 PM

In official 4.8 I still have this bug - and i'm 100% sure (I've tested it) it's because AnimInstance type variable (which determines my player's Animation Blueprint) resets to None after packaging... Along with many other variables, for example Texture2D type variable, which causes my player to be untextured, or some boolean variables, which is game breaking :( It is very similar (probably the same bug, caused by the way blueprints are referencing each other) to THIS ONE, I've also posted it with repro project.

avatar image Doug E ♦♦ STAFF Jun 30 '15 at 05:02 PM

Hey Slavq-

As TJ Ballard mentioned in the other post you created, a new report has been created (UE-17464) to track this issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey guys I know this is been a dead thread, but this occurs again in 4.15...

I am doing my game since 4.8 and after upgrading to 4.15 this happened. never happened before, and I have done a LOT of tests in 4.12 and 4.13, now on 4.15 this happened.

more ▼

answered Feb 14 '17 at 05:48 PM

avatar image

10 5 6

avatar image Slavq Feb 14 '17 at 05:59 PM

That sounds scary! I can't test it on my end yet, but I hope that this bug won't return in the official 4.15 release... It is basically a game breaker.

BTW. I'm not sure if someone from Epic will be notified about this, maybe a new report or a comment under @Doug Wilson 's answer will help, just to be sure.

avatar image Doug E ♦♦ STAFF Feb 14 '17 at 10:30 PM

Hey BagmanPT-

Can you elaborate on what you're seeing? The specific issue originally reported has been fixed, so what you're seeing is likely a different issue. It would be best to create a new post to track the issue separately. Please provide as much detail about your setup / reproduction as possible.

avatar image BagmanPT Feb 15 '17 at 03:07 AM

Ok so this is the setup:

THE HISTORY: I am building on the GenericShooter template. Been doing it since 4.6/4.7 and upgrading every step of the way, everything worked without any problem until 4.13 which gave me a problem with spawns and I had to wait for 4.14, 4.14 came and I had yet another problem related to that, 4.15, preview 1, 2 and 3 gave me all errors regarding enums, Async loading, and other packaging errors, enums have been messed on preview 2 but I've redone it so it worked as intended, preview 4 came out, and I finally managed to package the game.

THE ERROR: 4.15 preview 4 came and I packaged the game, everything went smooth and when testing the game, my character has a T pose with a -90 rotation, standing in the air... (see attachments, one is in editor/standalone the other one is the game packed. same skeleton, same parameters, same map even)

Everything in the editor works perfectly, standalone works perfectly as well, and when packaging the game, the character just resets, puts itself in -90 rotation and T pose.

EDIT: ALSO need to mention: I am using a BP_playerCharacter as a parent, and I am using several children BP as different character.Exactly like the original problem was on the thread

sssnp.png (1.4 MB)
sssp.png (1.2 MB)
avatar image Doug E ♦♦ STAFF Feb 15 '17 at 03:18 PM

I tried to reproduce this in a new ShooterGame project by creating a child blueprint of PlayerPawn (and child of that BP). When packaged, my skeletal mesh (HeroTPP) appeared with the expected animation. According to the post by Zak M, the bug that was reported originally was fixed. Please try migrating your character/animations into a new project and let me know if the packaged game for that has the same issue. If so, providing a copy of that sample project will help us investigate the problem. Also, it would be best to create a new post with all this information there to prevent the details for your issue from being lost in this post. You can comment here or send me a PM on the forums (with a download link to the sample project if possible) to make sure your new post gets assigned to a member of our support staff.

avatar image BagmanPT Feb 15 '17 at 05:52 PM

Doing a migration and repack results in the same problem, HOWEVER I've tried using the parent blueprint in the original project instead of the children blueprints, and with the parent blueprints works perfectly after packed. It seems it only affect the children blueprints...

Done reparenting and creating new child blueprints. same thing, T pose, no animations. The problem is definitely related to the children/parent connection...

any ideas?

avatar image Doug E ♦♦ STAFF Feb 16 '17 at 05:32 PM

Please create a new post for your issue and link to it here so that we can assign one of our support staff to investigate. Be sure to include as much detail about your issue as possible. Based on the information provided so far, a sample project demonstrating the issue would also be helpful.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey Slavq-

I was able to confirm on my machine that setting the animation in a parent blueprint and setting the mesh in a child blueprint causes the animation to not play when packaged. I submitted this bug to our internal tracking database (UE-7987) for further investigation by an engineer.


Doug Wilson

more ▼

answered Jan 21 '15 at 08:29 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey Slavq,

Thank you so much for all the details of your investigation. It really helped me a lot. I just tested the first preview of 4.8 and it fixed the problem for me.

more ▼

answered May 07 '15 at 02:57 PM

avatar image

81 5 7 21

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question