x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

BluePrint Corrupted, Crash when opening Project

link textlink text

Hello, I Have Been Working on a small project Based on BluePrint, When a BluePrint (ResistanceWeapon) stopped compiling whitout any changes to it or to any other blueprint related. Without saving i closed the project and reopened it. Unfortunately All my BluePrint Related to ResistanceWeapon, and ResistanceWeapon itself were now Corrupted. At this point, Start Playing or Right/Left Clicking any of those corrupted BluePrint in the Content Browser made the editor crash.

I Tried Setting bRecompileOnLoad to False in BaseEngine.ini but my BluePrints were still uneditable.

I then tried many things. Creating a new project and Importing old backups of my blueprints with bRecompileOnLoad to false gave me the chance to edit them. But they couldn't compile, Some of the Variables i made appeared in the graph but couldn't be found in my Variables list. I Deleted those variables in the graph, but when trying to create new ones with the same Name, the Editor told me i couldn't because a Variables with the same name already existed.

After Deleting all parts of the BluePrint that communicated with other blueprints, i then recompiled it and those "Ghost" variable still weren't appearing, couldn't be found with the search tool, but the Editor still told me they existed when trying to create new ones.

So i Created a brand new project Extending on the ThirdPerson BP. Created brand New BluePrints, And Remade the hole project based on some Copy-Past and Remaking some stuff. There i Encountered a new minor problem. Input Command inside my BluePrints extending actor did not respond anymore. I just went around this problem by Puting Inputs Inside "MyCharacter" BluePrint and making them communicate with the blueprint extending from Actor.

At This Point all my Project was back and running. All worked perfectly fine. While remaking this new project i exited the editor multiple times and got the time to manually make a backup of the project from the document Folder.

The next day (Today) i Turn on the computer, and open my project. Editor instantly Crashes. I open the manual Backup i made, Same Thing. I Try Removing "ResistanceWeapon" Project opens (but obviously dont compile due to references to ResistanceWeapon of other blueprints)

I Linked the .uproject and all the Blueprint I Modified or Created from the project from the save i made yesterday when everything were working like a Charm after Copy/Pasting, Recreating everything. When Crashing the editor always display nothing else than : "We apologize for the inconvenience. Please send this crash report to help improve our software."

plz.....Help me....

*Edited, with Log of current Crash and DxDiag

Product Version: Not Selected
Tags:
more ▼

asked Mar 22 '14 at 10:08 PM in Bug Reports

avatar image

Talus
179 34 35 43

avatar image Alexander Paschall ♦♦ EPIC Mar 22 '14 at 11:05 PM

Hi Talus,

Could you please post your Dxdiag and also the log files that were generated at the time of the crash? The log filess can be located in the [Project Name]/Saved/Logs. That will allow us to further investigate the issue.

Cheers!

avatar image joessu Mar 24 '14 at 02:35 AM

Build: GITHUB 4.0.1-0+UE4

I could also include the assets in question

avatar image bigzer Mar 28 '14 at 04:25 AM

Just to point out we've had the same issue and had to redo 1 day of work.

avatar image joessu Mar 28 '14 at 06:54 AM

My colleague is having the same issue problem asset. this is definitely a file that is failing.

He reached this problem by his computer crashing, and then rebooting.

Unreal said that it could not load blueprint because it couldn't find parent class, but the parent class exists, we did a recompile to make sure.

hexgrid.zip (9.8 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Talus,

Was "ResistanceProj" a class that you had defined and maybe removed or renamed? Or maybe you didn't include it in the .zip that you provided us?

I did find and fix a crash, but it looks like it resulted from not being able to find a class type that used to exist (specifically regarding the "PM_Slot" variable).

Either way, thanks for identifying this crash. Users should be able to remove/rename classes without hitting a crash.

Cheers - MikeB

more ▼

answered Apr 17 '14 at 07:47 PM

avatar image

User-1420270633 STAFF
963 27 26 58

avatar image Talus Apr 28 '14 at 06:32 AM

Hi Mike, I did have a "ResistanceProj" blueprint, but all assets that are still there are present in the .zip file. I don't remember if ResistanceProj got deleted or if it was a Rename. Anyway, i am now on 4.0.2 and i never reencountered this bug again.

avatar image User-1420270633 STAFF Apr 28 '14 at 05:14 PM

Awesome! Glad to hear it!

avatar image Talus Apr 30 '14 at 12:43 AM

Omg i just posted such a long comment on a Reiteration of the bug but it just dissapeared, the Post still lost its "resolved flag" but the message just dissapeared. I am very sorry but i dont have the energy to right everything again. In Short, Same bug again, on a new Project base on the FirstPerson BP template this time. Quite the same structure. Here are the assets link text

I am still on 4.0.2, if this bug is fixed on 4.1 please let me know. You might find some Additionnal information if the comment i just posted is still stored somewhere. If you have any question i'll Answer them gladly.

Love you. edit:Seems like my original comment found his way back.

blueprints.zip (502.0 kB)
log.zip (4.3 kB)
avatar image Talus Apr 30 '14 at 02:25 PM

Hi Again. I never encountered this bug again....... until now....... Yep... So I Worked Today on a new project. i Made up a very similar Setup that the one i had on the ResistanceProject, but from the FirstPerson template this time.

No Projectile class this time (only the one that comes with the template) but a similar bug. This Time the two class that seems to pose problem are MyCharacter and RizeWeapon. Anytime I touch those, editor Crashes, Removing Mycharacter gives me the possibility to open my other Blueprints.

Changing the name of MyCharacter inside my project folder document also provide me the possibility to access all my blueprint without crash. There i can see that DefaultPawnClass inside "MyGame" is automatically set to None, some node gets automatically disconnected, and that all the "cast to MyCharacter" nodes inside RizeWeapon are now considered bad. If i fix the blueprints, game is up and running again.

When i Compile RizeWeapon i get the little green icon, but when i then compile MyCharacter, the RizeWeapon Compile Icon shows the orange "Dirty" (And Vice-Versa)

If i save and close the editor, everything bug again.

I Wonder if this is not coming from a simple "DependsOn" option that we had in UnrealScript, and that might fuck up the blueprint, but i sincerly have no idea.

I am Currently still using 4.0.2, please let me know if i can get rid of this bug by upgrading, or if it will still be there. Hope those additionnal infos might help you improve the engine, cause unfortunatly this Post might not be "resolved" ;(

Love you still.

Here are the Assets used (Notice that i might have renamed stuff after the crash, but no rename was done before the crash occured)link text

link text

log.zip (4.3 kB)
blueprints.zip (502.0 kB)
avatar image User-1420270633 STAFF May 02 '14 at 04:19 PM

That's a bummer that it is still happening for you :(

First off, I would definitely recommend upgrading to 4.1. With each release, we've been fixing up so many issues that this will always be our first piece of advice. So give that a try and let me know if you're still running into the crash.

I'll take these assets and give them a look over and let you know if I find any issues myself.

As always, thanks for bringing these issues to our attention!

avatar image User-1420270633 STAFF May 02 '14 at 05:34 PM

I couldn't reproduce your crash with the assets you gave me. Was it happening for you when you were opening either the MyCharacter or RizeWeapon blueprint?

This hopefully mean that your issue has since been fixed, and 4.1 is worth trying. Let us know how that goes.

In other news, about the two blueprints dirtying each other from compiling. This is somewhat a known issue, and it does mean that the two blueprints have been identified as depending on each other. Usually the dependence goes one way, but often you can get a circular dependency like you have here.

We're a bit heavy handed in marking dependent blueprints dirty (if it depends at all, then we dirty it). We need to be more mindful of what has changed to see if it actually alters the dependent blueprints (and only mark dirty then). I've logged this as an issue for us to follow up on.

Thanks, and hopefully 4.1 resolves your issues!

avatar image Talus May 30 '14 at 09:22 AM

Ok, I am now on 4.1, and better structure for no dependencies loop allow my projects to work. Apparently, making loop dependencies crash the project, and making mutual dependencies on two direct child of a same class does not crash, but some connections do not save when rebooting the editor, (and doesn't work on a package game). Also, putting a blueprint directly inside a map, instead of putting a volume making it spawn for exemple, can create dependencie problem while launching the game on PC or launching the packaged version of it.

avatar image User-1420270633 STAFF Jun 02 '14 at 03:30 PM

Could you provide us with some assets that are exhibiting these issues? Thanks!

avatar image joessu Jun 03 '14 at 02:43 AM

Mike, To quote Talus, "and making mutual dependencies on two direct child of a same class does not crash, but some connections do not save when rebooting the editor, (and doesn't work on a package game)." We experience that as well and it is interesting that Talus came to this conclusion about the cause. We have another post here describing the problem, and we are in the process of zipping and FTPing 2 project folders, one without the breaking change and one with.

avatar image User-1420270633 STAFF Jun 17 '14 at 03:36 PM

Hopefully that other thread ends up resolving this issue, I'm marking this one back as answered since this is a separate topic. You got some good people on that other thread and collectively I'm sure we'll get to the bottom of this. Please post there if you have any further information on the subject.

Cheers - MikeB

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Would you mind providing the assets in question? Unfortunately, there's not a lot to go on in the log!

more ▼

answered Mar 25 '14 at 03:00 AM

avatar image

Nick Whiting STAFF
301 5 5 8

avatar image joessu Mar 25 '14 at 06:02 AM

link text

Here they are I think... They seemed to get corrupt when i was updating the blueprint interface they implemented and i think i may have deleted it or something??? not 100% sure, i just know i was messing with interfaces.

avatar image Nick Whiting STAFF Mar 28 '14 at 01:49 AM

Hi joessu -

I tried opening those assets, but they don't appear to have valid package signatures. Were you using a modified version of the engine? If they're simple enough, can you paste screens of what was in them so we might get some leads? Thanks!

avatar image joessu Mar 28 '14 at 02:30 AM

ugh... unfortunately i can't reproduce it!!!!!! (i did update) I just tried one of the backups that was during the time i was having issues, it said during launch of editor "couldnt find blueprint blah blah" but i opened it and saved and compiled it just fine. i have a ton of backups from the time stuff was generating the error. between noon and 4pm on sunday. i attached a zip of the remaining backups during that time. you can see that i was mucking with interface stuff. i put the zip on my dropbox because it was too big.dropbox zip

The engine i was using was just a vanilla github compile

avatar image User-1420270633 STAFF Mar 28 '14 at 09:41 PM

Hi joessu -

Unfortunately all the MyCharacter and TeleporterBallProjectile backups here have to same issues that the prior zip had... You say it works now? Have you since recreated the work you were doing? Or did you do something different? The files are definitely borked, it'd be nice to have a hint of what lead to this (it is unfortunately hard to reverse engineer the cause). If you've recreated the work (to the best of your recollection), then could you provide us some screens of your current graphs? This could hopefully give us some leads to follow.

Thanks! - MikeB

avatar image joessu Mar 28 '14 at 09:44 PM

Well, the hexgrid.zip file in the comments above cannot open (causes crash). It was caused when the computer it was on crashed. i guess the unreal process was flatout killed while the blueprint was open? (at least in that particular case)

avatar image User-1420270633 STAFF Mar 28 '14 at 11:37 PM

With that asset, it looks like there was a "Break" struct node and the associated struct type can not be found (maybe it was deleted)? Regardless, this should not crash. I just fixed the crash issue, so that should be resolved with some update in the future.

However, once you make it passed the crash, the asset is like the rest. Do you maybe not have the struct defined that your colleague was using (and this is why it's crashing for you)? Does your colleague have any information on the crash that seems to have caused this? What exactly was he/she doing? What are the specs of the machine that he/she is on? I assume that since it rebooted the machine, that he/she didn't get a chance to report the crash through our reporter tool?

At the very least, thanks for helping us resolve the break-struct crash! This will for sure help others down the road.

avatar image joessu Mar 29 '14 at 12:44 AM

Dude the blueprint stuff is awesome, if i knew the source better i would take a stab at debugging it myself! We were compiling the game code when the computer crashed (it actually overheated haha stupid skype screen share), and i'm not sure how far along the compile was, since we were watching VS do it's thing then boom black screen.

In both cases, the blueprints inherited from custom code classes!

avatar image User-1420270633 STAFF Mar 31 '14 at 08:26 PM

Is there any way that you can provide us with those native code files, so that we can try and load it with those classes (we can't load them without the parent classes)? What might have happened is if you ever got rid of the code classes (renamed them, etc.), then somehow saved the blueprint, it could have saved out with a null parent class. Even if you bring the old base class back, the association has been lost.

avatar image joessu Mar 31 '14 at 08:30 PM

lemme know which folder you want, the sources folder? It was just a prototype/learning project so i don't mind sharing the whole thing really.

avatar image User-1420270633 STAFF Mar 31 '14 at 09:40 PM

The files that contained the custom code classes that the blueprints in question inherited from. - Thanks!

avatar image joessu Apr 01 '14 at 03:48 PM

[link text][1]

here are all the sources [1]: /storage/temp/2942-sidescrollertest.zip

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question