x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Weird Shadows on Mesh.. What i'm doing wrong?

Howdy folks... First of all ty for helping. I'm new to UE and i'm kinda stuck. I done some research b4 asking here but i'm stuck. I made 2 channels. First for Texturing and 2nd for lightning. I attached both here as well as 1 which i made in 3ds max (which i'm using for light). While rendering i don't get any errors and for template i'm using tesing one. Ty.

Product Version: Not Selected
Tags:
01.jpg (715.2 kB)
02.jpg (969.0 kB)
uv_0.jpg (792.0 kB)
uv_1.jpg (989.7 kB)
untitled.jpg (369.2 kB)
more ▼

asked Jan 14 '15 at 11:12 AM in Rendering

avatar image

Javorcek
41 2 5 6

avatar image AndrewHurley Jan 14 '15 at 06:21 PM

Hey Javca,

It seems you have your Lightmaps and UVs organized well, and your spacing is fine. After looking at all of your images, I think your problem lies with the resolution of the floor that is receiving the shadows.

Try changing the resolution of the floor mesh as well as checking the box that says, 'Inset Shadow' on your building mesh. This will give you a higher and more accurate shadow resolution.

Let me know if you need help locating these options or if you still are having problems with your shadows.

Cheers,

Andrew Hurley

avatar image Javorcek Jan 18 '15 at 07:13 PM

Something bugged couldn't write here :/ answer is below

avatar image Javorcek Jan 18 '15 at 07:12 PM

I wanted to complete whole floor so here it is. And again same problem i tried to bump up resolution to 256 and nothing changed.. Here are some pictures. And i couldn't find 'Inset Shadow' in mesh editor... Material is double sided and everything is fine, but the shadows are still problem. Light Source is default BP_Sky_Sphere with default settings.. Ty

picture01.jpg (741.5 kB)
picture02.jpg (453.8 kB)
picture03.jpg (374.8 kB)
avatar image Javorcek Jan 18 '15 at 09:18 PM

alt text This is without build lightning

no_lightning.jpg (566.7 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello Javca,

You might try a resolution a bit larger if this is all one Static Mesh. Try either 512 or 1024.

Before changing the resolution however; try the 'Cast Inset Shadow' setting that I mentioned previously. I have posted some images as reference where to find it, and the change it can have on your shadows.

Cast Inset Shadow Off alt text

Notice how some of the shadow is dithered.

Cast Inset Shadow On alt text

Now notice how the shadow is full and looks cleaner.

The setting can be found in the 'Lighting' section in your Static Meshes 'Details' settings.

Hopefully this resolves your issue, but if you are still having problems, let me know and we can try some other approaches.

Cheers,

Andrew Hurley

more ▼

answered Jan 19 '15 at 03:15 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Fixed.. Ty Andrew... Now with another problem -.-

more ▼

answered Jan 19 '15 at 07:07 PM

avatar image

Javorcek
41 2 5 6

avatar image AndrewHurley Jan 19 '15 at 07:52 PM

If you have another issue, just post a new question and we will be happy to assist. :)

Cheers,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question