x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

UMG - Text blocks loosing text when i compile.

I'm having this strange problem in 4.7 that when I add text blocks to a widget and change the text it does not change on the viewport (unless you change the color/alpha of the text). Also in the hierarchy it changes all text blocks to display the text I've entered.

When compiling the Widget it reverts all text back to 'Text block' I've tried creating new widgets and keep having the same problem. alt text

Product Version: Not Selected
Tags:
more ▼

asked Jan 14 '15 at 11:35 AM in Blueprint Scripting

avatar image

Lankeytom
81 6 7 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

This is a known issue, and is caused by all text in UMG being given the same key for the LOCTEXT system. The offending change was removed by the following revision: https://github.com/EpicGames/UnrealEngine/commit/2f181bff70b43575eb67e75be4382ff784d09b26

Thanks, Jamie.

more ▼

answered Jan 14 '15 at 11:44 AM

avatar image

Jamie Dale STAFF
7.5k 176 66 304

avatar image Lankeytom Jan 14 '15 at 12:18 PM

The link is dead, will this be fixed in the next update?

avatar image Jamie Dale STAFF Jan 14 '15 at 12:28 PM

Dead as in 404? You have to be logged into GitHub with an account that has permission to see the UnrealEngine repo, otherwise you see a 404.

It will be fixed in the next update, yes. Are you using a 4.7 preview (rather than the GitHub source)?

avatar image Maceo_P_King Jul 28 '15 at 04:48 AM

Hey Jamie, I'm getting the same error in UMG only with Images instead of text - whatever I add into the image box will be cleared when I compile it.

Github will fix that? I'm just using the UE4 4.8 as its the most recent download, but... I've been seeing that there are benifits to using that (i'm just not sure if that's something I really know how to do. Like, I use Ue4 blueprints, so unless its the same program i'd be downloading and using, it all seems kind of iffy to me. But... i want it to work so... yeah please advise :)

avatar image Jamie Dale STAFF Jul 28 '15 at 11:26 AM

Hey,

We're not currently aware of any issues where images would be lost when compiling your UMG blueprint. Does this also happen on a new project, or is it limited to your current project?

I wouldn't advise using a GitHub build unless you're comfortable compiling it yourself. It's a simple enough process, but unless you're going to benefit from it (and you likely won't here as we don't have a fix for your issue), then it's probably not worth it.

Thanks.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question