x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

FPS stuck at 75 - help?

Hello,

I seem to be having some sort of GPU bottleneck and I'm running out of things to check. It doesn't seem to want to go over 75FPS on this project (occasionally it goes up to 80). Actually, I think the GPU is sleeping more than it is working. I'm trying to figure out the best way to approach this. The game thread runs at 4-5 Ms 99% of the time and the draw thread as you can see below is less than 1. This is an issue because when I run it on Oculus the frame rate cuts in half.

Vsync is definitely off, So is frame smoothing. I also tried with it set to 120 min and max.

I set the game to wireframe for these shots to minimize whatever is being rendered. Am I correct in guessing that the huge white gap in the bar of the profile window is the thread sleeping?

Any suggestions would be helpful. This machine has 16Gigs of ram, an I7 at 3.8Ghz, and a GTX 780. It shouldn't be slow.

In Editor View

Stand alone game

Product Version: Not Selected
Tags:
ineditor.png (213.0 kB)
standalonegame.png (160.0 kB)
more ▼

asked Jan 14 '15 at 09:46 PM in Rendering

avatar image

xdbxdbx
195 17 20 33

avatar image MickD777 Mar 11 '15 at 05:03 PM

This is called vsync. You are probably capped at your monitor refresh rate.

avatar image xdbxdbx Apr 08 '15 at 01:33 AM

Sorry, I somehow missed this till now. In the screenshots above, you can see r.vsync = 0. yet its still on apparently. whats up with that? is there another vsync setting I should be aware of?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question