x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Emissive materials break when using splitscreen

I'm creating a game that utilises a lot of emissive materials. Within the editor, these look fine. When playing the game with a single camera view, they still look fine. However, after using the blueprint node to create a new player and use splitscreen, the emissive materials completely change. They become flat and lose any sort of bloom or glow around them. I tested this in a level within my game (4.6), a new empty level in my game and in the 3rd person template game in 4.7 with all the same results.

Any suggestions?alt text

Product Version: Not Selected
Tags:
more ▼

asked Jan 15 '15 at 01:15 AM in Bug Reports

avatar image

Melisande
41 2 4 6

avatar image Eduard Gotwig Jan 30 '15 at 10:14 PM

Our game, for up to 3 players, is also affected by this. please compare those two images! Can we expect a fix in UE 4.7? Those bugs are really game breaking.

alt text

alt text

avatar image Imagine-Games Nov 30 '17 at 09:29 PM

wondering if you ever fixed this.. i followed the steps below for changing the showflags.cpp to include bloom and motionblur but how is that related to emmisive materials, I didn't see any change , my splitscreen still doesn't show emissive materials glowing....

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Melisande-

Thanks for the report. I was able to reproduce this and have submitted it to our internal tracking database (UE-7627) for further investigation. This fix should be included in a future update to the engine.

Cheers

Doug Wilson

more ▼

answered Jan 15 '15 at 07:57 PM

avatar image Melisande Jan 21 '15 at 08:37 AM

Thanks for the quick response! Fingers crossed for a quick fix. :)

Melisande

avatar image pr4wl Mar 17 '15 at 10:10 PM

Any update on this? It's been a few patches now and this is one of two things that is still breaking our game's splitscreen.

avatar image Doug E ♦♦ STAFF Mar 17 '15 at 10:21 PM

Hey Voren-

We are still looking into how to best address this issue. It looks more like bloom is disabled when splitscreen is enabled, and we are trying to find the best way to address that point.

avatar image pr4wl Jun 09 '15 at 04:25 AM

Any chance we will see this in 4.8?

avatar image Doug E ♦♦ STAFF Jun 09 '15 at 02:52 PM

Hey Voren-

The fix for this issue will not be included in 4.8. This report is currently considered a lower priority issue because it is not a crash or show-stopping bug.

However, once 4.8 is officially released and our developers are freed up, this issue will likely move up in priority. We will post back here with updates as we have them.

avatar image pr4wl Jun 09 '15 at 08:24 PM

Did I break a rule or anything? It looks like my comment got removed?

I was only trying to present my case for why I think this should be higher priority. If that came across wrong I apologize, it was not intended.

avatar image pr4wl Jun 10 '15 at 12:38 PM

This is a long standing show-stopping issue. If you are making a Split-screen only game and your game needs bloom then your game looks bad without it. Can't ship a game like that.

Have you ever seen Tron? Imagine Tron without any glowing lights. It doesn't look good.

Other posts regarding this issue: https://answers.unrealengine.com/questions/85667/431-split-screen-post-process-not-working.html https://answers.unrealengine.com/questions/162437/post-processing-doesnt-work-in-splitscreen.html

As you can see this issue has been reported since 4.3.1 and has been ignored because it is 'low priority'

Easy simple Split-screen support and great special effects was the reason I chose UE4 over 'that other engine' for this project. Starting to think that was a mistake :,(

Thank you for the quick responses and I hope you will re-consider the priority of this issue.

avatar image Doug E ♦♦ STAFF Jun 10 '15 at 07:55 PM

Hey Voren-

I've bumped up the community interest in this bug to bring more attention to it. I will update you here when there is any change to its progress.

avatar image HenningAx Nov 01 '15 at 02:08 PM

Is there any progress on this, we are also going to make a splitscreen game and without post processing it won't look good

avatar image Doug E ♦♦ STAFF Nov 02 '15 at 02:29 PM

Hey HenningAx-

Investigation into this issue has shown that the main issue is the bloom effect rather than the post processing. When the bloom is enabled there is a an artifact on the split separations when the height is not a power of two (Assuming we are splitting horizontally). This artifact happens because of the power of two down sampling of the target that contains the 2 screens. Disabling the bloom is the intended behavior to remove the artifact effect.

avatar image hzn84 Apr 11 '16 at 01:26 AM

Hi Doug, I've also would love split-screen to get it's much needed attention. In the meantime, could you please, share where to look for in source if one would like to turn it on himself. Thanks!

avatar image Doug E ♦♦ STAFF Apr 14 '16 at 03:57 PM

Hey parabolainteractive-

In the 4.11.0 source code from GitHub you can edit the if(bIsSplitScreen) block in the ShowFlags.cpp file. The block begins on line 337. If you are using 4.11.1 or another version the line number may be off slightly due to changes in that file.

avatar image hzn84 Apr 14 '16 at 04:00 PM

Thanks a lot for your answer! Yeah, I managed to find it myself. I enabled motion blur and bloom for splitscreen and so far it works great, without any artifacts or anything.

avatar image MrRabbit Apr 21 '16 at 10:38 PM

Thank you very much Mr. Wilson for the fix! I can confirm that there are no visible artifacts as far as I tested it.

avatar image Sushii Jan 17 '17 at 08:15 AM

Hi Mr Rabbit, i work on student poject and we need to use splitsreen. I have try change the ShowFlags.cpp but doesn't work. Maybe i miss step ! :/ It's possible to give me some help ?

alt text

cpp shoflags.png (21.2 kB)
avatar image Imagine-Games Feb 05 '18 at 09:56 PM

Hello Doug, can this also be in the default downloaded version of UE4.16 or does it have to be the github version? After editing the showflags.cpp file does it need to be recompiled or just saving does the trick? Thanks!

avatar image eudrea Mar 03 '16 at 11:13 PM

Wouldn't be nice to have an option? Or is there one already? I suppose can start with it disabled and let programmer enable it, I'd guess it doesn't look all that bad in all situations? Sadly bloom does a lot for many games, some even base their look on it and disabling it makes them look ugly.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question