x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Self Shadow Only in static lighting

It seems that SelfShadowOnly doesn't work with static lighting. Simply check a box "Self Shadow Only" in StaticMeshActor, and rebuild lightmaps. Shadow appears in lightmaps even if both mesh and light are marked as static.

Product Version: Not Selected
Tags:
more ▼

asked Jan 16 '15 at 02:11 PM in Rendering

avatar image

Esidar
68 5 10 16

avatar image AndrewHurley Jan 16 '15 at 08:23 PM

Hello Esidar,

Which version of the engine are you running?

I tried testing your issue on the binary release of 4.6.1 and was able to get the 'Self-Shadowing' to work with Static lights.

Perhaps you can provide me with a screenshot of you Static mesh and your light properties you are trying to get this to work. Also, if you could provide me with some reproducible steps that would be helpful as well.

Thanks,

Andrew H

avatar image Esidar Jan 17 '15 at 11:00 PM

I'm sorry, I didn't gave you a repro right away. It looked like a 100% repro to me :) I did it with 4.6.1, and now, I've also downloaded 4.7 pr3 and have the same result.

I've started new project "First Person Shooter", grabbed DirectionalLightStationary, changed it to Static, then selected one of the cubes, changed to Static, and checked "Self Shadow Only" flag. I'm attaching a screenshot: on the left side, there's no shadow (it dissapeared after selecting "Self Shadow Only"), on the right side there's a shadow after calculating a lightmaps.alt text

untitled.png (1.1 MB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

The SelfShadowOnly feature is for dynamic shadows only - it allows to have a first person weapon in high quality without casting a shadows onto the world. I guess the name should have the word dynamic in it. We might be able to make it consistent for static shadows to make it less confusing. I created a task to fix that. Fixing it for static shadows might be hard as it can break the GI computation to have artificial non physical things happening there.

more ▼

answered Jan 19 '15 at 07:18 PM

avatar image rohoon Aug 10 '15 at 01:22 AM

Any word on whether this will be applied to static shadows as well? I'm currently having to bake self-shadowing into textures.

avatar image AndrewHurley Aug 12 '15 at 06:57 PM

hey rohoon,

as Martin mentioned this is a dynamic shadowing feature and is not meant to be used with baked static lighting. You might be confused as he mentioned editing the tooltip to be more consistent with the feature itself.

Thanks,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question