x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Dissapearing meshes from maya to UE4 after deleting faces

Hi guys,

Basically I'm having an issue with the export from maya/import to UE4. The main issue stems from the character I have (rigged and weight painted with A.R.T.).

When I add clothes I need to delete faces from the main mesh so that there aren't any clipping issues with the existing animations, However whenever I delete faces from the body mesh in Maya 14 to accommodate for the new trousers, the body mesh disappears when I export it from Maya/import it into UE4. The separate trouser mesh remains, as does the skeleton structure itself and I cant figure out what's causing it.

I've tried checking the normals and the skin weights and they're all fine, I've also tried combining the meshes into one and that doesn't fix it , the mesh exports perfectly when I don't delete the faces from the legs. Has anyone else encountered this? and has anyone found a solution?

Any help would be appreciated Cheers

alt text

Product Version: Not Selected
Tags:
more ▼

asked Jan 16 '15 at 02:26 PM in Everything Else

avatar image

cappatches
36 1 1 4

avatar image Crofty Jan 20 '15 at 10:21 AM

I'm having the same problem. It works in 3dsMax if you keep the skin modifier at the top and delete faces in the "edit poly" beneath. However I need to be exporting it from Maya. Hope someone answers.

avatar image pchan126 Sep 18 '15 at 04:38 PM

Having the same issue in Maya LT 2016. Deleting faces causes the whole mesh to disappear, same with using Mesh->Separate

avatar image pchan126 Sep 18 '15 at 04:54 PM

Hm. Looks like the issue might lie with Maya LT. Re-importing the mesh back into Maya yields the same results.

edit: There was an export error that causes the mesh to not be exported. Deleting the Non-Deformer History fixed this for deleting faces, however mesh separate cannot be fixed in this manner.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question