x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Particle spawned before play

I always need wait to spawn/born for example smoke particles to full range on whole scene. But I would like to have smoke on whole scene exactly after hit a play button. What should I do?

Thanks!

Product Version: Not Selected
Tags:
more ▼

asked Jan 16 '15 at 02:27 PM in Rendering

avatar image

thobias
41 7 9 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I had the same issue, in UE 4.18, and as @xlar8or pointed out; the "Warm Up Time", in cascade, does not work for GPU particles :(

My workaround is to set the CustomTimeDilation, of the particle system, to a very high value (100) in the BeginPlay of the level blueprint. This makes the particle system play 100 times the regular speed. After a short delay, of 0.025 seconds, I restore the CustomTimeDilation to 1.0. Depending on your game, such as the size of your particle system and whether you use e.g. GlobalTimeDilation, you may want to set different values for the CustomTimeDilation and the delay before restoring it back to 1.0.

P.S. I know this answer comes a bit late, but when searching I found this. If it helps just one person it's worth the post :)

more ▼

answered Dec 06 '17 at 06:31 PM

avatar image

amcofi
530 9 83 49

avatar image SleepyRatSquad Nov 19 '18 at 04:24 AM

@amcofi - Thank you! Your solution worked great!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey thobias -

In Cascade, Click in the black area beside your module list and then look in the Details panel at your whole system settings for that particle system and you should see a Warm Up Time, adjust the time as necessary to have your system start where you desire.

Thank You

Eric Ketchum

more ▼

answered Jan 16 '15 at 08:50 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 736

avatar image thobias Jan 19 '15 at 11:00 AM

Thank you, Eric, that is exactly what I need!

avatar image xlar8or Nov 07 '16 at 07:59 PM

This only works for CPU particles, at least in 4.12 :(

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question