x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Main Menu Problem

I made a simple menu using BP Widgets. It seems to work fine in the viewport when I click play, but when i launch the game, it always crashes when I click on any button that load a level.

Here's the crash I get: http://puu.sh/eFKwx/febd5aa3fa.png

I only have a start button and a quit button, and I start the game in a "main menu" level separate from the playable game level. Having checked multiple sources, my BP layout should be correct:

Level BP: http://puu.sh/eFMMR/abe156f96c.png

Menu BP Widget: http://puu.sh/eFMJ5/4cc431fdd0.png

Does anyone know what might be the problem?

Product Version: Not Selected
Tags:
more ▼

asked Jan 18 '15 at 04:50 AM in Using UE4

avatar image

Hcui
0 1 1 3

avatar image Rudy Q ♦♦ STAFF Jan 21 '15 at 05:23 PM

Hello Hcui,

I was unable to reproduce this issue on my end. I have a couple of questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. What version of the engine are you using?

  2. Can you reproduce this in a clean project?

  3. If so, could you provide a detailed list of steps that you used to reproduce this issue? (The images are very helpful, however I will need to know the steps taken to perform the crash)

avatar image Rudy Q ♦♦ STAFF Jan 29 '15 at 05:23 PM

Hello Hcui,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

avatar image Web Master Aug 06 '15 at 04:58 AM

i have the same problem -_-, i added the main menu with the load level in it but it crashes with crash report or something Using Unreal engine 4, version 4.8

avatar image Rudy Q ♦♦ STAFF Aug 06 '15 at 01:27 PM

Hello Web Master,

I have a few questions for your that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, can you provide a detailed set of steps to reproduce this issue on our end?

  3. Can you provide screen shots of any blueprints that may be involved?

avatar image ultrask14 Jun 11 '16 at 10:11 PM

i am having a similar issue. however my issue involves the map not locating my map. when i press play in normal "play in new window" the map doesnt load. when i use standalone, sometimes it works. when i package the game it says error code 1 exit.

avatar image Rudy Q ♦♦ STAFF Jun 13 '16 at 01:27 PM

Hello ultrask14,

Could you go through and answer the questions that I have asked above? This information would be helpful in narrowing down what issue it is that you are experiencing.

avatar image Alan Kunder Nov 30 '17 at 06:55 PM

even i have the same problem where my game works when i click start in viewport but if i click it in standalone it crashes Please HELP.

avatar image Rudy Q ♦♦ STAFF Nov 30 '17 at 06:59 PM

Hello Alan Kunder,

Could you go through and answer the questions that I have asked above? This information would be helpful in narrowing down what issue it is that you are experiencing.

avatar image Alan Kunder Dec 04 '17 at 11:41 AM

yes i have tried all the scenarios it still crashes on launching in stand alone

avatar image Rudy Q ♦♦ STAFF Dec 04 '17 at 03:10 PM

Could you provide a detailed list of steps to reproduce this issue on our end (Please include screen shots of any settings/blueprints/widgets that may be involved)?

avatar image Alan Kunder Dec 04 '17 at 04:42 PM

i have completed my game and all my widgets work fine even if i package my game has no error or warning but only the main level dosn't open, everytime i try to open it in either standalone or fully packaged it just crashes with no discription I have a start menu in a level which basicly when clciked start it should be connect to the main level but all it does is that it crashes

avatar image Rudy Q ♦♦ STAFF Dec 04 '17 at 11:55 PM

If you are not getting a callstack, you may need to make sure that you have the debugging symbols installed. I have provided an example below. Once that is complete, I will need you to provide the complete callstack (including your machine ID). Could you also tell me what engine version it is that you are using?

Example:

alt text

alt text

avatar image Alan Kunder Dec 05 '17 at 12:46 PM

i am using 4.15.3 PS: currently downloading editor sybols for debugging

avatar image Alan Kunder Dec 08 '17 at 11:36 AM

![alt text][1]

3.png (93.6 kB)
(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

After taking a look at the callstack I was able to find that this is a known issue. I have provided a link to the public tracker. It appears that the issue was closed as won't fix. I have also provided a link to the original post. I hope that this information helps

Link: https://issues.unrealengine.com/issue/UE-24762

Link: https://answers.unrealengine.com/questions/350276/map-crashes-on-load-1.html

Make it a great day

more ▼

answered Dec 08 '17 at 04:08 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image Alan Kunder Dec 08 '17 at 07:20 PM

I don’t understand how do I fix it I am doing a doing this project for a certified course for which I will be getting my diploma after completing

avatar image Rudy Q ♦♦ STAFF Dec 08 '17 at 08:11 PM

From what I found about this issue it appears to be an issue with a directional light. One suggestion would be to use the back up files that are automatically generated in your project's saved folder.

avatar image Alan Kunder Dec 10 '17 at 05:56 PM

alt text

4.png (108.9 kB)
avatar image Alan Kunder Dec 12 '17 at 09:29 PM

I don't find any back up in my saved folders

avatar image Rudy Q ♦♦ STAFF Dec 13 '17 at 01:28 PM

I have provided an example of what the default path should be to get to the folder containing backup files. Is is possible that you have deleted your saved folder recently?

C:\Users\YOUR USER NAME\Documents\Unreal Projects\YOUR PROJECT NAME\Saved\Backup

avatar image Alan Kunder Dec 13 '17 at 04:42 PM

my game got fixed after i deleted all my directional light thank you for your help

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question