Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to Launch or Package Game

Hi there, right now in my project, if I hit Launch, it will begin to cook content, but if I look in the output log, it will endlessly spam the message "LogCook:Display: Failed to find dependency timestamp for"

I left it cooking like this for about an hour, but it was clear that it was hung up. I searched around for a bit, but I can't seem to see this same problem coming up for anyone else

Additionally, when I try and package the game for win 64, it failes, giving me an error: "RunUAT.bat ERROR: AutomationTool was unable to run successfully."

I did find mention of this problem on the answers hub and forum, but none of the listed fixes worked for me. Please let me know if there's any more info I can provide to help get to the bottom of why either of these errors are occuring. Thanks!

Product Version: Not Selected
more ▼

asked Jan 19 '15 at 06:21 AM in Packaging & Deployment

avatar image

105 15 20 23

avatar image B_May Jan 21 '15 at 04:39 AM

Still running into this. Anyone have any idea why my project fails to launch or package?

avatar image [Epic] Gribbs ♦♦ STAFF Jan 21 '15 at 08:48 PM

Howdy BrianMay,

Thank you reporting this error that has been occurring for you. I am going to need a bit more information before I begin to diagnose what may be occurring. Would you be able clarify which version of UE4 you are using when you are seeing this error? Also, is that version a Binary or Source build of the engine?

Are there any build log file that you may be able to attach to this post? Would this happen on a blank template project?

Any additional information would be greatly appreciated.

Thanks and have a great day!

avatar image B_May Jan 21 '15 at 09:05 PM

Hi Sean, thanks for helping me out, I can definitely provide the info you're looking for.

I'm running in 4.7 preview 3, the binary build that's deployed through the launcher. I will include my build logs when I get home and am able to dig through them to find the right ones for you. This problem did not happen when I tried it with a blank project or with any of the example projects.

Thanks! I'll get you more of the logs this evening when I'm home.

avatar image B_May Jan 22 '15 at 03:41 AM

Here is a little more from my output log when I try to package for win 64


Let me know if there are any other specific logs I can dig up for you!

avatar image B_May Jan 23 '15 at 04:59 AM

Does that log give any clues as to what might be going on? Can I gather any more useful info?

avatar image [Epic] Gribbs ♦♦ STAFF Jan 23 '15 at 01:47 PM

Hey Brian,

Thank you for sharing those logs. Looking into them, I am seeing a similar error that some other users have been having. There may be a couple of workarounds to try.

First, Would you be able to test this issue on preview 4?

What version of Visual Studio would you be using? Are you running your project in DevelopmentEditor mode?

Where you seeing this error is the 4.6.1 version of UE4?


avatar image B_May Jan 23 '15 at 04:01 PM

Hey Sean, thanks for getting back to me. I'm not currently using visual studio, this is purely through the editor right now. I can definitely download it and give it a try though. Can I switch to development editor mode without VS?

I'll give preview 4 a shot today. Thanks for that tip!

I had not tried to package in 4.6.1, sorry!

avatar image [Epic] Gribbs ♦♦ STAFF Jan 23 '15 at 07:17 PM

Since you are not using a code project, you are only able to package for Development or Shipping via Project Settings>Packaging. With the 4.7 previews, these are not stable builds so that may be the reason why you are running into errors. If you get the chance, would you be able to test a build on 4.6.1?


avatar image B_May Jan 23 '15 at 07:24 PM

Ok that makes sense, I wasn't sure how that worked. I will give 4.6.1 and 4.7p4 a try tonight! Thanks for your help.

avatar image B_May Jan 25 '15 at 11:53 PM

Hey Sean, sorry for the delay. I've tried 4.7 preview 4, and it still crashes in the same way with the same log.

I tried converting the project back to 4.6.1, but it crashes the editor on load after conversion.

avatar image [Epic] Gribbs ♦♦ STAFF Jan 27 '15 at 02:16 PM

When you were attempting to use 4.6.1, were you using the open a copy option? I would recommend that you open a new project, and then use Window Explorer to transfer over the files that way. Reverse conversion is an issue due to new content attempting to be referenced when the content is non-existent.


avatar image B_May Feb 02 '15 at 01:36 AM

Hey Sean, I went ahead and tried this solution, but the editor crashed every time I tried to do it.

I would copy the files over, then open the project file, and then the content browser would hang at "Discovering Assets" for a few minutes, lagging my machine down, then it would crash. I've uploaded all the crash reports, describing as much.

avatar image [Epic] Gribbs ♦♦ STAFF Feb 02 '15 at 06:27 PM

Would there be any log files generated that may be associated to this crash?

Also, I was able to located the crash reports, so thank you for reporting them.

avatar image B_May Feb 02 '15 at 11:08 PM

I'm not too sure where to look to grab those log files. Where do they get created by default?

avatar image [Epic] Gribbs ♦♦ STAFF Feb 03 '15 at 01:57 PM

If you go into Windows Explorer, where you Unreal Projects are located, and then follow this route: (Project Title)\Saved\Logs. In that location there should be logs file generated from your project.

If there is not, please be sure to let me know as well.


avatar image B_May Feb 03 '15 at 04:16 PM

Hey Sean, I tried to attach the .log and .dmp file to this post, but the file types are not allowed. I've uploaded the .log to pastebin instead: http://pastebin.com/i9N3YiA3

You can grab the .dmp here: https://www.dropbox.com/s/vbpffkqvm43guiz/Dump-723291920.dmp?dl=0

avatar image [Epic] Gribbs ♦♦ STAFF Feb 03 '15 at 11:17 PM

Hey BrianMay,

Just wanted to do one last check in with you before I submit this bug report. Would you be able to test this issue in the new preview 5 build of UE4? There have been numerous bug fixes and I just want to be sure that one of the fixes does not help you with this issue.

Thanks and have a great day!

avatar image B_May Feb 04 '15 at 05:13 PM

Hey Sean, thanks for your help and patience, I really appreciate it.

I just tried with 4.7p5, and it throws the same error. The Output Log from the editor looks identical to the one I originally posted. Sorry!

Thanks for filing the bug, I hope we can get this resolved soon

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey BrianMay,

Thanks again for all of the information asked for previously. JIRA ticket UE-9096 has been entered into our bug database so that the issue may be addressed in a future release.

If ok with you, I would still like to test out your project on 4.6.1 and see if it is possible to package the project. If you would like to, you could share the project with me via a private message in the forums. You can find my page here: https://forums.unrealengine.com/member.php?4890-Sean-Gribbin

Thanks and have a great day!

more ▼

answered Feb 04 '15 at 09:27 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

avatar image B_May Mar 05 '15 at 10:46 PM

Hey Sean, I shot you a copy of the project. Any luck with it? Any progress on this bug? Thanks!

avatar image [Epic] Gribbs ♦♦ STAFF Mar 06 '15 at 12:33 AM

Howdy Brian,

Sorry about the lack of response. I have been looking into your project the past couple of days and have been having packaging issues as well. I am going to look into it again first thing in the morning and, if I hit a build failed once again, I will be putting in a JIRA report.

Thanks for your patience and have a great day!

avatar image B_May Mar 06 '15 at 02:31 AM

Awesome! Thanks Sean!

avatar image [Epic] Gribbs ♦♦ STAFF Mar 06 '15 at 11:18 PM

Hey Brian,

I worked to try to get it to package again and it just wouldn't cooperate. I looked into the bug report and the issue is still open and unresolved. With GDC happening this week, it has been a bit hectic so I would expect this report to be worked on next week. I will be sure to keep you updated.

Thanks for your patience.

avatar image B_May Apr 11 '15 at 01:40 AM

Hey Sean, it's been a couple weeks. Any movement on this? I'm still unable to package the game, but for some reason now I can launch it at least.

avatar image [Epic] Gribbs ♦♦ STAFF Apr 13 '15 at 01:23 PM

Hey BrianMay,

Thank you for your patience. I have just tested your project on the latest internal build and was able to package with no errors. I am unsure as to when this build, or a later build, will be released, but I was able to package for Win 64-bit. I will be sure to keep you posted when I am certain that this fix has been implemented.

Thanks again!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question