x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7 p3 / source] Blueprints causing Crash on Load

I am using a relatively large BP project see ( https://forums.unrealengine.com/showthread.php?53208-MMO-Starter-Kit ) .

[version unaffected] - no compile errors

  • 4.6.1

[versions affected]

  1. p2

  1. p3

  1. latest source as of (1/18/2015)

  • Promoted (1/18/15)

  • Master (1/18/2015)

All give the following error , i'm trying to better debug to see which of the blueprints is causing it (probably caused by a BP casting somewhere)

http://pastebin.com/qgkrbvNU

I've tried debugging the editor, after the editor breaks, trying to figure out which node is causing it, but the heirarchy is pretty complex.

Product Version: Not Selected
Tags:
more ▼

asked Jan 19 '15 at 06:02 PM in Bug Reports

avatar image

KRushin
176 4 10 11

avatar image Adam Davis STAFF Jan 19 '15 at 06:59 PM

Are you receiving any specific errors when it crashes? Additionally can you post your crash logs located at \Unreal Projects\PROJECTNAME\saved\logs\?

avatar image KRushin Jan 19 '15 at 08:37 PM

Here is the log file (from 4.7 p3 source) http://pastebin.com/YQ5RLuBW

Here is the dmp file if it helps https://www.dropbox.com/s/r6ft7ovm01dbo0l/Dump-1567798640.dmp?dl=0

avatar image Adam Davis STAFF Jan 19 '15 at 09:12 PM

Does the editor have any output errors that you receive before it crashes? For instance are you getting any "access 'None'" errors?

avatar image KRushin Jan 19 '15 at 09:32 PM

No errors in 4.6.1, The editor won't load the project at all (it crashes at ~93%)

avatar image KRushin Jan 19 '15 at 09:35 PM

[2015.01.19-21.33.34:968][ 0]LogBlueprint:Error: [compiler] Error The function in node Event Receive Condition Check cannot be overridden and/or placed as event

[2015.01.19-21.33.34:969][ 0]LogBlueprint:Warning: [compiler] Warning Could not find a function named "FinishConditionCheck" in 'NotCloseEnoughYet_C'. Make sure 'NotCloseEnoughYet_C' has been compiled for Finish Condition Check

[2015.01.19-21.33.34:970][ 0]LogBlueprint:Warning: [compiler] Warning Could not find a function named "FinishConditionCheck" in 'NotCloseEnoughYet_C'. Make sure 'NotCloseEnoughYet_C' has been compiled for Finish Condition Check

[2015.01.19-21.33.34:974][ 0]LogBlueprint:Error: [compiler] Error Cannot override 'BTDecorator_BlueprintBase::ReceiveConditionCheck' at Event Receive Condition Check which was declared in a parent with a different signature

[2015.01.19-21.33.34:984][ 0]LogBlueprint:Warning: [compiler] Warning [0077.30] Compile of NotCloseEnoughYet failed. 2 Fatal Issue(s) 2 Warning(s) [in 31 ms] Application "\??\D:\UnrealEngine 4.7\Engine\Binaries\Win64\ShaderCompileWorker.exe" found in cache Assertion failed: Pin != nullptr [File:D:\UnrealEngine 4.7\Engine\Source\Editor\BlueprintGraph\Private\K2Node_DynamicCast.cpp] [Line: 201]

Looking to see which node is causing the problem though so i can maybe get something more reproducible

avatar image Adam Davis STAFF Jan 19 '15 at 09:35 PM

Try removing your folders containing blueprints out of the editor to open it. Then start adding these folders back into their correct filepath until the crash occurs. It looks like a casting crash that isn't finding a specific blueprint that it is trying to access.

avatar image KRushin Jan 20 '15 at 12:25 AM

I found that part of the error log that was caused by significant changes in BTDecoratorBlueprintbase http://i.imgur.com/JznK4U3.jpg

I created a blank project and just did this section of the code and converted to 4.7 (I fixed the BP and migrated to project)

http://i.imgur.com/Uonb8gI.jpg

I have since found where it was coming from (a single BP), traversing the BP to find which cast is causing it

avatar image KRushin Jan 21 '15 at 02:55 PM

Hey adam, I think i found the issue / another (unrelated bug?). Meant to post it here but its down below.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Sounds like it's my bad. I didn't take enough precaution to shield BP users from the massive BP-implemented BT decorators fix. I'm on it, should be in before you learn to say "Grzegorz Brzęczyszczykiewicz, Chrząszczyże-Woszyce, powiat Łękołody" ;)

Cheers,

--mieszko

more ▼

answered Jan 20 '15 at 10:08 AM

avatar image

MieszkoZ STAFF
7.3k 225 57 413

avatar image KRushin Jan 21 '15 at 06:58 AM

Thanks Mieszkoz!

I get a nice deprecated warning so that will be helpful for others!

I think i've tracked it down to a bug with Blueprint Macro Libraries. The original crash seems to all come down to my Custom Game Instance. I am using a macro that basicaly just gets the game instance, and cast to my custom game instance. Here are the two (seperate bugs?) .

  1. [Unrelated ?]Can't Create a NEW [Actor] Macro library (instant editor crash) in 4.7 p4

  2. I had a BP-Object macro library. Throughout my project, I want to get a reference to my custom game instance so i made a macro. In 4.6.1 http://i.imgur.com/R0WrZNu.jpg it looks like this. You can't do this in 4.7 ? Context bug?

How i fixed it:

  1. Create a blank new BP Object Macro Library in 4.6.1, create a very basic BP so that i can get a "get game instance" node (since i can't add in 4.7?) http://i.imgur.com/2rVBKgx.jpg

  2. Migrated it to my 4.7 project, changed the basic macro (from above) into one that looked like the original.

I have no idea if the old macro library became corrupted? Circular dependency?

I still have a few random small errors/not working as intended bugs, but that comes with every new big release.

The project runs, and is 97% working like it was so thats good :) but its strange, if the blueprint teams wants, i can forward a copy of the project (from 4.6.1) so they can better investigate.

avatar image Adam Davis STAFF Jan 21 '15 at 05:02 PM

Hi KRushin,

Did you happen to change the name of the macro from the original name? There seems to be a potential bug with macros that is preventing the macro from being accessed if it is not the original name given to the macro library. For instance, if it was created and called "NewMacro_0" but immediately renamed to "TestMacro". The macro would not be called unless you used "NewMacro_0". I have entered a bug report for this as UE-7948. Can you check to see if this helps with your crash?

avatar image KRushin Jan 21 '15 at 06:17 PM

As far as the original problem it doesn't to fix it.

Are we still suppose to be able to Get Game Instance in Macros in 4.7 (cause can't anymore)?

avatar image Adam Davis STAFF Jan 22 '15 at 09:15 PM

Hi KRushin,

Can you post a screenshot of your macro calling the game instance? I might be able to see what is going on with that.

avatar image KRushin Jan 22 '15 at 11:26 PM

This is all the macro is http://i.imgur.com/R0WrZNu.jpg . So its very simple (I call it throughout my blueprints (character, player controller, etc...)

I can't call "get game instance" in 4.7? so it being valid (in 4.6.1) then migrated might be causing the crash?

To fix my crash, i just disconnect/don't use the macro

Before (crash) http://i.imgur.com/R0WrZNu.jpg

After (no crash) http://i.imgur.com/MaPYvCd.png

avatar image KRushin Jan 25 '15 at 02:03 AM

Fixed.

I'm in process of creating a simple example that makes it reproducible. But either way the editor not failing safely.

http://i.imgur.com/SGqreN1.png

avatar image Adam Davis STAFF Jan 26 '15 at 05:24 PM

Hi KRushin,

I just want to make sure I am on the same page. These are the steps to take to reproduce the crash you are experiencing:

  1. Open Editor in 4.6.1

  2. Create new macro library

  3. Create new macro inside library

  4. Cast to game instance as in your picture labeled "Before"

  5. Compile, save, close library

  6. Call this macro in some other blueprint, compile save close.

  7. Add copy of blueprint to level, save and close editor.

  8. Update project to 4.7. Attempt to open project

At this point the editor should crash. Are there any steps that I am missing or do not need to take in the above list?

avatar image Marek Mar 02 '15 at 05:06 PM

Is there any updated regarding this issue? I'm getting crash on startup with very similar macro library as KRushin's example. Once I delete the library the editor runs but I'll have to fix all other blueprints using anything from that macro library.

avatar image Adam Davis STAFF Mar 02 '15 at 08:21 PM

Hi Marek,

Are the steps I provided above the steps you are taking that cause the editor to crash? Can you post your logs here so we can take a look?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question