x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Are timers different in 4.6 and 4.7?

I originaly made my game in 4.5 but since I switched to 4.6 and up (I am now using 4.7) one of my timer node stopped working. The function I am trying to call is named Cast Frostbolt and it should be called after 1.6 seconds according to the timer, however nothing seems to happen when I do. It used to work just fine though in 4.5. When I call the function directly it also works so the Cast Frostbolt function itself is not the problem. Here's a screenshot of my little timer.

http://i.imgur.com/utwKCyO.jpg

Am I missing something?

Edit: I found what the issue was. It had to do with the name of the function having a space in it. I tried just changing the name of Cast Frostbolt to just Frostbolt and it worked.

Product Version: Not Selected
Tags:
more ▼

asked Jan 19 '15 at 07:48 PM in Blueprint Scripting

avatar image

timetravel
78 27 28 37

avatar image Jacky Jan 19 '15 at 09:47 PM

Try CastFrostbolt without space instead of Cast Frostbolt and see if it works now.

avatar image Pierdek Jan 19 '15 at 10:08 PM

Put something to Object -> Reference to self. You can also put

 [Core.Log]
 LogBlueprintUserMessages=VeryVerbose

In DefaultEngine.ini in your game module to check in Output window or logs if everything is fine.

avatar image timetravel Jan 19 '15 at 10:43 PM

Putting a Reference to self for the timer did not work either. This is what I tried:

http://i.imgur.com/et2kiMu.png

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

The problem was the spaces and I guess the general formatting. I tried changing the name of the function to simply "frostbolt" and it worked.

more ▼

answered Jan 19 '15 at 09:55 PM

avatar image

timetravel
78 27 28 37

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question