x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

DUMPMOVIE + BENCHMARK missing frames

Evening,

I am running Unreal Engine 4.6. I have packaged a project for development to render some simulations. I am attempting to use DUMPMOVIE and BENCHMARK to render high quality scenes, but Unreal seems to ignore the benchmark command and generates inconsistent frame counts for different resolutions. My specific command is:

MyGame.exe MyScene -ResX=2048 -ResY=1152 -BENCHMARK -FPS=25 -DUMPMOVIE

This generates ~ 201 frames for an ~12 second scene (short 99 frames).

MyGame.exe MyScene -ResX=640 -ResY=480 -BENCHMARK -FPS=25 -DUMPMOVIE

This generates 295 frames for the scene (which I believe is the actual count).

MyGame.exe MyScene -ResX=2048 -ResY=1152 -BENCHMARK -FPS=25 -DUMPMOVIE

For some reason this only created 151 frames for the same scene.

Am I doing something wrong?

Other specs: Win 7 x64, 24gb ram, 6 cor i7 @3.30 Ghz, NVIDIA GeForce GTX 580

Product Version: Not Selected
Tags:
more ▼

asked Jan 20 '15 at 05:33 AM in Rendering

avatar image

fishhead2567
106 2 72 13

avatar image CognizanCe Apr 03 '15 at 05:00 PM

Same problem I guess. -FULLSCREEN -ResX=1920 -ResY=1080 -DUMPMOVIE -BENCHMARK -FPS=30 -SECONDS=20 Only gives 121-145 frames. Supposed to be 600.

avatar image rotoslinger Oct 09 '15 at 12:45 AM

Same problem. Has anyone figured this out yet?

I've noticed that the -RESX and -RESY flags effect frame rate much more than the -FPS flag. The lower the resolution the higher the frame rate and the higher the number of output images regardless of the -FPS value.

In fact the -FPS flag doesn't seem to do anything for me

At the same resolution a -DUMPMOVIE -BENCHMARK -FPS 30 renders out roughly the same number of frames as a -DUMPMOVIE -BENCHMARK -FPS 60, though sometimes I get a few extra frames.

I've tried changing the Framerate settings (bSmoothFrameRate, bUseFixedFrameRate, bFixedFrameRate) and I never get consistent results.

Are the -BENCHMARK and -FPS command line flags supposed to work with default Project Settings or do we need to change something to get these to work?

I am working on a project that is relying on this feature to work, could someone please help?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I ended up using a work around.

Rather than using the -FPS flag I turned on UseFixedFrameRate in the engine settings, and set my fixed frame rate to 30. Now I am getting a consistent number of images in my screenshots directory. This number of screenshots when converted into a .mov file is the proper duration (the exact length of my Matinee).

WARNING: UseFixedFrameRate will cause an inconsistent framerate in game. Everything looks like it is rendering double speed for me. The trick is to only load the settings when you want to DUMPMOVIE. You can do this by making a separate .ini file and only loading that from the command line when you start your game with the -DEFENGINEINI flag

this is what the contents of the Custom.ini file looks like:

[/Script/Engine.Engine]

bUseFixedFrameRate=True

FixedFrameRate=30.000000

bSmoothFrameRate=False

And the -DEFENGINEINI flag should look something like this:

-DEFENGINEINI=C:\Users\jdoe\Desktop\WindowsNoEditor\packageConfig\Custom.ini

more ▼

answered Oct 16 '15 at 10:59 PM

avatar image

rotoslinger
76 1 5 9

avatar image Trent_WP Jan 07 '16 at 07:47 PM

I have the same problem. I have tried the custom.ini solution and it is not working for me and causes black frames to be dumped when using it as a exe flag and says it can not find the file when using it as a console command at runtime. Are these any other solutions to this?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question