x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't disable version control

Hello, I wanted to disable version control in a project, and followed "Deactivating Source Control" section here https://docs.unrealengine.com/latest/INT/Engine/UI/SourceControl/index.html

However, every time I try to save an asset, for example a blueprint, it asks me to check out or make the asset writeable. I can make the asset writeable, but I need to do this for each file now. How to fix this? I unchecked "Prompt for checkout on asset modification" in editor settings but it didn't help.

Product Version: Not Selected
Tags:
more ▼

asked Jan 20 '15 at 09:22 AM in Using UE4

avatar image

CodeSpartan
266 12 111 34

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hi

Did you have source control (specifically Perforce) enabled previously? If so then it will likely have left your files all marked as 'read-only'. This is probably why you are seeing messages that ask you to make the asset writable.

more ▼

answered Jan 20 '15 at 10:02 AM

avatar image

Tom Sarkanen STAFF
1.7k 39 12 53

avatar image CodeSpartan Jan 21 '15 at 07:19 AM

I unchecked read-only on the files in Windows and it worked, thanks!

avatar image stabbedbyapanda Feb 09 '19 at 03:05 AM

To clarify, what they mean is go to the the project folder> Right click> Properties> Uncheck Read- Only. It will ask if you are sure, hit yes, then apply and ok. This will runs a loading bar to set everything back from read only.

This issue also causes an error of being unable to rename a file until it's writeable. Once read only is unchecked you can rename all your files again. Hope this clarification helps, as the above answer wasn't fully clear and precise, imo.

(comments are locked)
10|2000 characters needed characters left

there is no such a thing as disabling version control. it is against the whole idea :) every version control uses a hidden folder to keep the connection and track changes which is knows as the repo, by deleting that you automatically solve your problem. for example for git it is ".git" and you have to do it in the file browser of your OS and not in UE4

more ▼

answered Feb 09 '19 at 11:33 AM

avatar image

plangton
347 17 20 31

avatar image stabbedbyapanda Feb 11 '19 at 09:36 AM

i think you misunderstood the issue look at my response above.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question