Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Couldn't Start "../UE4Game-Win32-Shipping.exe" .Uproject

I release my demo last Sunday and there as been a rare instance where a user experiences a "Couldn't Start" error message. Attached is a screenshot from one of the bug reports submitted to me. This bug has been experienced by 3 out of 1,261 users. I'm posting here since the error was able to be reproduced 100% of the time by these users even after re-downloading from the mirrors I supplied to my fan base.

The demo was packaged as shipping in 32 bit windows. The assets are packed into .pak files. No additional settings out of the ordinary were used besides the defaults.

The game was packaged in Unreal 4.7.

If there is a solution I can execute to the audience without Unreal support, i'd be grateful. Else, if its an engine issue, i'll have to issue a statement regarding a delay on a fix for them. Thanks!

alt text

 "Error Couldn't Start:  
  "C:/Documents and settings/*username*/Desktop/NaughtyShinobiv0001/Engine/Binaries/Win32/UE4Game-Win32-Shipping.exe"
 CreateProcess() returned c1."
Product Version: Not Selected
more ▼

asked Jan 21 '15 at 09:54 PM in Bug Reports

avatar image

59 9 12 16

avatar image [Epic] Gribbs ♦♦ STAFF Jan 22 '15 at 03:26 PM

Howdy sbnewsom,

Thank you for reporting this issue. I have looked into what may be happening and have come up with 2 possible solutions.

The first could be that, when you are sharing your project, when the users are downloading, their antivirus software may be causing an issue when downloading your game. I would have them try to downloaded it without having their antivirus on if possible.

Also, I found a user with a similar error here: http://stackoverflow.com/questions/7003981/createprocess-fails-under-windows-7 .

Let me know if this is helpful with the errors. It may also be a hardware issue, so if the problem remains after trying these steps, would there be a way to get their DXdiags?

Any additional information would be greatly appreciated.

Thanks and have a great day!

avatar image [Epic] Gribbs ♦♦ STAFF Jan 26 '15 at 04:34 PM

Hey sbnewsom,

Just wanted to check in with you and see if these workaround have been helpful for the users testing your project? Please be sure to let me know so that I may be able to assist you further. Thanks and have a great day!


avatar image sbnewsom Jan 28 '15 at 08:37 AM

From what I understand they haven't been able to fix the issue. Here is their DxDiag for reference though. I can't make heads or tails. link text

dxdiag.txt (40.8 kB)
avatar image [Epic] Gribbs ♦♦ STAFF Jan 28 '15 at 04:15 PM

Hey sbnewsom,

Thank you for providing the DXdiag from one of your users. I have looked into the specs of the GPU and CPU, and they are significantly lower then what is recommend to run any games from UE4. I have provided some links to show you were the GPU and the CPU rank among what we recommend.

GPU (user): http://www.videocardbenchmark.net/gpu.php?gpu=Intel+82945G+Express GPU (recommended): http://www.videocardbenchmark.net/gpu.php?gpu=GeForce+GTX+470

CPU (user): http://www.cpubenchmark.net/cpu.php?cpu=Intel+Core2+Duo+E7200+%40+2.53GHz CPU (recommended): http://www.cpubenchmark.net/cpu_lookup.php?cpu=Intel+Core2+Quad+Q8300+%40+2.50GHz

I also noticed that the RAM is at 2 GB. The recommended is 8 GB for the Engine.

Though this is the minimum recommended for running the editor, having specs that are significantly under this is going to cause errors.

If you can, would the other 2 users with this similar issue be able to provide a DXdiag? This would be the best way to compare the errors that they are all coming across.

Please let me know if you have any additional questions


avatar image sbnewsom Jan 30 '15 at 04:47 AM

I was able to get one other DXDiag. From the looks of this user's log, they meet system requirements. Although i'm unsure if your engine supports the Intel HD Graphics Family even if it supports DX11. Never worked with that sort of hardware.

Let me know what you think.

link text

dxdiag.txt (88.9 kB)
avatar image [Epic] Gribbs ♦♦ STAFF Feb 02 '15 at 04:27 PM

I am still seeing that the graphics card that they are both using is well below the recommended:

GPU benchmark: http://www.videocardbenchmark.net/gpu.php?gpu=Intel+HD+4000

Looking at the ratings of this card compared to our recommended, I believe that is safe to say that we do not support a card with that low of a rating. I am not saying that the card will not work with your project, but they may find difficulties when attempting to play your project.

As for the HD Graphics Family, it is not that we do not support those cards, but we do highly recommend an upgrade.


avatar image [Epic] Gribbs ♦♦ STAFF Feb 06 '15 at 08:36 PM

Howdy sbnewsom,

Just wanted to check in with you and see if you had a chance to test something with those users. Would you be able to send them a packaged project using the new preview build? There have been many bug fixes from Preview 4 to 5. I doubt this may fix the error, as I believe the error is lies in there Graphics cards.

Let me know how that goes if they happened to get the project to run.

Thanks and have a great day!

avatar image sbnewsom Feb 06 '15 at 08:37 PM

Yeah, just did the upgrade today. I'll send it out to the users and see how it works.

I really appreciate the help you and your team do. :) Thanks.

avatar image [Epic] Gribbs ♦♦ STAFF Feb 13 '15 at 07:23 PM

Howdy sbnewsom,

Just wanted to check in with you and see if this issue has been resolved with the update of the engine. Please be sure to let me know so that I may further investigate or close out this issue.


avatar image Stormrage256 Apr 18 '15 at 02:04 PM

Just wanted to let you know that this issue is still there if Avast antivirus is running in the background. When it's turned off, it's working well. Is there any way to make it more friendlier to the user? At the moment, it looks like the game is sending some crash report as soon as you launch it.

avatar image [Epic] Gribbs ♦♦ STAFF Apr 20 '15 at 07:21 PM

Hey Stormrage,

Thank you for posting on this issue. What version of UE4 would you be using and is that version a Binary or Source build? Would you be able to capture an image of the Antivirus notification that shows from UE4?


avatar image Stormrage256 Apr 22 '15 at 09:49 AM

Hi Sean, I'm using v 4.7.6. It's a pure blueprint project and I'm not using the source build. However I do want to point out that the game starts after a while even though this message appears. But at first glance, a new user would think that the game has crashed. Also, it only appears during the first launch after packaging the game. I did not see this issue in subsequent launches. However it pops up again once if I move the project to a different folder.


Oh and mine is a 64 bit packaging. I posted here, since the pop up window details were the same.

avatar image [Epic] Gribbs ♦♦ STAFF Apr 22 '15 at 09:17 PM

Hey Stormrage,

Thank you for the additional information and screenshot. Are you able to replicate this issue on a blank template project? Just want to be sure that we cover all bases of why this may be occurring.


avatar image Stormrage256 Apr 27 '15 at 04:59 PM

Hi Sean, sorry for the delay. I have tested it in a packaged [development] blank blueprint project in v4.7.6. I'm getting the same pop up window during the first launch.

avatar image wittlief ♦♦ STAFF May 04 '15 at 08:28 PM

Hi Stormrage,

Were you able to locate your build logs for this project, and if so can you add them to this thread as a .txt file?

avatar image [Epic] Gribbs ♦♦ STAFF Apr 29 '15 at 02:23 PM

Hi Stormrage,

Would you be able to attach your build log files to the post? I would like to check and see if any errors are produced with having Avast open.


avatar image Stormrage256 May 05 '15 at 03:28 AM

Could you tell me where I can find the build log files?

avatar image sbnewsom May 05 '15 at 03:31 AM

The build log is stored in (Your Project Folder)/Saved/Logs.

The file should be (ProjectName).log Make sure to provide the most recent (date modified) log file for Sean.

avatar image Stormrage256 May 05 '15 at 05:50 AM

Thanks, got it.

avatar image Stormrage256 May 05 '15 at 05:51 AM

Here are the log files you asked for: link text

myproject4.log (18.9 kB)
avatar image wittlief ♦♦ STAFF May 11 '15 at 09:35 PM

HI Stormrage256,

What I'm seeing now in your logs is this error:

ModuleManager: Module 'GameplayDebugger' not found - its StaticallyLinkedModuleInitializers function is null.

Here is another AnswerHub thread wherein a user was experiencing a similar issue (his was Mac, however), and it was determined to be a known issue (UE-13075), which should be integrated into the upcoming 4.8 update.

In the meantime, you have to either rebuild UBT or run GenerateProjectFiles .bat (which should be in your UE4 folder) files after modifying build.cs files.

These could all be unrelated to your main issue, but it is worth a look.

avatar image Stormrage256 May 12 '15 at 03:42 AM

Thanks wittlief, I will keep checking in the 4.8 preview updates. If it gets rectified, I'll post it here.

avatar image wittlief ♦♦ STAFF May 28 '15 at 02:24 PM

Hi Stormrage256,

Just to update this issue, it looks like the fix for UE-13075 was integrated and should have made it into the 4.8 preview 4, released yesterday, if you'd like to try. If you do open your project in the update, be sure to make a copy, do not convert, conversion can sometimes do unpleasant things to blueprints.

Hope this helps!

avatar image Stormrage256 Jun 08 '15 at 04:07 AM

Hi wittlief,

I've tested it out in both native v4.8 p4 projects as well v4.7.6 projects opened in v4.8 p4. Unfortunately in both cases, I'm experiencing the same issue for the first time I package a game into a new folder.

If I delete the packaged game contents inside a folder (A) and then repackage the same or different game into the said folder (A), everything's fine. But if I create a new separate folder (B) and then package to that folder (B), the pop up window comes again for the first time.

avatar image wittlief ♦♦ STAFF Jun 08 '15 at 08:15 PM

Hi Stormrage256,

Have you tried adding UE4 to your Avast application whitelist? I assume there is such a thing, I am not overly familiar with Avast, but that is still what is causing this problem, yes?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey wittlief, I was having the same problem as Stormrage using 4.8.2. I am also running Avast. I put the packaged game into a new folder, whitelisted that folder in Avast, and ran the game for the first time and I did not get the error.

For anyone else, open the Avast user interface, go to Settings > General > scroll down till you see Exclusions > then add your folder there.

I've had problems with Avast and UE4 in the past. I also had to add exclusions for the entire engine directory and my projects directory.

more ▼

answered Jul 25 '15 at 09:32 PM

avatar image

554 59 164 125

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey sbnewsom,

I am going to mark this issue as being resolved for tracking purposes but if you see this issue happen for more users, please feel free to reopen this issue so that I may be able to further investigate. Let me know if any additional information is needed.

Thanks and have a great day!

more ▼

answered Feb 23 '15 at 09:32 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question