x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to save to Android

I have found some other threads on this issue, but none of them seem to resolve it.

I have set up my blueprint to save the player's top score. It works fine when I test it in the editor. A .sav file is automatically created in the correct directory and I am able to recall the data stored in it successfully.

However, when I package the game and install it on my Moto G using the .bat file, it does not seem to save or load the data. Looking through the directories on the phone, I am unable to find a .sav file. But I am unaware as to how the file is stored on Android (I cannot find any documentation on this).

Both my Slot Name and User Index are set beforehand, and like I said, it works fine when I test it in the editor.

I'm wondering if it has anything to do with the Android manifest, but it seems that the manifest that Unreal creates is adequate.

And ideas as to possible causes?

Product Version: Not Selected
Tags:
more ▼

asked Jan 22 '15 at 07:16 AM in Blueprint Scripting

avatar image

BlockyDK
51 2 4 13

avatar image MarinN Jan 22 '15 at 10:44 AM

Can you post a screenshot of the Blueprint?

avatar image BlockyDK Jan 22 '15 at 05:30 PM

The first two screenshots show how the data is being saved. It is located in my player class.

The second two show how it is being called, which is in the level blueprint.

Both the Slot Name and the User Index are default values in the savegame blueprint, which is called savescore.

It seems like the cast is failing, but I am not sure why because it works fine in the Editor. It is almost as though it can't write to the android device. alt text alt text alt text alt text

avatar image BlockyDK Feb 03 '15 at 01:11 AM

bump. I recently heard that there were new security features in android 4.4 (which my phone runs) that cause problems when saving to internal storage. I'm still doing research, but it could be the possible root of the problem.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

It seems I solved it myself. I had followed the documentation, but not realizing that doing so was causing me to save a blank save file every time I started the game. I fixed it by checking for a save first and running that through a branch to either load or create the save file.

more ▼

answered Feb 03 '15 at 02:07 AM

avatar image

BlockyDK
51 2 4 13

avatar image Fahooosh May 24 '15 at 07:21 PM

Can you post a screenshot of the your new Blueprint?

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question