x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Post Process Effect stop working

Somehow after getting project from my colleague, post process volume that he set it up has stop working. I also tried to create a new scene and add post process volume but it doesn't work. Is there some setting that got messed up after getting the project?. I am using 4.5.1

Thanks,

Product Version: Not Selected
Tags:
more ▼

asked Jan 22 '15 at 07:12 PM in Rendering

avatar image

Shantaram
91 12 21 27

avatar image PightyMo Feb 03 '15 at 03:10 PM

Hey,

i've got the same problem. Are there any new informations about how to fix the bug?

Best regards, Pighty.

avatar image Tim Hobson ♦♦ STAFF Feb 03 '15 at 06:40 PM

Hi PightyMo,

Did you read through any of the information below, If so, did you try any of the steps below as well, as this would be my troubleshooting process.

Can you post a copy of your DxDiag? This was something I didn't ask Shantaram though, if willing I'd be curious with that one as well.

There may be a correlation here that I could have our Compatibility team look into. With the test maps and images provided I was not able to reproduce the error on my end.

Shantaram provided a test project that this is happening with as well. I've got time to start looking into this one a little more this week, and since opening it I can see the test project it is not functioning properly. I have no idea why at the moment and will need to investigate further.

If you have any way of recreating the issue in a more consistent basis I'm definitely interested or even just clues to what happened right before it stopped working.

Right now, the work around seems to be to migrate content to a new project. Not the best solution at the moment though.

avatar image Tim Hobson ♦♦ STAFF Feb 03 '15 at 07:27 PM

@Shantaram: I've opened the project, but I'm not able to locate the issue thus far. I'm still trying to track down the issue, but without being able to upgrade the project to 4.6 and see if I can get things to resolve. I know there were some code changes that need to be handled for code projects for the upgrade to function properly. I know you mentioned this did not work for you though.

Still investigating though. :/

avatar image Shantaram Feb 03 '15 at 07:39 PM

Thanks for looking into it. I really appreciate it.

avatar image PightyMo Feb 04 '15 at 09:42 AM

Hey Tim,

thanks for your upcoming help. Maybe it has nothing to do with the problem, but the error only occurs in our project after we started using Matinee. I've fixed the problem a few weeks ago by migrating all data in a blank new project. Now 3 weeks later it occurs again. We are also work with perforce, but deleting the saved and intermediate folders didnt help us out.

DxDiag: https://dl.dropboxusercontent.com/u/13719013/DxDiag.txt

avatar image PightyMo Feb 06 '15 at 02:11 PM

Hey,

i've got some more informations:

I have migrated our project into a complete new project. After that all post process effects begin to work again and we've started rendering our trailer. After finishing that (2 hours ago) i've switched to another map, on which we have placed all gameplay elements. Then suddenly the post-process effects stopped working again. :( I didn't have tweaked any graphical or performance options, just switched the map.

avatar image Tim Hobson ♦♦ STAFF Feb 06 '15 at 10:50 PM

If you have the time, you would be able to test migrating just the maps to a new project and switching between them to see if that can reproduce the issue for you? If that's the case I would be very interested in a copy of this project to test as well without all the assets. I posted below submitting Shantarams project with UE-9366. I could always attach anything else to this ticket to help the engineer better look into the issue.

Thanks! :)

avatar image Rodesqa Jul 19 '15 at 04:54 PM

My Post process just show a solid texture....even if i just put a texture in the material editor set up the post process like in the documentation, and hook up just the texture to the Emissive input it just shows solid. What am i doing wrong?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Why some Postprocess might not show up:

  • User changes showflags and the state was saved causing confusion. (Set showflags to default in editor UI)

  • Scalability settings are on low/med/high, not epic (Editor might auto apply if performance is low, look for UI)

  • Project settings can refine some default post procses like bloom check the (project settings)

  • Othographic=non perspective viewports can have a limited feature set

  • Editor might run in mobile emulation

  • PostProcess volume setting is wrong (look for Unbound, Enable, Weight, checkbox in front of the setting)

  • PostProcess volume priority supressed the settings (delete other volumes, use a larger the priority)

  • Blueprint overrides some settings

  • Camera override some post process settings (cameras can have settings and have priority)

  • SceneCapture can complicate things (e.g. captureing HDR will not show postprocess)

  • In Shipping/Test we compile out some shaders/features, some viewmodes or showflags might not show the expected results

  • Sometimes we rename feature properties, which can cause if not picking up the old values. If the meaning changes we don't want to maintain the old value. This can cause confusion with Matinee. If that happens you should see a log printout/warning/error.

That should help to identify the issue - if this is still a bug we would like to know the details, please mention that you verified it's not one of the points above.

more ▼

answered Mar 04 '15 at 06:23 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

this happened to me as well. checked a few different threads with similar issues to this, and it turns out, if you enable mobile HDR, save your level, close project, delete intermediate and saved folders in the project directory, and restart project, post process is back working as intended. i'm not developing a mobile project, and have my ini's set to desktop and maximum graphic settings (and epic scalability) so not sure why mobile hdr would effect this. this was in 4.12.2.

more ▼

answered Jun 17 '16 at 02:10 PM

avatar image

paradoc
1.2k 49 31 86

avatar image Numbat Aug 18 '16 at 07:58 AM

Thanks Paradoc!

avatar image Rael5 Oct 30 '16 at 05:44 PM

This happened to me as well. I didn't have to delete any folders though, but it required restarting the editor. I didn't notice until I restarted the editor hours later when my post process randomly stopped working. There's definitely issues with this option.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi Shantaram,

The first thing I would look at would be the Engine Scalability settings to make sure that these are set to EPIC. If it is not the post processing will be disabled. This feature enables the editor to run on lower end PCs or if the CPU load is too much it can lower the settings in the editor to free that up some.

To check the status of the Engine Scalability settings go to your tool bar above the viewport > Settings > Engine Scalability > here set the option to EPIC.

Let me know if that works for you.

Tim

more ▼

answered Jan 22 '15 at 08:43 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image Shantaram Jan 22 '15 at 08:48 PM

It is set to Epic and it still doesn't work.

THanks,

avatar image Shantaram Jan 22 '15 at 08:52 PM

Just wanted to add that its a perforce project so is there some file that needs to be checkout to make it work.

Thanks,

avatar image Tim Hobson ♦♦ STAFF Jan 22 '15 at 09:15 PM

Post processing should be there if you have the editor and the project is loading up.

Can you try selecting the PPV and scroll to the bottom of the details panel and select "Unbound." This will make it so that everything is affected by the volume and not just what's inside it.

If that doesn't work, let's make sure this isn't just project related by creating a new project. That is if you've not done this already.

My typical test for quickly checking post process:

  • Create New blank Project - no starter content or anything else required

  • Use the default level

  • Place a PPV and set it to unbound with Bloom and Lens Flare with intensity cranked to full

  • Adjust the camera and look at the Sun directional light

At this point you should have what looks like a J.J. Abrams movie going on. If not, there is something going on that may require a reinstall of the editor or something else that I'm not fully sure about at the moment.

If it is working, then at least we know it's something with the project that we can take a look more closely and try to determine what is causing the issue. :)

Let me know.

Tim

avatar image Shantaram Jan 22 '15 at 09:18 PM

I did tried those steps and it is something with the particular project that I am working on. It is working on the other projects.

Thanks,

avatar image Tim Hobson ♦♦ STAFF Jan 22 '15 at 09:29 PM

Hmm...That's strange. :/

If you create a new level in this project are you able to get PPV to work properly? I guess then we can narrow it down to that individual level.

If you're able to narrow it down to that level would you mind sharing that map file? It won't contain all your other content, but maybe there is something corrupted with it that I can at least try and figure out a workaround for you.

avatar image Shantaram Jan 22 '15 at 09:39 PM

Thanks for help, I really appreciate it. It doesn't work in the new level that I create also. How do you I share the map? Should I just upload the map file here or do I have to migrate or export it?

Thanks

avatar image Tim Hobson ♦♦ STAFF Jan 22 '15 at 09:45 PM

You can upload the map here is you'd like in a zip file (as long as it's below 5.2 mb), if it's above that you'll need to use a link for a shared cloud drive like Google Drive, DropBox, or OneDrive.

If you don't want to post it here you can always send it privately via a PM to me on the Forum via this link: https://forums.unrealengine.com/private.php?do=newpm&u=4894

As far as the content. If you migrate the map it will grab any material or assets associated with that map to send as well. If you're comfortable with that that is fine. Alternatively, you can just grab the map file in question from the projects folder and just send the MapInQuestion.umap file.

avatar image Shantaram Jan 22 '15 at 09:50 PM

link text

Its just a blank scene with post process volume set to unbound and tint color change to red.

Thanks,

mapinquestion.zip (344.1 kB)
avatar image Tim Hobson ♦♦ STAFF Jan 22 '15 at 10:21 PM

I've had a look at the map, and everything the post process is definitely made it a bright red scene.

So, this map isn't producing this on your end? Just to be clear.

avatar image Shantaram Jan 22 '15 at 10:23 PM

Nope. Its not working on my side. alt text

Thanks,

postprocesstest.png (622.9 kB)
avatar image Tim Hobson ♦♦ STAFF Jan 22 '15 at 10:29 PM

Which version of the engine are you currently using?

avatar image Shantaram Jan 22 '15 at 10:31 PM

4.5.1 and I also tried to upgrade the project to 4.6 and still it didn't work.

THanks

avatar image Tim Hobson ♦♦ STAFF Jan 26 '15 at 09:52 PM

Since we know it will work in a new project, but is not with this this current project, I'm kind of running out of ideas without migrating all content to a new project. :/

Can you open up the project folder and try deleting the saved and intermediate folders (I understand there may have been changes made to these, but just as a test). You can just move these out of the project folder to back them up if needed. The editor will create new ones when you start the project back up.

Let me know if that has any effect with the scene.

avatar image Shantaram Jan 26 '15 at 10:00 PM

I tried that already and it didn't work. I already created new project and migrated all my content and its working perfectly. As we created a whole new project, I can delete content from my old project and share the whole project with you so that you guys can look into in more detail. Would you mind if I share that project?

Thanks for all the help

avatar image Tim Hobson ♦♦ STAFF Jan 26 '15 at 11:37 PM

That would be absolutely fine. I'd definitely be interested in trying to get this to happen on my end or at least see if there is anyway to reproduce what happened.

You can post the link here or send to me on the forums and I can check it out.

avatar image Shantaram Jan 27 '15 at 03:48 PM

I have PM you the project link on forums.

Thanks,

avatar image rickdlol Feb 03 '15 at 08:54 PM

Hello Tim and Shantaram! I am seeing the same issue - almost the same issue over here. Perforce project, some things work in PPV and some don't - the one that doesn't seem to be working for me is AO: http://i.imgur.com/bGux6f9.jpg Checked in the effects cave example scene and it works there (and in other projects I have created). I also tried copying over a working PPV from another project but no effect.

Engine version 4.6.1

Did you discover anything that would help? This is pretty worrying because I have no idea what else might be broken that we just haven't noticed yet :(

Cheers for any info!

avatar image Shantaram Feb 03 '15 at 09:06 PM

its the same issue. I had to create a blank new project then migrated all the assets and then check in with perforce to make it work. Hope Tim is able to figure out the issue.

Thanks,

avatar image rickdlol Feb 03 '15 at 09:29 PM

Alright, some digging. I don't think this was exactly related, we had added Intermediate and Saved folders to perforce at the beginning - and it seems some file somewhere was resetting the quality levels to for post-processing to low - or something, I don't know what exactly was going on. Managed to resolve this by getting those out of perforce so individual user settings wouldn't keep getting overwritten. At least I think that was the problem, I am not 100%, something strange was definitely going on.

avatar image Shantaram Feb 03 '15 at 09:39 PM

Its a different issue than compare to mine because when I moved my project out of perforce and deleted intermediate and Saved folders, it didn't solve anything.

avatar image Tim Hobson ♦♦ STAFF Feb 06 '15 at 10:47 PM

Hey Shantaram,

I've still not been able to nail down a repro for this, but I have submitted the project along with a ticket for an engineer to take a look at. For your reference the ticket # is UE-9366.

I'll update you with any information I have along the way.

avatar image rickdlol Feb 08 '15 at 12:41 PM

snip

If anyone is using the https://github.com/mitchemmc/UE4FirstPersonVRTemplate VR Template it is setting everything to low when you play the game. Probably completely unrelated to this issue? But maybe it helps someone!

avatar image Tim Hobson ♦♦ STAFF Feb 08 '15 at 07:35 PM

Not related. This issue is the loss of post process all together. Engine scalability doesn't have an effect here.

avatar image Shantaram Feb 09 '15 at 06:53 PM

ok. Thanks for still looking into it.

avatar image Tim Hobson ♦♦ STAFF Feb 09 '15 at 08:29 PM

I actually had this happen to me on one of my blank projects at home last night. I didn't have time to look at it much yesterday when I found it, but I'll be looking at it at home to see if I can get a repro. I've not been able to do it on my machine here, which can be frustrating. The issue has been assigned to an engineer to start looking into as well along with anything new I find I'll keep updating. My project at home was in 4.6.1. No upgrading or opening copies. :/

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I like to help, I know this is an old post but, I have found that in Parent class Blueprints if there is things on the event tick, it will not work properly on the Child. So, in order to fix this, Make a function instead on the parent event tick and in the child event tick Call the Parent event tick funtion. Cheers!

more ▼

answered Apr 30 '18 at 04:34 PM

avatar image

ShdwKnghtLT
8 1 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question