x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Level blueprint save on compile issues, no save button on bar

I am on UE4 4.7 preview 4. This took a few hours to figure out. Was a simple matter. Basically when working on a fireworks show I would make changes for when the fireworks would shoot off in the level blueprint and I would preview it with "VR preview" everything was working accordingly.

But then the problem: When I would package the project no changes from my level blueprints would take effect. Even after saving my entire project.

Well, It ended being an issue in the level blueprints section under the file menu, the "save on compile" setting. It is by default set to "never" and is greyed out. It also also buried deep in there, there is no save button on the top bar here like in other sections. (at least on my screen) so my assumption was it was auto-saving on compile.

I had to go to file "save all" then the changes would finally take effect in the packaged project. This seemed a little counter-intuitive as I had saved the entire project but it would not apply my level blueprint changes on packaging.

I am not sure if this is a recent bug? I still can't change that setting to auto-save and somtimes I forget to go to file, save all.. but perhaps that should be set to default. I feel as though when you package a project it should know to autosave the level blueprint, and have the same behavior as the Editor preview options, and apply the updated levelblueprint to the package. I spent a good amount of time messing around with maps and modes and various game modes trying to figure out the problem. Just want to give a heads up.

Product Version: Not Selected
Tags:
more ▼

asked Jan 22 '15 at 10:35 PM in Bug Reports

avatar image

haggler2
36 1 10 13

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey haggler2,

Thanks for the feedback! I agree that this might be confusing, so I have entered a feature request to add a Save button to the Level Blueprint Toolbar for the developers to consider. I will let you know what they say as soon as I get an update.

I was not able to reproduce the greyed-out Save On Compile option, however. Is this still occurring in 4.7 Preview 7? Is this happening in the binary build from the Launcher, or have you built from source?

more ▼

answered Feb 12 '15 at 11:47 PM

avatar image Sam2103 Jan 27 '16 at 01:03 PM

I have the save on compile options in level blueprint greyed out and set to Never, where the rest of my blueprints are set to Save on Success. I'm on 4.10 and build the engine myself.

This has caused me to loose a small amount work a couple of times now when the engine crashes.

avatar image Ben Halliday STAFF Jan 27 '16 at 04:02 PM

Hey Sam2103,

I just build 4.10.2 from source, and I'm not seeing this. However, the only option I'm aware of is the option in Editor Settings > Blueprints. I don't see anything specifically for Level Blueprint in this regard, nor in any specific Blueprint. Can you elaborate on what you're referring to? Thanks!

avatar image Sam2103 Feb 17 '16 at 09:32 AM

Hi, only just seen this response... didn't get a notification!

I'm on 4.10.1 so maybe its been fixed, but when in the level blueprint, the dropdown list on the compile button has options to 'Save on Compile' or 'Jump to Error Node'. Inside 'Save on Compile' all options are greyed out and 'Never' selected. Whereas is all other blueprints I have 'On Success Only' and for that matter the Editor preferences for 'On Success Only' selected.

Cheers

avatar image Ben Halliday STAFF Feb 17 '16 at 05:55 PM

Ah, I apologize, I forgot about that dropdown menu. I'm not certain whether those are intended to work (the Level Blueprint is tied to the map, which may have different save requirements), but I've created a bug report for the options being grayed out (UE-27066). At the very least, it would be nice to see a tool-tip explaining why the options aren't available, if it's not possible to save-on-compile the Level BP.

I'll post here when I see any updates. For now, just be sure to Save the level frequently as you make changes. Thanks!

avatar image AndrewHurley Feb 22 '16 at 06:36 PM

Hey all,

The bug report was returned as something we will not be fixing. This is because saving of the level BP means saving of the level - something we don't want Blueprints to have control over (people could lose work if they don't understand this correlation).

Thank you for your patience while we investigated this issue.

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question