x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Steam API disabled

Hello,

Not too long ago I build my game using the Steamworks integration wiki and everything went well first time, and the steam showed I was playing SpaceWars as per the test app id.

I've now come back after a little break and wanted to test my build and there seems to be an issue with steam not loading when I build the game. This is the error I've found in the output log -

 MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2015.01.23-14.45.24:385][  0]LogTaskGraph: Started task graph with 3 named threads and 6 total threads.
 MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2015.01.23-14.45.24:445][  0]LogOnline:Display: STEAM: Loading Steam SDK 1.30
 MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2015.01.23-14.45.24:445][  0]LogOnline:Warning: STEAM: Steam API disabled!
 MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2015.01.23-14.45.24:445][  0]LogOnline:Display: STEAM: OnlineSubsystemSteam::Shutdown()
 MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2015.01.23-14.45.24:445][  0]LogOnline:Warning: Unable to create OnlineSubsystem module Steam
 MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2015.01.23-14.45.24:445][  0]LogOnline:Warning: Unable to load default OnlineSubsystem module Steam, using NULL interface

Any thoughts as to why this is? I've been over and checked that all the DLL's are in the right place, checked that the steamworks SDK is up to date too. I did notice that it says Steam.SDK 1.30 which is odd seeing as the folder has been updated to v131 and I have updated the steamworks.build.cs to match.

Any help would be great!

Product Version: Not Selected
Tags:
more ▼

asked Jan 23 '15 at 02:52 PM in Packaging & Deployment

avatar image

Hodgeasaurus
163 15 18 25

avatar image The Cheese Dragon May 22 '15 at 12:01 PM

I got this error but I couldn't get it wot work even following those instructions...

avatar image Kochab Jul 07 '15 at 04:43 PM

Using engine 4.5.1 and I HAVE to use a folder called Steamv130 cause that's all it looks for regardless what the steamworks.build.cs says. And the sdk version I'm using is 133b. Even when it finds the binaries, it still doesn't load the subsystem and says "Steam API disabled." This is so confusing.

avatar image The Cheese Dragon Jul 07 '15 at 10:04 PM

I did get it to work a wile back, I think I fluked it... I filled out all the codes as I was told to except eventually it magically decided to work... I hate messing with bits of code. It was a wile back now so I don't remember exactly what I did but two things that are important to check are that you have done stuff to all three bits of code, (I did two and forgot I hadn't done the third which was my main problem)

Also even when I got it working it would only work if A steam was already running and B I was joining someone else, not myself because it doesn't allow you to join yourself sadly, so its even harder to test than before I had the steam SDK working!

I would also really recommend updating to 4.8 or at least 4.7 because that is a very out of date version of the engine!!!! you must not have updated in about 6 months!!! You do realize its free now right?

Good luck, I am afraid I can be of no more help to you than that.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Ok, there's clearly been some changes since I last ran it - following this got it working again!

https://wiki.unrealengine.com/Steam,_Using_the_Steam_SDK_During_Development

Thanks to Rama.

more ▼

answered Jan 23 '15 at 04:03 PM

avatar image

Hodgeasaurus
163 15 18 25

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question