x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Launcher refuses to launch

Why, hello! Today I subscribed to the UE4 and downloaded the Launcher File, but after installation, a message came that said: "Error! No version information received." After clicking OK I couldn´t sign in, it said: "Error! Did not get a response. Are you connected to the internet?". After an hour of searching the web and the AnswerHub I tried all your tips from the Troubleshooting Page. I restarted my computer, I ran the Launcher as Admin, I made sure not to use a proxy and that TLS 1.x are on, I disabled my firewall and the AntiVirus software, I switched DNS Server to Google, but: nothing. The only thing that has an effect is adding "-HTTP=Curl" to the target path, but when starting the Launcher then, a window pops up that tells me it´s searching for an Update and I have to wait, but even after an hour nothing happens. So I followed your 10-steps and saved a Verbose-Log.

link text

So, can you figure out what my problem is?

My specs are: Intel i7-4770 3,4 GHz, 8 GB RAM, GeForce GTX 760, Windows 8.1 64 Bit

Thanks, Chris

Product Version: Not Selected
Tags:
more ▼

asked Jan 23 '15 at 03:29 PM in Installation & Setup

avatar image

Chris Rebmann
21 2 2

avatar image TJ V ♦♦ STAFF Jan 23 '15 at 09:11 PM

Hi Chris,

Thank you for the report and for taking the time to work through the troubleshooting steps then post your Verbose logs. We will investigate the issue and post back here as soon as we can.

avatar image arbrown STAFF Jan 24 '15 at 01:43 PM

Hi Chris,

From the logs, the first point of failure looks to be this line:

LogHttp: InternetStatusCallbackWinInet request=00000006E1D31440 AsyncResult.dwError: 00002EE7.

Which is this error https://msdn.microsoft.com/en-us/library/windows/desktop/aa385465%28v=vs.85%29.aspx

ERROR_INTERNET_NAME_NOT_RESOLVED, 12007, The server name could not be resolved.

Could you please visit this site, http://whatismyipaddress.com/proxy-check and let us know if you are behind a proxy at all, as we've had reports from other users like this too, thanks

Andrew

avatar image Chris Rebmann Jan 24 '15 at 02:54 PM

Hi Andrew,

I´ve done the proxy check and it tells me no proxy server has been detected; all the results under IP are False, if it helps you to know...

avatar image arbrown STAFF Jan 24 '15 at 03:46 PM

Hi Chris,

That's interesting... the issue you're experiencing if very similar to another users here:

https://answers.unrealengine.com/questions/147795/updating-unreal-engine-launcher-loading-by-hours.html

You mentioned you've already tried the 10 steps, so I'm just wondering if you might try the steps outlined in that link too, please? Particularly the nslookup and DNS posts, thanks.

Andrew

avatar image Chris Rebmann Jan 24 '15 at 04:50 PM

Hey Andrew,

I get this when I run that nslookup-command: alt text

DNS seems to work, but I´m very far from being an expert in internet-tech-stuff :(

nslookup.jpg (68.9 kB)
nslookup.jpg (71.7 kB)
avatar image Chris Rebmann Jan 27 '15 at 07:50 AM

Hello guys, haven´t heard from you for two days and I really want to start with UE4. Btw, I have no further problems connectiong to the internet, everything works just perfect, so did the payment for your engine;) The only thing that doesn´t work is the UE4-Launcher.

Thanks, Chris

avatar image arbrown STAFF Jan 27 '15 at 10:26 AM

Hi Chris,

Sorry we haven't responded sooner, it's odd that the URL doesn't resolve for you using either your own DNS or googles DNS. Are you behind/running any VPN at all, or have any banking software installed? (as they are known to enforce their own VPN behind the scenes) if so it might be worth disabling or uninstalling. You mentioned you disabled your firewall... depending on where your PC is setup you may be behind a corporate firewall you don't have access to, which may blanketly be blocking any URLs with 'game' in them, could this be the case? Could you also trying this address in your browser, please? https://account-public-service-prod03.ol.epicgames.com/account/api/version if it doesn't work there then we could be looking at an issue with the system/environment as a whole.

Andrew

avatar image Chris Rebmann Jan 27 '15 at 10:43 AM

Hi Andrew, I´m not running a VPN, I´m not behind a corporate firewall (it´s just my single happy little workstation) and I don´t have any banking software installed. When I open the adress you told me, it says:

{ "app" : "account", "moduleName" : "Epic-Account-PublicService", "branch" : "Release", "buildDate" : "2015-01-15T00:53:01.203Z", "serverDate" : "2015-01-27T10:36:41.833Z", "build" : "46", "cln" : "2406532", "overridePropertiesVersion" : "$Revision: #45 $", "version" : "1.11" }

Is that good ortotally uncool?

Thanks, Chris

avatar image arbrown STAFF Jan 27 '15 at 12:05 PM

Hi Chris,

We're not sure what the problem is at this point. Your PC should be able to resolve the URL, but your images above show that it can't do this using either your ISPs DNS of Googles DNS (I suspect OpenDNS [208.67.222.222 or 208.67.220.220] would be the same too). The fact that your browser can resolve it might be due to it authenticating it with the use of proxies. At this point we don't believe it's an issue with the Launcher, I've asked a member of our IT department if they know of any issues that could be causing it on a users machine, and I'm waiting to hear back. In the mean time, it may be worth searching online for nslookup issues and see if they are any help at all, here's a couple to start

http://webmasters.stackexchange.com/questions/46644/process-of-dns-resolution-using-nslookup-starting-from-root-nameservers

http://hackercodex.com/guide/how-to-stop-isp-dns-server-hijacking/

It may also be worth setting your DNS to either Googles and OpenDNS (rather than just specifying it as an nslookup parameter) and then calling ipconfig /flushdns from the cmdline and retrying the Launcher, just to rule it out. If I hear any more, I'll get back to you.

Andrew

avatar image arbrown STAFF Jan 28 '15 at 11:52 AM

Chris,

IT came back with a few suggestions...

  • Have you modified any of the launcher files at all?

  • Do you have another PC/laptop you can test this on? if it works on another machine from the same location then it's likely to just be an issue with this PC rather than an issue with your router/ISP

  • Do you have a IPV6 network at home? If so, can you disable the network adapter and try again?

  • Can you resolve the official A record of the server https://account-public-service-prod03-407304895.us-east-1.elb.amazonaws.com/account/api/version and what does nslookup have to say about that one?

  • Can you ping the server? (it shouldn't ping back, just interested to see if pinging resolves the address too)

  • In summary, this looks like a proxy, or a firewall blocking ports (router firewall maybe?). Could you do a Wireshark capture (https://www.wireshark.org) and see whats happening?

Thanks

Andrew

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first

Hi Andrew, thanks for your help and thanks to your IT department as well. I will try your latest suggestions in the evening or during night, I got some rendering stuff to do that kepps my computer busy at the moment. Maybe I put my computer over to a friend´s house to see if it works there. Unfortunately it´s my only PC, my very very old laptop still has XP on it and the launcher didn´t work at all on this one. So, as soon I got the time, I´ll try it and then come back on you.

Thanks very much, Chris

more ▼

answered Jan 28 '15 at 12:14 PM

avatar image

Chris Rebmann
21 2 2

avatar image TJ V ♦♦ STAFF Feb 02 '15 at 05:52 PM

Hi Chris,

I just wanted to see if you have had time to try the suggestion Andrew provided above? Once you do, post back here to let us know and it will reopen the question.

Cheers,

TJ

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question