x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Performance regression in 4.7.0 preview

My problem is as follows: In 4.6 I'm getting 40-60 fps on my map that has relatively large amount of foliage. In 4.7 preview I'm getting less than 1 fps on the same map I. I migrated the map and its assets to a new project and migrated that to 4.7. GPU visualizer shows that most of the time is spent on rendering cascaded shadow maps, which takes 50 milliseconds per cascade.

TL;DR: I get a 98% drop in performance.

GPU visualizer: http://i.imgur.com/Y4wWFoU.png (is it possible to export this as text instead of taking a screenshot of it?

I attached my dxdiag file just in case.

I also sent the a test project to Andrew Hurley, I won't be posting it here since the assets are part of a project that isn't public.

Product Version: Not Selected
Tags:
more ▼

asked Jan 23 '15 at 07:42 PM in Bug Reports

avatar image

jonimake
126 12 19 26

avatar image AndrewHurley Jan 23 '15 at 09:14 PM

Hey jonimake,

I am downloading the zip file your provided now. I will let you know when I have tested your issue you are reporting!

Thank you,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Just a heads up, something in the new 4.7.0 preview 5 seems to have fixed my performance problems.

more ▼

answered Feb 03 '15 at 06:21 PM

avatar image

jonimake
126 12 19 26

avatar image AndrewHurley Feb 03 '15 at 09:00 PM

I was actually going to ask because we fixed a game breaking issue with Foliage causing projects to break (mine included). With the fix came the new improvements upon foliage performance as well!

Glad to hear!

Andrew Hurley

avatar image tkorkalainen Feb 03 '15 at 11:54 PM

My framerate dropped from about 45 to 22 after migrating to 4.7 preview 5 from 4.6.1 (landscape + small amounts of foliage).

avatar image AndrewHurley Feb 03 '15 at 11:56 PM

Just to let you know, the foliage instanced static mesh performance improvements have not been implemented within the newest preview build.

@Tkorkalainen have you attempted to rebuild your lighting?

avatar image tkorkalainen Feb 04 '15 at 12:06 AM

Thanks for the information and help. I'm not using lightmaps (Force No Precomputed Lighting).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question