x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blocky Sprite Edges

Ben was nice enough to solve a large number of our problems with Unreal, but now we are back to a fundamental problem that we have been ignoring. Blocky sprites. We moved from Game Maker into Unreal (for obvious reasons) and the sprites have not been rendering correctly since day one.

  • I've set the AA the FXAA.

  • We have the game quality set to maximum.

  • 60FPS

  • I've tried setting the texture to bi-linear.

  • I've tried a variety of mask settings on the sprites.

This is a picture. The edges both on the sprite standing in the middle and the environment, are not supposed to be blocky.

alt text

Product Version: Not Selected
Tags:
more ▼

asked Jan 26 '15 at 07:22 PM in Rendering

avatar image

The Britain
73 19 14 18

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Any masked option will do this. Try to change it to TranslucentUnlitSpriteMaterial( or TranslucentLitSpriteMaterial you want the sky lighting to effect it). You have to check the plugin option(clicking on "view options"(the eye) will reveal it) to see the TranslucentUnlitSpriteMaterial though.

more ▼

answered Jan 26 '15 at 07:51 PM

avatar image

spazchicken
447 35 20 53

avatar image The Britain Jan 26 '15 at 08:06 PM

That kind of fixed the problem. The background looks fine now, but the animated sprite has had no change. It is still jagged around it's outer edge. Thanks for the help so far!

alt text

stg2.png (503.5 kB)
avatar image The Britain Jan 26 '15 at 08:18 PM

So it turns out, if you have a flipbook, you have to set it AGAIN on the flip book, but here comes a weird problem. Ok, that worked, kind of.

Now, my character always appears behind my background, no matter what the Y increment. Any ideas?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

No need to change every frame.Now flip books support materials.Just double click on your animation and change the material to something translucent.

more ▼

answered Jan 26 '15 at 08:16 PM

avatar image

Roccinio
576 52 56 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

No need to change every frame.Now flip books support materials.Just double click on your animation and change the material to something translucent.

more ▼

answered Jan 26 '15 at 08:16 PM

avatar image

Roccinio
576 52 56 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Good to hear! It looks like the flipbook is still masked, did you change the option for each sprite/frame in the flipbook? If so, there is also an option for it in the flipbook itself. I'd change that!

more ▼

answered Jan 26 '15 at 08:12 PM

avatar image

spazchicken
447 35 20 53

avatar image The Britain Jan 26 '15 at 08:26 PM

You must change it on the flipbook as well it turns out, though the new problem is even stranger. The character is now rendering behind the background, for no reason. No matter what the Y ordering.

avatar image The Britain Jan 26 '15 at 08:29 PM

Here is a screenshot.

alt text

edge3.png (335.8 kB)
avatar image The Britain Jan 26 '15 at 08:31 PM

This only happens if both the background and the character are set to unlit/lit translucent at the same time.

I am going to start a new topic on this new bug, thanks again for your continued help!

avatar image Roccinio Jan 26 '15 at 09:39 PM

Go to your actor settings when you place him in the level type 'sort' and under that field adjust everything starting from zero(background) and add 1 as you reach the foreground

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question