x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Normal maps from Blender not working correct

Here is a in engine screenshot (Anything looks fine in Blender): (ignore the star) alt text

Product Version: Not Selected
Tags:
normals.jpg (425.7 kB)
more ▼

asked Jan 26 '15 at 08:48 PM in Rendering

avatar image

Viewtron
110 9 12 12

avatar image AndrewHurley Jan 26 '15 at 09:10 PM

Hello Viewtron,

Would you mind providing me with a screenshot of your material set up?

Thank you,

Andrew Hurley

avatar image Luos Jan 26 '15 at 11:16 PM

To continue on what andrew asked, could you also show your UV-layout? I got the strong feeling that halfof the model is mirrored, as well as the way your uv-map is laid out.

avatar image Viewtron Jan 27 '15 at 01:47 PM

UV: alt text

Texture settings: (tried to flip the green channel) alt text

Material set up: alt text

uv.jpg (482.3 kB)
tex.jpg (328.3 kB)
material.jpg (283.4 kB)
avatar image AndrewHurley Jan 27 '15 at 02:34 PM

Hi Viewtron,

The normal map type you are using looks like a World Space Normal instead of a Tangent Space Normal which I am used to seeing most often in the Engine.

The first thing I noticed is you do not have a 'Texture Coordinate' node plugged into your 'Normal' texture sample. Do this to see if your seems are taken care of on your doll mesh.

The next thing I would suggest is using either a different Normal Map type, or you will want to transform the current one you are using. I have a read over the documentation for normal maps within the Engine and how they are handled.

Bump Without Tangent Space Normal Documentation

https://docs.unrealengine.com/latest/INT/Engine/Rendering/LightingAndShadows/BumpMappingWithoutTangentSpace/index.html

alt text

This gives a bit of information about using a World Space Normal vs Tangent Space normals. Have a look over the documentation to see what approach you would like to take. I would suggest finding a free normal map generator and using that instead. I like to use SSBump Generator for my maps, but there are others out there that are paid and work really well also.

Let me know if this resolved your issue or if you need further help.

Cheers,

Andrew Hurley

avatar image Viewtron Jan 27 '15 at 02:53 PM

I used tangent space for the normal maps (the green channel is flipped in unreal).

Unflipped normal map looks like this: alt text

I treid the TexCoord node, but it doesn't help (still looks the same).

avatar image AndrewHurley Jan 27 '15 at 06:28 PM

Hello Viewtron,

Have you tried 'Generating Lightmap UVs' for this object?

avatar image Viewtron Jan 28 '15 at 09:45 AM

Isn't this only for static meshes? This is a skeletal mesh.

avatar image AndrewHurley Jan 28 '15 at 03:20 PM

Apologies, I was not sure if this was a Skeletal Mesh or a Static Mesh.

So, one thing you could definitely try would be to have a look over the 'Normal Map Creation Guide' documentation.

Normal Map Creation Guide

https://docs.unrealengine.com/latest/INT/Engine/Content/Types/Textures/NormalMaps/Creation/index.html

Try going through this documentation and follow the steps/settings suggested for implementing normal maps within the Engine. Start from the beginning so you can make sure it is not a setting you could be overlooking.

Skeletal Mesh Pipeline

https://docs.unrealengine.com/latest/INT/Engine/Content/FBX/SkeletalMeshes/index.html

Let me know if you have given this a try and are still not setting the right results for your mesh.

Thank you,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Ok solved the problem, my normal maps where 32 bit, had to set them up as 8bit now it's working correctly.

more ▼

answered Feb 01 '15 at 01:18 AM

avatar image

Viewtron
110 9 12 12

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question