x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

BlueprintCallable very strange issues on mobile

Firstly, everything works as expected in the editor and mobile preview but not on my device.

Galaxy S5, Android 4.4.2

UE4 version 4.6.1

I have no idea what's causing it, it's very bizarre. I tried the same in an empty project and it seems to work. I just can't figure out what's causing this strange behavior in my project. I should add that I discovered the problem not by attempting this simple method, but one where I was returning custom object. This method below was purely for testing. It also doesn't work with objects or float values.

I have this method in C++

  .h
  UFUNCTION(BlueprintCallable, Category = ElementalAI)
  FVector VectorCheck();
  
  .m
 FVector AElementalCharacter::VectorCheck()
 {
     FVector v = FVector(100, 100, 100);
     UE_LOG(LogElemental, Log, TEXT("V: "), *v.ToString());
     return v;
 }

This is what happens if I call that method from BP on my Character (or any other custom class/blueprint, I've tried many)...

From OnPossessed (or BeginPlay). It does nothing. No result from the Print String and Nothing logged from the code (checking the log file on device and using logcat). Game runs as if it was never there. alt text And now the weird bit. When I attach it to the end of my existing blueprint nodes, which have worked flawlessly for months. It causes the node before it to run in an infinite loop (in the case of the picture below: "Give Weapon", also moved it up the chain with the same result). Still no output from the Print String or from the code. Game cant run due to infinite loop. I have to force quit on the device. alt text

I've attached the output of LogCat and the Log file. link text link text

Product Version: Not Selected
Tags:
more ▼

asked Jan 26 '15 at 09:44 PM in Bug Reports

avatar image

DannRees
245 18 32 40

avatar image DannRees Jan 30 '15 at 03:13 PM

Sort of fixed... I created a new project, copied all my code and migrated all my assets from the original project and it now work on my device.

Still no idea what caused the problem though.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey DannRees-

Have you had this error happen since creating a new project and copying everything over? It sounds as though the blueprint became corrupted and recreating it (along with the project) fixed the issue. If you have this problem come up again in the future feel free to reopen this post with any additional information you have.

Cheers

Doug Wilson

more ▼

answered Feb 04 '15 at 09:17 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question