x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why are my Actors flickering on and off in the Viewport when my camera is moving?

Hi there, New to UE and worked my way through the new UE4 Level Creation Tutorials, I have a question I cant find the answer too.

As I move around the environment in Edit, Play, or in a launched Mode, When viewing some of the props (Specifically the wall beam props) through a gap in other geometry, they appear to flicker in and out of existence. as in they become visible and then invisible again rapidly as I move. I've attatched an image where you can see the objects flickering out of view (Circled in red). The bars at the far end of the picture actually repeat across the whole wall. But when viewed from underneath through the gap you can see, this effect occurs.

Same thing happens in every mode, yet if I float the camera above the beams, the effect stops.

Any idea what might be going on here?

[1]: /storage/temp/2150-error.jpg

Product Version: Not Selected
Tags:
error.jpg (128.3 kB)
more ▼

asked Mar 23 '14 at 07:27 PM in Using UE4

avatar image

Springularity
1 1 2 3

avatar image nexgencgi Mar 24 '14 at 07:52 AM

Sorry I don't have the answer for you, but I also have the exact same problem and believe it or not but in the exact same spot and same props lol, Have you had any luck? here is my picture's. kind regards

1.jpg (95.5 kB)
2.jpg (72.1 kB)
avatar image Springularity Mar 25 '14 at 08:08 PM

Nope, no luck i'm afraid! What hardware are you using? Any cross over in our systems perhaps?

Win 7 Home Premium - Intel i5 3570 quad @ 3.4ghz - GeForce GTX 680 - 8 GB DDR3

avatar image nexgencgi Mar 26 '14 at 01:29 AM

Very similar rig by the look of it but you have a better gfx card

Win 7 ultimate - Intel i5 3570k @ 3.6ghz -GeForce GTX 650Ti - 8Gb DDR3

Ill keep looking and give you a heads up if I find anything.

avatar image Robert Apr 21 '14 at 05:26 PM

Do the props flicker when you're close to them in the viewport or only when they are far away because I have only had this problem when I've place props that where overlapping.

avatar image nexgencgi Apr 22 '14 at 06:41 AM

Hi Robert this happens only when further away, up close they are fine and definitely not overlapping.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question