x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Project Crash on Start

This is really starting to annoy me.

Over the weekend I made a game in UE4 for Games Jam, ran into a little issue where the project would crash when attempting to open it, it would crash when it would say "Loading 66%" every time. In the end, I had to make a brand new project and move over all of my blueprints/meshes/maps whatever to that, it worked, but it's a major hassle.

Now my main piece of work for the year has got the same problem, thing is, it happens every time now, so I literally have to make a new project, set up inputs, fiddle around with for an hour before I can actually do anything and pray that I don't have to do this again.

But I know I will.

I'm going to assume I'm using the software wrong as the issue seems to arise when making parents and childs of character blueprints. I know for sure the project won't open again as it usually freezes for 10-20 seconds when I close any character blueprint before closing the project.

I'm starting to miss UDK, with that my files didn't corrupt on a regular basis.

Any help would be greatly appreciated.

Crash Report:

MachineId:8FD75B71425AD25D17D1E0A440848C59 EpicAccountId:4e17713507cd40bb8472fa911bf93806 We apologize for the inconvenience. Please send this crash report to help improve our software.

Product Version: Not Selected
Tags:
more ▼

asked Jan 29 '15 at 01:11 PM in Bug Reports

avatar image

Conkoon
26 3 5 6

avatar image Doug E ♦♦ STAFF Mar 10 '15 at 04:15 PM

Hey Conkoon-

I apologize for the delayed response, we are still trying to track the cause of the crash you were having. There are a couple additional questions I'd like to ask to help us understand the problem better.

Are you still seeing this crash in the latest engine version? If so is it specific to character blueprints? If you find that you are crashing after closing a specific blueprint, try removing the .uasset from the contents folder (move to desktop for example) and open the project again. Let us know if you are able to open the project again after doing so. Also let us know if you can think of any other conditions that may contribute to the crash.

Thanks

Doug Wilson

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Conkoon-

WE have had received reports of projects failing due to blueprints and are looking into the best solution to fix the problem. It's most likely that the blueprint became corrupted. If your issue is happening when creating parents/children blueprints then you may want to try removing those BPs from the project's content folder and try to open the project again.

Cheers

Doug Wilson

more ▼

answered Jan 29 '15 at 03:13 PM

avatar image Conkoon Jan 29 '15 at 10:22 PM

Thanks for the quick response (: I played around with my project a bit and found opening a map without the unstable blueprint it won't crash, if I then load the map it will, however... If I were to open my player blueprint, save & compile it and then open and close the parent blueprint, it doesn't crash when I load my map... It's very odd.

avatar image Doug E ♦♦ STAFF Jan 30 '15 at 02:02 PM

Hey Conkoon-

Are you able to reproduce this in a new project? If so what steps do you take that cause the crash? I'm attempting to test this myself and want to make sure I'm following the same steps. I've created a blueprint based on Character (Parent) and then created a blueprint based on that (Child) but would need more information to go from there.

avatar image Conkoon Feb 13 '15 at 06:20 PM

I've tried a few times and there's definitely something which causes it, but it could be related to how long the project has been open, as both cases it was open for 10 hours+ and that could cause a problem when RAM gets low. I've been carrying on with the project making sure I open a blank map first as this stops the crash, however when I close the project it closes then throws up a big error message, which is odd...

avatar image Doug E ♦♦ STAFF Feb 13 '15 at 07:12 PM

If you could post the log files from the crash that will help point us to where the crash is happening. Additionally, which version of the engine are you working in? If possible try testing for the crash again in the latest released version of the engine (4.6.1) if you are not already on this version.

avatar image Conkoon Feb 14 '15 at 03:45 PM

I am currently using 4.6.1, here's the crash log upon closing the engine


MachineId:8FD75B71425AD25D17D1E0A440848C59 EpicAccountId:4e17713507cd40bb8472fa911bf93806

Unknown exception - code 00000001 (first/second chance not available)

Assertion failed: !HasAnyFlags(RF_NeedLoad|RF_NeedPostLoad) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.6\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectLinker.cpp] [Line: 96] Detaching from existing linker for ..//..//..//..//.

KERNELBASE + 37901 bytes UE4Editor_Core + 3092349 bytes UE4Editor_Core + 1597688 bytes UE4Editor_Core + 1479058 bytes UE4Editor_CoreUObject + 1690196 bytes UE4Editor_CoreUObject + 918215 bytes UE4Editor_CoreUObject + 927204 bytes UE4Editor_CoreUObject + 1183309 bytes UE4Editor_CoreUObject + 426071 bytes UE4Editor!TBaseMulticastDelegate::Broadcast() + 129 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\core\public\delegates\delegatesignatureimpl_variadics.inl:978] UE4Editor!FEngineLoop::AppPreExit() + 374 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launchengineloop.cpp:2718] UE4Editor!FEngineLoop::Exit() + 472 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launchengineloop.cpp:2025] UE4Editor!GuardedMain() + 532 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launch.cpp:142] UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:126] UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:202] UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

avatar image Doug E ♦♦ STAFF Feb 16 '15 at 03:28 PM

Hey Conkoon-

The callstack you provided is useful, however for more information could you also include the project log? This will help point to what exactly is crashing. https://wiki.unrealengine.com/Locating_Project_Logs will provide more information on where the file is located on your computer.

avatar image Conkoon Feb 25 '15 at 08:44 PM
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question