x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blender animation becomes small

Hi, Every time I import an fbxlink text skeleton mesh with an animation I get a good looking mesh with correct dimentions, but when I start the animation the objects becomes tiny (100 times smaller) but with the correct animation attached an easy example of the fbx what am I doing wrong in Blender or UE4?? Thanks

Product Version: Not Selected
Tags:
suzanne.zip (23.0 kB)
more ▼

asked Jan 30 '15 at 07:24 PM in Using UE4

avatar image

3Dmix
6 1 1 3

avatar image eXi Jan 30 '15 at 07:34 PM

Hm, sounds like a exporting bug. Try using Blender Version 2.70. Newer version gave me bugs like this.

avatar image Artur J. Feb 03 '15 at 08:41 PM

This is related to this:

https://forums.unrealengine.com/showthread.php?57800-Blender-Armature-to-UE4

If you scale your armature and mesh by 100 (applying translation/rotation/scale after that) and then export as "scale = 1" in the fbx exporter it should work.

The scale option in the exporter seems to work only for the mesh.

avatar image Adam Davis STAFF Feb 05 '15 at 08:52 PM

Hi everyone,

I just tested this on my end and everything seems to be working as intended. How are you performing the scaling? If you do it through the world settings in blender before exporting (set world settings to metric at a scale of .01) it seems to come in without a problem.

avatar image eXi Feb 05 '15 at 08:54 PM

I had the same issue. The Models exports ok, but as soon as you play an animation, the model gets tiny. Though the animation is playing.

I changed from 2.72 to 2.70 and the bug was gone.

avatar image Adam Davis STAFF Feb 06 '15 at 06:05 PM

Hi Artur J,

I saw here that you attempted using the 6.1 exporter as opposed to 7.4, did this have any impact on your bug here?

https://forums.unrealengine.com/showthread.php?57983-Twisted-bones-when-playing-animation-Blender-to-UE4

avatar image Artur J. Feb 06 '15 at 07:09 PM

Hi Adam,

It seems that the 6.1 exporter was only a help to avoid the twisted bone problem. The scale problem is even worst with the 6.1, as problems with bone sizes start to happen. Currently it only works if the export scale is 1.0; FBX 7.4 binary exporter is more correct in this matter, only the size change when playing the animation.

If you need a file to test, you can download the model of the twisted bone thread here: https://dl.dropboxusercontent.com/u/7549551/Octopus.zip

Thanks.

avatar image Artur J. Feb 06 '15 at 07:19 PM

Sorry, I forgot to answer your previous question and mention that the scale is performed when exporting.

File->Export->FBX : Scale : 100 (export parameter on the left of the window)

I will need to think about using world setting to handle the x100 scale and always export as 1.0 scaled. It could be an option.

Edited: using world settings for me is not working and Unreal complains about different bone transformations than the original.

avatar image Adam Davis STAFF Feb 06 '15 at 07:42 PM

Have you tried rolling back to blender 2.7 instead of using 2.73 if you are using the latest version? There have been several users reporting issues with 2.73, but 2.7 seems to export/import without the same errors.

avatar image Apokalypto_ Mar 30 '19 at 07:08 PM

One caveat: naming your armature "armature" removes the root bone that Blender itself assigns to it. In other words, if you try to use this solution to export an animation that you intend to use root motion with, it will not function properly.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

6 answers: sort voted first

Yes, I'm using the latest version (2.73). I'm using features that appeared on 2.72 and I'm waiting for the final version of the custom normal editing (2.74, maybe?). So downgrading is not an option.

I have found workarounds for all my error situations. Although the workflow is not smooth (and sometimes forget to do the things in the special way that avoids the failure, making me to repeat the operation), now at least there is a way.

I will wait to see if future improvements/bug fixes in the exporter (blender) or the importer (Unreal) make this process easier. If I found a stopper situation in the future I will let you know. And if the current problems persist in the future... I will try to help looking at the exporter(blender)/importer(unreal) code.

Good luck with the bug hunting!

more ▼

answered Feb 06 '15 at 09:01 PM

avatar image

Artur J.
51 1 2 2

avatar image MJ_01 Feb 16 '15 at 12:01 AM

Can you possibly go into detail on how you made it work? This answer currently isn't very helpful.

avatar image Artur J. Feb 16 '15 at 06:50 PM

Hi MJLaukala,

A workaround for this is:

  • Scale your armature and mesh by 100 in blender. So, 100 Blender Units = 1 Unreal Unit.

  • Apply translation/rotation/scale, so mesh and armature are at (0,0,0) with scale (1, 1, 1).

  • Export to FBX using "scale = 1" in the exporter option.

This should work.

avatar image dacanizares Mar 01 '15 at 05:09 AM

When I try to apply scale to the armature my animation goes crazy. What can I do? Thanks.

avatar image Artur J. Mar 01 '15 at 12:21 PM

Hi dacanizares,

If your animation only contains rotation/scale keyframes it should be working ok. But if your animation contains translation keyframes, you are right, the animantion could be completely broken and you will need correct them.

That's why I think this should be corrected in the Unreal importer. This just served me as a workarround for some simple animations or as a way to "port" my already done animations to a new scale and continue animating to that scale.

I still don't have enough time for this... but downloading UE4 git source code for now...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Name your armature something besides "armature" and animations will come in same-scale in UE4.

This issue is very old but posting anyway in case anyone new has this problem and wonders why.

more ▼

answered Nov 21 '17 at 09:47 PM

avatar image

TooManyDemons
110 1 3 6

avatar image homembarata Dec 12 '17 at 02:08 AM

Thank you, I was just having this problem. It's bizarre that this bug is still around after 2 years.

avatar image Alwoood Dec 16 '17 at 03:33 PM

Thank you so much !!

avatar image ArticMonkey Dec 23 '17 at 07:18 AM

I can't believe it, but this solution worked.

avatar image User1513111019 Jan 15 '18 at 03:05 PM

Fixed it for me as well, should be marked as accepted answer!

avatar image ryanbeezle Jan 24 '18 at 07:53 AM

Good find. Fixed for me too. I knew there had to be a simpler fix than all the other hacky fixes.

avatar image alhamra Jan 25 '18 at 10:43 AM

Thank you so much! I was having this same problem, it's unbelievable that it works! We are in 2018, and this issue is still not fixed in Blender...

avatar image draWardBear Feb 20 '18 at 04:54 AM

Thank you this worked!

avatar image KayLegendZ Mar 12 '18 at 11:04 PM

Seriously? God, this solved the problem of all my assets here. Thank you so much

avatar image Y O S May 13 '18 at 07:19 PM

That was simpler than I thought, thanks.

avatar image DigitalCraze Nov 19 '18 at 05:02 PM

So simple. Singed in just to + vote. haha. Thank you!

avatar image squeegeesus Nov 29 '18 at 08:52 AM

This solved my issues too, after hours of trying different settings. This answer absolutely needs to be marked as the correct answer, otherwise people will be confused by the current "correct" answer above.

avatar image Kamillekaz Jan 14 '19 at 08:58 PM

Thank you so much !

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi,

Verify if you are using the metric system, i had the same problem and changing from metric system to None solved it.

alt text

errorscale.png (4.3 kB)
more ▼

answered Feb 28 '15 at 04:47 AM

avatar image

Cris
6 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Ok. first post here. hope to be glorious :)

So. my workaround was:

change grid size in blender to 100 ( hotkey N -> display -> gridfloor -> scale) alt text

the exported the mesh and armature without any sort of animationalt text

and imported in UE4 as a skeletal mesh, but without the "import animation" selectedalt text

Now, back to blender and create your animation. When exporting just use the same method but deselect the mesh and export only the armaturealt text

finally, go to ue4 and import the animation and select the armature from the first exportalt text

cheers

capture.png (14.3 kB)
capture2.png (42.0 kB)
capture3.png (124.3 kB)
capture4.png (3.9 kB)
capture5.png (105.0 kB)
more ▼

answered May 05 '15 at 02:43 PM

avatar image

Mikelabs
6 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The only workaround I've had for this issue is to recreate my armature once the scale of my mesh is correct for UE4. If I an existing armature, this scale issue appears when animation is selected in UE4 (even if I apply transforms after scaling).

more ▼

answered May 29 '15 at 03:17 PM

avatar image

URIYEL
1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I'm aware this is an age old question but as far as I can tell it's still an issue so...

Blender 2.78

If I leave scales on 1, the model looks fine until I animate it. After that the usual issues appear.


The solution I use:

FBX export Scale to 0.01 in Blender.

Scale skeletal mesh (or skeletal mesh component) to 100 in UE.


Not on import but directly on the skeletal mesh component - this scaling affects animations too. For some reason import scaling didn't go well for me (didn't do a thing) but it might have been my luck.

Unanimated, animated, works so far. And is very simple to do so. (Formatting is still weird here - double enter for a simple line break...)

more ▼

answered Aug 25 '18 at 11:04 AM

avatar image

Kokuyouseki
18 3 7

avatar image Kokuyouseki Nov 29 '18 at 09:53 AM

Nevermind, TooManyDemons's solution is way easier. Though I never would've guessed something like that would work :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question