x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Rolling Ball on two static meshes, problem with collisions

Good afternoon everyone. :)

I wanted to create a little Pong game, just to learn how to use Blueprints.

First, I made this simple static mesh with Blender, there's no UV-mapping:

My static mesh Collision

Then I added two of these static meshes into my world like this :

alt text

To test the collisions, I coded a little rolling ball with Blueprints :

alt text

The problem is that when I shoot the ball, the ball jumps a little bit between the two meshes, and I have no idea how to fix it :

alt text

Can someone please help me ? What should I do ?

Thank you everyone, and sorry for my bad English, I'm French and I'm still learning English.

I use UE 4.4

Product Version: Not Selected
Tags:
more ▼

asked Jan 30 '15 at 10:00 PM in Using UE4

avatar image

MyroG
48 4 5 9

avatar image F3NR1S Sep 05 '16 at 04:19 AM

Old question but I am having the same issue. I don't have quite the solution yet but as seen in other threads this has to do with the collision settings for the ball. Simple collision should roll smoothly, but I have no luck so far. What should the collision of the mesh be like?

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

I eventually found the solution:

You need to adjust the physics simulation settings of your project. Specifically the "Contact Offset Multiplier" and the "Contact Offset" bounds. Beware of the trade-offs for performance.

more ▼

answered Jul 21 '17 at 12:33 AM

avatar image

F3NR1S
127 5 15 18

(comments are locked)
10|2000 characters needed characters left

If collision doesn´t work, try to set Collision complexity and collision presets inside the Static mesh.

this worked for me:

alt text

rightproperty.jpg (14.0 kB)
more ▼

answered Jul 17 '17 at 07:49 PM

avatar image

leofucci
127 8 14 22

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question