x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Sessions not found over internet - Only locally [STEAM]

Hello again,

I have recently built my session browser following the helpful video posted on the UE YouTube channel a while back.

I am however having some issues and I'm not sure where to begin tackling it. I have set it up so that it works like a traditional server browser, with refresh, host and direct connect buttons. When I click to host the game on my machine, the session creates and I'm loaded into the level. However the issue I'm having is that my friends cannot find the session via the browser online, however I can find it locally.

I have been through the basics over and over such as making sure the session create/find is not set to LAN. I have updated the steam .dll's to the latest and have double checked it is all correct for the steam setup. I have also forwarded the needed ports so that isn't blocking me either.

I am happy that Steam is set up correctly as the overlay appears and the game can fetch the users Steam username. However the game is currently setup to use the default app id 480 and I was wondering if this would cause an issue for the sessions not being found over the net?

Just so I can show the DefaultEngine file is setup correctly:

 [/Script/Engine.GameEngine]
 !NetDriverDefinitions=ClearArray
 +NetDriverDefinitions= (DefName="GameNetDriver",DriverClassName="OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="OnlineSubsystemUtils.IpNetDriver")
 
 [OnlineSubsystem]
 DefaultPlatformService=Steam
 PollingIntervalInMs=20
 
 [OnlineSubsystemSteam]
 bEnabled=true
 SteamDevAppId=480
 GameServerQueryPort=27015
 bRelaunchInSteam=false
 GameVersion=1.0.0.0
 bVACEnabled=1
 bAllowP2PPacketRelay=true
 P2PConnectionTimeout=90
 
 [/Script/OnlineSubsystemSteam.SteamNetDriver]
 NetConnectionClassName="/Script/OnlineSubsystemSteam.SteamNetConnection"

Any help to get my sessions showing online would be great :)

Cheers, Joel

Product Version: Not Selected
Tags:
more ▼

asked Jan 30 '15 at 11:13 PM in Blueprint Scripting

avatar image

Hodgeasaurus
163 15 19 25

avatar image BagmanPT Jul 08 '15 at 09:36 PM

i have the exact same problem. no idea how to fix it...

if you find a solution, please send tell me.

thank you

avatar image Megamind Studios Apr 19 '17 at 01:54 AM

did you ever get this fixed guys?

thanks!!

avatar image BagmanPT Apr 20 '17 at 01:13 PM

I did. here is how:

on the [/Script/Engine.Engine] part

the last line add:

+NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="OnlineSubsystemUtils.IpNetDriver")

also I did removed all the +NetDriverDefinitions and -NetDriverDefinitions

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

4 answers: sort voted first

Well I've got Steam working over the internet, tested with someone 50KM away, but within the same country. I've read something about issues with different countries/continents when using the 480 App ID.

Here's what I've got on some of the settings. DefaultEngine.ini [OnlineSubsystem] DefaultPlatformService=Steam PollingIntervalInMs=20

 [OnlineSubsystemSteam]
 bEnabled=true
 SteamDevAppId=480
 GameServerQueryPort=27015
 bRelaunchInSteam=false
 GameVersion=1.0.0.0
 bVACEnabled=1
 bAllowP2PPacketRelay=true
 P2PConnectionTimeout=90
  
 [/Script/OnlineSubsystemSteam.SteamNetDriver]
 NetConnectionClassName="/Script/OnlineSubsystemSteam.SteamNetConnection"

projectname.Build.cs

 PublicDependencyModuleNames.AddRange(new string[] { 
              "OnlineSubsystem",
              "OnlineSubsystemUtils"
          });
 
         DynamicallyLoadedModuleNames.Add("OnlineSubsystemSteam");
 
         //Uncomment if you are using Slate UI
         //PrivateDependencyModuleNames.AddRange(new string[] { "Slate", "SlateCore" });
         
         //Uncomment if you are using online features
         PrivateDependencyModuleNames.Add("OnlineSubsystem");
         if ((Target.Platform == UnrealTargetPlatform.Win32) || (Target.Platform == UnrealTargetPlatform.Win64))
         {
             if (UEBuildConfiguration.bCompileSteamOSS == true)
             {
                 DynamicallyLoadedModuleNames.Add("OnlineSubsystemSteam");
             }
         }

projectname.Target.cs

 public projectnameTarget(TargetInfo Target)
     {
         Type = TargetType.Game;
         bUsesSteam = true;
     }

I hope that this might help you to find what's wrong.

more ▼

answered Jul 09 '15 at 09:10 PM

avatar image

Serellyn
247 27 28 40

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Feel this may have gotten lost overnight so I'm going to bump it.

more ▼

answered Jan 31 '15 at 10:40 AM

avatar image

Hodgeasaurus
163 15 19 25

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

So this seems to be an intermittent thing... So I am assuming it's a draw-back to using the 480 App ID. Any one able to confirm that for me? Also, as the game is running via steam, is it best practice to change the port from 7777-7778 to Steams 27015?

more ▼

answered Feb 03 '15 at 12:28 PM

avatar image

Hodgeasaurus
163 15 19 25

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I did. here is how:

on the [/Script/Engine.Engine] part

the last line add:

+NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="OnlineSubsystemUtils.IpNetDriver")

also I did removed all the +NetDriverDefinitions and -NetDriverDefinitions

more ▼

answered Apr 20 '17 at 12:13 PM

avatar image

BagmanPT
10 5 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question