x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Standalone game very laggy

Hey, so i'm still fairly new to Unreal Engine. I spent a few days and made a pretty basic horror game with some trees, grass, and an enemy that follows you. I packaged the game for windows and tried running but but it's so laggy, I get around 1 frame every few seconds it seems like. I also tried it on a different computer and it did the same thing. Is the problem that both computer are too bad to run the game, or am I just missing something? My computer is good enough to handle games like Outlast, so i'm not sure why it couldn't run this little game. Thanks!

Product Version: Not Selected
Tags:
more ▼

asked Jan 31 '15 at 12:29 AM in Packaging & Deployment

avatar image

Mxeaez
31 6 9 10

avatar image TheCakeNuke Aug 22 '15 at 03:57 PM

Hey, I have the same problem! It is not your PC, trust me. I can handle Grand Theft Auto V on maximum settings but when I packaged my game for windows it was lagging horribly, even though it was playing nicely in the editor. If you have found any fix, please let me know!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey, I finally got a reply! Haha. What I did was add a menu for adjusting graphics such as render distance, pixel quality, etc. By default, everything is set to max which is why it was so hard for my computer to run it. After I made the graphics menu, I just turned down the settings and it seemed to work good.

I'm not sure if this is the case for you though since you said you can handle Grand Theft Auto V on maximum and you would think that would be able to handle your own game at max settings. Hopefully you get it fixed!

more ▼

answered Aug 23 '15 at 05:28 AM

avatar image

Mxeaez
31 6 9 10

avatar image TheCakeNuke Aug 23 '15 at 07:35 AM

It probably is my case, too. Maybe the shaders are a bit too much. The game runs at some pretty ~15-20 FPS (I'd say) so maybe it's because of the graphics. And I know how it is to get no reply. I once got a reply right after I fixed a problem myself. Thank you, I'll try to make a graphics menu, too.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question