x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Grass turns Black in level Where Have i gone wrong?,My Grass mesh seems fine in the editor but Black in level how do i fix this?

Hello Folks!

I made this Grass Mesh Everything seems to check out, The material Is basic and just straight forward, The Grass looks fine in the Editor preview but once I Place the mesh in the level It turns Black? Im not sure what I have done Wrong? Perhaps we can figure this out?

After building the scene I did get this error:

Component is a static type but has invalid lightmap settings! Indirect lighting will be black. Common causes are lightmap resolution of 0, LightmapCoordinateIndex out of bounds.

When i orginally created the mesh I placed the 2nd UV Too close to each other, After i moved them out more I reimported the mesh and Rebuilt the scene but unfortantly It didnt Fix my Issue.

Please Review my Image, Sorry be warned its a huge screen! alt text

http://postimg.org/image/74a620985/full/

Product Version: Not Selected
Tags:
more ▼

asked Jan 31 '15 at 05:46 AM in Rendering

avatar image

KTR19
48 1 2 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

hi . try this : ue4 will generate custom lightmap uv . must of times you dont need to create light map uv . so delete 2nd uv and try . 1. i think this error is because your model uv is out of space of u:0-1 and v:0-1 in your 3d modeling software . try to adjust model uv within space of 0-1 . alt text 2. if its not work try to change lightmap resolosion to some thing like 256 .

uvset.jpg (179.3 kB)
more ▼

answered Jan 31 '15 at 07:21 AM

avatar image

tx2line
256 8 10 23

avatar image KTR19 Jan 31 '15 at 08:56 AM

Hey thanks for answering! So I played with some variables here.

First I deleted the Second UV channel in Maya and reimported the Mesh, the UE4 generated the second channel, but the same lighting artifact is still there.

Now this is my second UV channel For the light map Before I had UE4 generate it, I used the Maya's Automatic Mapping tool.

alt text

this is my first UV channel which contains the Picture data for my Grass Defuse, I made a flat plane with the projected image, After that i Moved the verts around to create a rounding Mesh and Duplicated the objects and rotated them around? perhaps my First UV channel is incorrect since its not all of the meshes in the grouping? alt text Could it be also that my FBX options are set up wrong? alt text

I did however notice that the light artifact happens when a light source is directly above it, but artifacts still appear even when the lighting scene changes for example in this video

https://www.youtube.com/watch?v=rhFiYOHX_VU&feature=youtu.be

elp!.jpg (237.3 kB)
elp!2.jpg (1.5 MB)
elp3.jpg (241.7 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question