x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Failing to cook content for Mac dedicated server

I am attempting to build a dedicated server executable on OS X 10.9. I am compiling a code-based project from the source build of 4.6.0. I have created a GameServer.Target.cs file as specified in the documentation here:https://wiki.unrealengine.com/Standalone_Dedicated_Server

The server and client binaries successfully build from XCode. I can package and run the client without error. However, I get the following error when I try to package the server: The requested value 'MacServer' was not found.

The only platforms that will actually cook are Mac and MacNoEditor. MacServer and MacClient fail with the same type of error.

The server returns: The requested value 'MacServer' was not found.

The client returns: The requested value 'MacClient' was not found.

I have tried a number of combinations here, but my cooking settings are currently as follows: Only

Under Package, I have tested 'Package and Store Locally', and 'Do not Package'. Neither setting seems to make a difference. Under deployment, I have tried changing the device variant from MacServer to MacClient, Mac, and MacNoEditor without success. Under Launch, I have tried launching as Dedicated Server and Standalone Client. Currently, my Deployment and Launch settings are as follows: alt text

I have also tested this process with a fresh project created from the C++ FPS template. The results are the same.

Product Version: Not Selected
Tags:
more ▼

asked Jan 31 '15 at 11:06 PM in Packaging & Deployment

avatar image

certifiedDoc
31 1 5 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Mar 24 '16 at 01:35 PM by Stephen Ellis for the following reason:

Issue is now outdated. If you are still experiencing this issue, please make a new post for assistance. Thanks


0 answers: sort voted first

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question