x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

LogStats:Warning: MetaData mismatch.

 LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FGenerationWorker///Thread_68c_0///////STATCAT_Advanced//// old //STATGROUP_Threads//FGenerationWorker///Thread_ce4_0///////STATCAT_Advanced////


Can you tell me please what is this about. And how can i get rid of these warnings messages? Thanks

Product Version: Not Selected
Tags:
more ▼

asked Feb 01 '15 at 06:48 AM in C++ Programming

avatar image

Azarus
1.9k 60 50 189

avatar image kShadowcraft Feb 13 '15 at 10:28 PM

I'm getting the same error. stuck on main menu. :(

avatar image Azarus Feb 14 '15 at 03:00 PM

The threads or objects has the same name. That's all.

avatar image RageCann0n Mar 05 '15 at 01:54 PM

@Azarus, what do you mean, and how to do you change it?

I'm having the same error in my Output Log for Launch. I'll build my scene with production lighting, but that build only works in Play Preview. In Editor Launch and .exe Launch it reverts to a previous light build at runtime then converts my scene back to that light build upon exit. Is it just a 4.7.2 issue?

avatar image VipAnderson Jan 27 '16 at 01:35 PM

the same error guys... please help me.. i just opened "Shooter Game" in editor, no change nothink, and just try to launch game... and error...

LogPlayLevel: Completed Launch On Stage: Build Task, Time: 0.751933 LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FLauncherTask///Thread_3c34_0///####STATCAT_Advanced#### old //STATGROUP_Threads//FLauncherTask///Thread_420c_0///####STATCAT_Advanced#### LogPlayLevel: Completed Launch On Stage: Build Task, Time: 0.000045 LogPlayLevel: BUILD FAILED PackagingResults:Error: Error Launch failed! Unknown Error

What i do? i read all post.. but really dont understand..

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

I got this error because i had multiple threads running with the same name. It shouldn't cause any problems thought.

https://docs.unrealengine.com/latest/INT/API/Runtime/Core/HAL/FRunnableThread/Create/1/index.html According to the documentation the second parameter should be unique for each thread instance.

 FRunnableThread::Create(RunnableObject, TEXT("UniqueThreadName"));

After giving an unique name for each thread i spawn the error dissapeared.

Edit: So many people looking for proper answer, so i update my answer.

This error happens when you have two or more threads, objects with the same name.

In my case i spawned multiple threads with the same name. To handle multiple tasks. (That was actually bad in general and pointless to spawn more than one thread in my case).

To generate an unique thread name for each task you want to perform you can use the "FThreadSafeCounter" object

 // Create a counter
 FThreadSafeCounter  WorkerCounter;
 
 // Increment the counter and create an unique name.
 FString ThreadName(FString::Printf(TEXT("MyThreadName%i"), WorkerCounter.Increment()));
 
 // Create the actual thread
 FRunnableThread::Create(RunnableObject, *ThreadName);


more ▼

answered Mar 05 '15 at 05:05 PM

avatar image

Azarus
1.9k 60 50 189

avatar image Goerge Carlin Aug 24 '15 at 05:17 AM

could you please tell me how exactly did you solve this?

avatar image Azarus Sep 03 '15 at 07:54 AM

I generated a different name for each thread.

avatar image spdemille Jan 05 '16 at 07:02 AM

which threads and where? i never start any in code or control any naming that i know of

avatar image Si Thu Jul 05 '16 at 10:38 AM

hi there, i am experiencing this issue, would you kindly be able to provide step by step instructions please? It will help a lot of users out here. Thanks.

avatar image Elggetto Jul 05 '16 at 02:01 PM

Could you expand on your answer please? We don't know how to give a different name to threads. And google didn't help me much. Thank you. :)

avatar image Azarus Jul 14 '16 at 08:00 AM

It's in my answer TEXT("Threadname?")

 FRunnableThread::Create(WorkerObject, TEXT("ThreadName Replace this string with an unique name")

avatar image Si Thu Jul 15 '16 at 01:45 AM

and where do we edit that thread name please?

avatar image Fredroxin Sep 22 '15 at 01:44 PM

how?! :c. Please help!

avatar image MuriloBeraldo Sep 29 '15 at 06:52 PM

Not meant to sound rude or anything...but what can be something obvious to you may be a complete blank for somebody else. I'm having the same issue for weeks now and whilling to find an answer. So please, if you guys could give a detailed solution to that it would be awesome.

Please T-T I'm really struggling because of this while launching to Android.

avatar image Azarus Oct 14 '15 at 12:53 PM

You have to give an Unique name to your objects.

avatar image spdemille Jan 05 '16 at 07:01 AM

unique name to which objects?

avatar image Azarus Feb 25 '17 at 08:04 PM

Its a question that i can not really answer. Sorry but how would i know what objects you have? You have to check your code and see if you give the same name for two objects or not.

avatar image spdemille Jan 05 '16 at 07:00 AM

i'm getting the same error. and i'm not ever starting any threads in code so i'm not sure what this renaming would be or where it would occur. i'm following the readme, it says to launch the html5launcher to start the server. then i open the main web page titled mygame.html. it never opens due to this error

avatar image 10xray1 Jan 25 '16 at 07:18 PM

I get this error too while launching a completely clean, no content, blank map. The only thing in the level is Fog, Floor, Light Source, Player Start, and Sky Sphere... as assigned by the engine for blank maps.

avatar image turanta Jul 27 '16 at 09:49 AM

I use 4.11.2ver and every my 11ver project all happen same error. but strangely I can package them and they can run rightly. but still I can't launch in editer

avatar image Si Thu Jul 30 '16 at 06:05 AM

yes thats right, i have been having this issue, and thats my work around too. but i still can't find how to fix it

(comments are locked)
10|2000 characters needed characters left

If I may? I think i have a solution. Did some digging on git and found FAsyncThreadIndex::GetNext(). It returns a unique int32. Here is how i used it. Hopefully this helps someone else!

 FString ThreadName = "Your_Thread_Name_Here_";
 ThreadName.AppendInt(FAsyncThreadIndex::GetNext());
 Thread = FRunnableThread::Create(this, *ThreadName, 0, TPri_BelowNormal);
more ▼

answered Feb 18 '17 at 03:42 AM

avatar image

StoneyBaloney7
6 2

avatar image Azarus Feb 25 '17 at 07:57 PM

I dont think that solution is safe to use. Tho you can use a FThreadSafeCounter struct to get an unique index for each thread. I updated my answer see above.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question