x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal Engine 4 starts very slow

Hello everybody,

I have a problem since the new updater came out. My Unreal Engine 4 takes a lot of time to start actually, I looked up in the tastkmanager what the "UE4Editor" is doing, but under memory Usage it stays for a very long time on the same value. It doesn't even change and under CPU it stays under "01". But it is first since the new UE4 Updater came out, before the new updater the engine started up very quick. I tried to launch the engine with the editor .exe and also with via the updater, nothing changes. Does anyone else have the problem? What could I do? Perhaps it is a bug?

My UE4 is placed on a SSD and it takes around 5-10 minutes to actually start. Also I tried to completely reinstall UE4, didn't work. Later when the engine started and is showing me the thumbnail it says "Initializing" and "Loading" and also this is taking a very long time around 5 minutes.

best regards

Product Version: Not Selected
Tags:
more ▼

asked Feb 02 '15 at 07:02 AM in Bug Reports

avatar image

frezer748
48 6 11 17

avatar image Rudy Q ♦♦ STAFF Feb 13 '15 at 08:05 PM

Hello frezer748,

After looking over your issue, I had a few questions for you that will help narrow down what issue it is that you are experiencing. This sounds similar to an issue that I had a few days ago.

Quick questions:

  1. Does restarting your computer have any effect on this issue?

  2. What version of the engine are you using?

  3. Could you provide us with your dxdiag?

  4. When you try and open the engine does it appear as though nothing has happened?

  5. Does project show up in your Task manager window?

avatar image frezer748 Feb 13 '15 at 09:41 PM

Hello Rudy, thank you for your reply first of all, I really appreciate it.

  1. No restarting my computer has no effect on solving this issue. It's getting even worse, because it looks to me that when I have to restart the engine it starts a little bit faster than when I start the engine for the first time the day. But it's not a huge difference.

  2. Currently I'm using the version 4.6.1

  3. I'm not sure if you're able to read it, because it's in german. So I don't know if it's a big help. But here is it anyway: http://i.imgur.com/0U6lkuX.png and http://i.imgur.com/dzdGehF.png the weird thing on the second image is, it shows only my intel card not my nvidia graphiccard. Here is also the text version(log in english) of the dxdiag if you wish: http://pastebin.com/kxs0DaZy

  4. So the launcher itselfs start quickly, but when I start the engine it looks to me like nothing is happening. First when I take a look at it in the task manager (process tab), it shows the process "ue4 editor" but the value (memory usage) stays at the same value unchanged and it takes a long time till it actually starts to increase and the engine startup windows appear, but the loading/initializing process also takes pretty long. 5.Yes my project itself shows up in the "application" tab in the task manager.

It looks to me also that the CPU isn't loading the process of the UE4. In the task manager under the tab "Processes" it shows under "CPU" the values "00" or sometimes "01", so it's not loading really something.

best regards

avatar image Rudy Q ♦♦ STAFF Feb 17 '15 at 07:27 PM

Hello frezer748,

How complex are the projects that you are trying to load up? I was speaking with a co-worker and they brought up an interesting point. We have a couple projects (such as Infiltrator) that can take up to 20 minutes to load up. Could this be the issue that you are experiencing?

avatar image frezer748 Feb 17 '15 at 08:52 PM

Hey Rudy, so I have 2 projects in my project list inside UE4. I would say one project is a little bit more complex, because of the amount of assets,shaders,maps etc. but it actually shouldn't be that huge that it takes this long. Also I usually start UE4 first and later I select and load the project from the project list when the window asks me if I want to create a new project or load an existing project. So it's not a certain project what needs to load this long, it's the engine itself.

best regards

avatar image frezer748 Mar 15 '15 at 10:13 PM

The problem is still existing in 4.7.2. Isn't there any solution for this problem? It is really annoying the editor needs almost 10 minutes to start up properly( especially the initializing, but also the loading)

best regards

avatar image Rudy Q ♦♦ STAFF Mar 16 '15 at 03:15 PM

Hello frezer748,

I have been looking into this issue and I have a couple of more questions for that may help narrow things down.

Quick questions:

  1. Does this occur if you try and open a the same project form another computer?

  2. Does the delay still occur if you launch from the project file?

The default path: C:\Users\YourUserName\Documents\Unreal Projects\YourProjectName

avatar image frezer748 Mar 16 '15 at 07:03 PM

Hey Rudy,

  1. No this actually only occur on my notebook, when I run it on my computer it work's great. The funny thing is actually that the notebook is faster than my computer except the graphiccard. But like I said it's not certainly the project which takes so long to load, it's also the engine itself.

2.Yeah it always takes very long, even when I start the project by the file or from the launcher. It's very strange.

One thing I forgot to mention, I've added some time ago to my "DefaultEngine.ini"following lines:

[InstalledDerivedDataBackendGraph] Boot=(Type=Boot, Filename=”/DerivedDataCache/Boot.ddc”, MaxCacheSize=512) Local=(Type=FileSystem, ReadOnly=false, Clean=false, Flush=false, PurgeTransient=true, DeleteUnused=true, UnusedFileAge=34, FoldersToClean=-1, Path=”/DerivedDataCache”)

I did this because UE4 always saved a lot of files on my SSD, the folder I mean is: C:\Users\Username\AppData\Locall\UnrealEngine . So I changed my DefaultEngine so it saves the files on my HDD not on my SSD. But like I said, it's not even the project which takes that long to loadup, it's also happen when I only start the normal UE4 without selecting a project.

best regards

avatar image Rudy Q ♦♦ STAFF Mar 16 '15 at 08:16 PM

Hello frezer748,

I was looking over your old post and I have a suggestion that you could try. I would like to know if setting the engine to run on the Nvidia card only will help speed things up.

You can do this by:

  1. Go to your Nvidia control panel (Right click desktop > Nvidia control panel )

  2. Click on Manage 3D Settings

  3. Click on Program settings

  4. Click the Add button and add the Unreal Engine

  5. Then go through all of the settings that say "Use global settings" and switch them to "Application-controlled" or "On"

This should tell your Nvidia card to kick in whenever the Unreal Engine is being used. Let me know if this makes any difference.

avatar image frezer748 Mar 16 '15 at 08:33 PM

Hey Rudy,

Well this also doesn't work, I did it exactly like you describe but nothing is changing. The "initializing" progress is still very slow. I really don't know anymore what the reason for that problem could be, I'm out of ideas. :(

best regards

avatar image Rudy Q ♦♦ STAFF Mar 18 '15 at 09:55 PM

Hello frezer748,

Would it be possible for you to send me a copy of your DefaultEngine.ini file that was changed?

avatar image Ranz Mar 16 '15 at 09:07 PM

Sorry, I didn't read much about your discussion. But did you try (If you have a dedicated graphics card) to re-assign UE4 to use your graphics card?

avatar image Missu Mar 18 '15 at 10:51 PM

This is because the engine compile its own materials and shaders in its folder. After a while it will be ok. I think this is a bug with the new version. Every time you start the engine it will compile again and again the same thing.

avatar image Missu Mar 25 '15 at 04:25 PM

Hey frazer why don't you reinstall the operating system...?

avatar image Missu Mar 19 '15 at 06:43 PM

I am really sorry maybe your operating system has something wrong...maybe in MSCONFIG --> BOOT --> ADVANCED OPTIONS you need to uncheck num of processor

avatar image Villason Mar 28 '15 at 08:32 PM

Same problem here. UE4 is great but I've never thought it was so buggy.

avatar image frezer748 Mar 29 '15 at 08:26 PM

Atleast I'm not the only one with the problem.

best regards

avatar image Roccinio Jun 11 '15 at 01:40 PM

Any news regarding this? 10 minutes to load my paper2d game? The log says that 99% of the 10 minutes is "discovering assets" . And my question is. Why Unreal searches for the same assets EVERY time i load my project?

avatar image Rudy Q ♦♦ STAFF Jun 11 '15 at 04:05 PM

Hello Roccinio,

Could you try launching the cmd argument -ddc=noshared and see if this helps with your issue? Are you in 4.7.6 or 4.8?

avatar image Roccinio Jun 11 '15 at 08:22 PM

Where should i run this cmd argument? Could you please explain it to me in a little more detail? Thank you

avatar image Rudy Q ♦♦ STAFF Jun 12 '15 at 02:15 PM

Hello Roccinio,

You will need to go to where your project is stored and create a short cut to the uproject and then you will need to open up its properties. Once there you will include a path to the engine that you are using within quotes at the beginning of the target path (please note: that you will need a space at the end of the engine path after the ending quotation and before the project path). You will then place the command after the project path. A space will be needed between the project path and the cmd argument. I have provided an example.

Example:

alt text

alt text

Below you will see an example of what the entire target path should look like.

"E:\Unreal Engine\4.7\Engine\Binaries\Win64\UE4Editor.exe" C:\Users\YourUserName\Desktop\MyProject\MyProject.uproject -ddc=noshared

Make it a great day

ddcachehelp1.png (25.8 kB)
ddcachehelp2.png (32.7 kB)
avatar image Roccinio Jun 12 '15 at 05:50 PM

Thank you for the detailed explanation! Unfortunately it makes no difference. It is not logical for a sprite only paper2d game to take 10 minutes to boot up from my ssd. There must be something else going on. It all started in 4.8 and in 4.9 it is still the same.link text

avatar image Urthrese Aug 17 '15 at 10:49 PM

did you ever find a solution for your slow startup?

avatar image Roccinio Aug 18 '15 at 12:23 AM

Nope. 99.9% of the 10 minutes it takes to load has to do with my persistent level that includes all my standalone levels.It makes no sense. For a sprite only project this is ridiculous. It appears that is rebuilding something every time I run it, because when I moved my project on purpose on a laptop to see if something's wrong with my pc it took 45(!) minutes to load. Now imagine 10 crashes a day with 10 minute loading times every time . It drives me crazy.

avatar image Urthrese Aug 18 '15 at 01:06 AM

oh man that sucks i'm so sorry. i was trying to find a solution for it myself and i know the feeling. it's driving me nuts right now.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi all,

We're not able to reproduce this internally, so I'd like to get a hold of a project that reproduces the problem for you if possible. Please upload a zipped project to someplace like Google Drive or Dropbox and get us a download link so we can take a look. You can send it to me privately on the forums, if you prefer:

https://forums.unrealengine.com/member.php?32-Ben-Halliday

Please make sure that we also have your dxdiag as well.

Thanks!

more ▼

answered Jul 14 '15 at 07:46 PM

avatar image Ben Halliday STAFF Jul 20 '15 at 04:37 PM

Hi all,

I'll go ahead and resolve this post until you have time to come back with a project we can reproduce this in. Thanks!

avatar image leonteale Dec 12 '16 at 11:57 AM

but it is stil lan open qustions. please see my new comment

avatar image Rudy Q ♦♦ STAFF Dec 12 '16 at 02:07 PM

Hello leonteale,

I do not see any other comments from you on this page. If you are experiencing this issue, could you provide a project so that we could reproduce this internally?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You need to change this inside your BaseEngine.ini: [InstalledDerivedDataBackendGraph]

Boot=(Type=Boot, Filename=”%GAMEDIR%DerivedDataCache/Boot.ddc”,MaxCacheSize=512)

Local=(Type=FileSystem, ReadOnly=false, Clean=false, Flush=false, PurgeTransient=true, DeleteUnused=true, UnusedFileAge=34, FoldersToClean=-1, Path=”%GAMEDIR%DerivedDataCache”)

more ▼

answered Mar 18 '15 at 10:53 PM

avatar image

Missu
305 13 8 28

avatar image Missu Mar 18 '15 at 10:54 PM

GAMEDIR will compile everything where you have located your project

avatar image frezer748 Mar 19 '15 at 06:57 AM

Hello everybody,

first of all thanks for the several answers. So I knew that it would save every shader,material etc. inside the project folder, when I changed this, I did this because I didn't want to have all the files on my SSD (C:) . So like I said, the project needs some time to load up and it really could be a bug like you said, but I'm not sure. Anyway the problem is not only the project itself, it's also the whole engine which takes that long to load up. So let's say I start the UE4 (4.7.1) out of the Epic Games launcher and than this loading process takes a very long time (where it says initializing and loading). When the window appear with the different projects than I select my project and try to load it also this takes some time(but I think it's not taking that long to load like the engine itself). So it's not only the loading of the proejct itself, which takes that long to load, it's also the startup of the engine.

PS: I will upload the DefaultEngine.ini file later today, currently I'm not at home.

best regards

avatar image Missu Mar 19 '15 at 07:01 AM

I had this problem with 4.5 but finally my hard drive was broken. Maybe this is your problem.

avatar image frezer748 Mar 19 '15 at 07:04 AM

Hey,

well it could be, but I think it isn't. My SSD and HDD are actually working pretty good so far, they still transfer the files very fast and also some tools shown me that everything is allright with my HDD/SSD, I already looked that up some days ago. :-(

best regards

avatar image Missu Mar 19 '15 at 07:08 AM

Or BAD RAM

avatar image Missu Mar 19 '15 at 07:10 AM

I will poste you a screenshot with my BaseEngine.ini....maybe will help

avatar image Missu Mar 19 '15 at 07:14 AM

alt text

avatar image frezer748 Mar 19 '15 at 05:01 PM

So here is my DefaultEngine.ini of the project itself:

http://www.file-upload.net/download-10440139/DefaultEngine.ini.html

avatar image Missu Mar 19 '15 at 05:41 PM

What version of engine you have?

avatar image Missu Mar 19 '15 at 05:45 PM

Ok I belive that you have to modify BASEENGINE.ini like in my picture (located inside your ENGINE folder not in YOUR PROJECT)

avatar image frezer748 Mar 19 '15 at 06:00 PM

Hey Missu, well I've already changed my BaseEngine.ini it actually haven't improved anything. I'm really wondering why UE4 always have to initialize that much and also over and over again, when you start the engine. The first time it takes very long to load is at 35%, in case this helps?

PS: Here is a screenshot of the BaseEngine.ini as well: https://i.imgur.com/ZDsHlmH.png

and here is also the DefaultEngine.ini file of my project: http://www.file-upload.net/download-10440139/DefaultEngine.ini.html (in case you didn't find it in the previous messages Rudy)

I currently use UE 4.7.2

Best regards

avatar image Missu Mar 19 '15 at 06:04 PM

Try to go inside BaseEngine and change bAllowAsynchronousShaderCompiling=False and NumUnusedShaderCompilingThreads=0

avatar image frezer748 Mar 19 '15 at 06:33 PM

Looks like it also doesn't work, this is so weird. But it has something to do with initializing the UE4 editor files I assume. Because it always need a long time to initialize the editor/engine and it looks like it have to regenerate it everytime I start the engine. Like you already said.

best regards

avatar image Rudy Q ♦♦ STAFF Mar 23 '15 at 08:24 PM

Hello frezer748,

When you start up a project do you see the full version number? It will look something like 4.7.3-2479750. Or do you see the shortened version of this number (4.7.3)? When a project is booted up for the first time it tends to take a little longer and it will show the full version number. If this full number is showing every time it would mean that you project may not be initializing incorrectly.

avatar image frezer748 Mar 25 '15 at 03:58 PM

Hey Rudy,

so I made a screenshot of the engine loading and the project loading window. So you will see it says 4.7.2.

Editor: https://i.imgur.com/TbE7ViX.png

Project: https://i.imgur.com/mDKlRjm.png

best regards

avatar image Rudy Q ♦♦ STAFF Apr 13 '15 at 07:10 PM

Hello frezer748,

Sorry it has taken so long to get back to you. I have been looking into your issue. After some digging I have found a known issue (UE-8439) that I am looking into that may be related to the issue that you are seeing. I also wanted to check in and see if any of the updates to the engine/launcher have made a difference in your situation.

avatar image Roccinio Apr 16 '15 at 08:52 PM

Same here! Paper2d project and since 4.8 it takes 5 sec to go to 95% and then it gets stuck there for 10 minutes until it finally loads up. Mind you that i have zero 3d stuff (like complex materials,lighting etc) that could warrant such a delay.

And another weird thing that i am positive that is related to the above issue is this:

When it finally loads up and i press play(standalone window or simulate) the preview starts in less than a second. Now if i change ANYTHING on an old BP that has references all over my game (by anything i mean even to uncheck a setting or to just edit a comment) then it takes 5 minutes(!!!) to start the preview .If i create a new blueprint with no references it lets me edit the crap out of it without affecting performance whatsoever .

It seems that there is a big bug hidden in there that re-calculates everything whenever we change something. This makes active development almost impossible.

avatar image Decadia Apr 18 '15 at 02:01 PM

Does UE4 use multiple cores?

Mine is running on 32GB RAM DDR3, 32 Core 3.4Ghz and 8(2x4) GBGDDR5 295x2 machine with upto 4Gbps speed SSD . And guess what...I have to wait about an hour for it to go through a simple import of a basic 4k poly geometry or when its doing it"processing outstanding changes 0 of 1" and it will remain frozen that way for awhile. It makes me wonder if its trying to use on board graphics instead of the real one since my on board is 16mb.

avatar image DRAHCIR1970 May 03 '16 at 01:56 AM

I am having this problem on my system. The default template projects seem to lock up when launching. The Engine editor takes forever to load.

avatar image Rudy Q ♦♦ STAFF May 03 '16 at 07:55 PM

Hello DRAHCIR1970,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. What engine version are you using?

  2. Is this this issue a new development?

  3. Could you provide your dxdiag?

  4. Are you using any plugins or devices?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question