x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't open some maps in 4.7 Preview 5

Well, I don't know what's really going on, some maps just aren't opening and keep coming up with this error: Zip2 They were working fine in Preview 4 (except for my map that had Instanced Foliage), but now the maps: Intro, World, Test, and ImageMap are not opening, the exception to these are my Menu map, Movie map and my Castle map that is a streamed level in the World map (the other streamed level I have,Village, however, does crash), some of these do not have BPs while the others do, Castle does have BP's and ImageMap might, so this may not be the reason for error, but its a start since the Error Log comes up with Template as the Crash Reason.

Product Version: Not Selected
Tags:
zip2.zip (6.0 kB)
more ▼

asked Feb 03 '15 at 11:37 PM in Bug Reports

avatar image

gmc
93 8 18 19

avatar image User-1420270633 STAFF Feb 06 '15 at 06:26 PM

Hi gmc,

Looks like you have some cyclic dependencies amungst your blueprints. With 4.7, we've made a concentrated effort to reorder loading such that it avoids issues like this.

As you can imagine, coming up with every cyclic Blueprint scenario is tough and it looks like you have one that we haven't seen before. Is there anyway that you can zip up your project so we can debug the scenario you're in?

avatar image gmc Feb 06 '15 at 08:54 PM

Will do! It is going to take a while to upload my entire project, however, unless you only need the Content folder or something.

avatar image Ben Halliday STAFF Feb 06 '15 at 08:57 PM

Hey gmc,

I've given Mike the copy I already had, so you don't need to worry about it. Thanks, though!

avatar image User-1420270633 STAFF Feb 06 '15 at 08:59 PM

I think Ben Halliday told me he already had the project from you, I'm getting it from him right now as we speak. I don't know how old the version he has is (and if you had made any significant changes since). I'll let you know if I hit your problem with what he has given me.

avatar image gmc Feb 06 '15 at 10:07 PM

O ok! If you do need a newer version just tell me, but I think that one should be fine!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Good news!

I already fixed this issue this morning. The commit can be seen here: https://github.com/EpicGames/UnrealEngine/commit/866f9150ec9b8e8ae2dd26d1805f6c68b6dfca1a

With this change, I was able to load up the MixamoCharacter_Master BP right away (without crashing), and without any compiler errors. I was also able to run Play-In-Editor.

Like I mentioned earlier, we've been trying to squash all cyclic dependency Blueprint bugs with 4.7. Thanks to users like you (who are trying out the preview builds, and reporting issues back to us) this is looking more like a reality. There were a couple holes that we missed in the initial implementation, but projects like yours have helped us find those issues.

My guess is that you have a web of interdependent Blueprints, one (or more) of which are UMG Blueprint assets (the hole we failed to fixed, and the fix I submitted today was aimed at UMG Blueprints). It seems to be working now, but keep in mind the more intertwined your blueprints are the longer it will be to iterate with them (they have to all load and refresh each other).

Hope this wasn't to much of a headache, and thank you so much for checking out the preview build (you saved us on a possibly embarrassing crash bug).

more ▼

answered Feb 06 '15 at 10:48 PM

avatar image

User-1420270633 STAFF
968 27 26 58

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey gmc,

I'm not certain what's causing this crash, so I've created a bug report and attached the crash logs and the project (UE-9114). I'll let you know as soon as I see an update.

more ▼

answered Feb 04 '15 at 08:16 PM

avatar image gmc Feb 04 '15 at 08:42 PM

So, I have some more information about this bug, I tried to open the MixamoCharacter_Master BP and the editor crashed with the same error (This is also true for all of its child BPs). I also tried to open my custom character BP I made for NPCs and it too crashed, however, the default character BP (MyCharacter) does not crash.

avatar image Ben Halliday STAFF Feb 04 '15 at 08:45 PM

If you remove the Mixamo content from the project, are you able to open these maps without crashing?

avatar image gmc Feb 04 '15 at 08:54 PM

Ok, deleting Both the Mixamo And my separate NPC BP (just a plain Character BP) worked for all of my maps, but my World map.

avatar image Ben Halliday STAFF Feb 04 '15 at 10:00 PM

Cool. I've added that information to the bug report. I would suggest trying to reimport that content and recreating the BPs. Most likely they were corrupted at some point, but I'll let you know when I see what the devs say.

avatar image gmc Feb 04 '15 at 10:28 PM

OK, I have even more info! I tried to open my HUD Widget BP that is directly influenced by the Mixamo and NPC BPs just to check if it was also corrupted, and sure enough, it crashed the editor with the same error! Deleting this let me load my World map, so now we have the 3 culprits for the error!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question