x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android debugger does not attach to device

I followed the "Set up Android" steps from the documentation, using the version of TADP that ships with the engine (2.0r8). Here are the steps I take to deploy my C++-based game to the device:

  1. Visual Studio: Build configuration Development Editor - Win64
  2. Run the UE4 editor (VS prompts for out of date build always but doesn't build anything if I ask it to build, another bug)
  3. UE4 editor: Package the game using File > Package > Android
  4. Command prompt: Run the Installer .bat file in the package directory to get the code and data initially uploaded to the device. At this point I can launch the game on my device but if it crashes or has other problems I have to rely on logcat and other primitive debugging methods.
  5. Visual Studio: Kill the UE4 editor with the "stop debugging" button.
  6. Visual Studio: Build configuration Development - Android
  7. Select Debug -> Step Into. (VS prompts again for out of date build, choosing to rebuild or not has no effect on the result)
  8. Tegra for Visual Studio startup dialog appears, and successfully steps through
    • Deploying application
    • Launching application
    • Pulling device files
    • Starting GDB server
  9. A dialog appears on the device stating that it is waiting to connect to the debugger.
  10. The Tegra dialog fails on "Starting Java Debugger" with the error message "Failed to attach: Invalid access to memory location."

I have tested on Nexus 7, Nexus 9, and Samsung Galaxy Tab S, all with the same problem.

Please improve the Android toolkit!

Product Version: Not Selected
Tags:
more ▼

asked Feb 04 '15 at 07:01 AM in Bug Reports

avatar image

ryani
57 9 14 30

avatar image [Epic] Gribbs ♦♦ STAFF Feb 04 '15 at 10:47 PM

Howdy ryani,

Thank you for reporting this issue. Would you happen to be using a newer version of Java on your machine? We have experienced this issue previously and updating to Java version 1.7 was causing this issue. We had to revert to 1.6, which is included with the TADP.

Let em know if this helps with your issue.

Thanks and have a great day!

avatar image [Epic] Gribbs ♦♦ STAFF Feb 09 '15 at 04:44 PM

Hey ryani,

Just wanted to check in with you and see if this has helped with this issue that you have been seeing. Be sure to let me know when you get the chance.

Thanks!

avatar image ryani Feb 10 '15 at 06:01 AM

I do have Java1.7 installed, but wasn't sure of the safest way to downgrade to 1.6 without breaking anything else on my machine. Instead I tried installing TADP3.0r4 from NVidia's website, and was able to successfully build and connect. I still have tons of problems debugging (bugs in the debugger), but am able to make slow progress. If you are free to share, I'd love to be connected with one of your Android engineers to talk about workflow and understand what your team has been doing to work on this platform.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey ryani,

Glad to hear that the issue has been resolved. As for the second part of the last comment, you are able to see what is currently being worked on and addressed via our Trello board and GitHub. This is going to be the most efficient way to figure out what is currently being addressed with a certain platform.

If the Github link is showing up as 404 link, you will have to create a Github account and connect it to you UE4 account. Here is some documentation on how to complete that task: https://wiki.unrealengine.com/GitHub_Setup

Thanks and have a great day!

more ▼

answered Feb 11 '15 at 06:46 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

ryani, did u find anyway to debug c++ code ?

more ▼

answered Jun 18 '16 at 07:54 AM

avatar image

Muzaheed
245 18 24 31

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question