x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[Crash] Unable to Convert/Load 4.6 Project in 4.7 built from GitHub (4.7p5)

I just opened a 4.6 project in my 4.7 build and it crashes. I've tried opening straight from visual studio as it is a C++ project which seems to convert fine and compile the sources fine. I've tried asking for an in-place conversion on a fresh copy as well as launching the C++ project straight from visual studio. They both produce the same error at 66% of load. I'm building from the 4.7 GitHub branch as of 20150203 (last commit: 5bac1375be31053932c7b9123cc3bb94c70dd5e0). I've also tried running: UE4Editor.exe -run=resavepackages -maxver=214 just in case that was necessary, no difference.

 MachineId:D47B853049B93D1BF2971CB4BB59413F
 UserName:user
 
 Access violation - code c0000005 (first/second chance not available)
 
 UE4Editor_Engine!UBlueprintGeneratedClass::FindArchetype() + 23 bytes [c:\github\unrealengine\engine\source\runtime\engine\private\blueprintgeneratedclass.cpp:262]
 UE4Editor_CoreUObject!UObject::GetArchetypeFromRequiredInfo() + 388 bytes [c:\github\unrealengine\engine\source\runtime\coreuobject\private\uobject\uobjectarchetype.cpp:53]
 UE4Editor_CoreUObject!ULinkerLoad::CreateExport() + 3692 bytes [c:\github\unrealengine\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:3271]
 UE4Editor_CoreUObject!ULinkerLoad::CreateExportAndPreload() + 27 bytes [c:\github\unrealengine\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:2503]
 UE4Editor_CoreUObject!ULinkerLoad::LoadAllObjects() + 589 bytes [c:\github\unrealengine\engine\source\runtime\coreuobject\private\uobject\linkerload.cpp:2583]
 UE4Editor_CoreUObject!LoadPackageInternal() + 2055 bytes [c:\github\unrealengine\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:896]
 UE4Editor_UnrealEd!UEditorEngine::Map_Load() + 5034 bytes [c:\github\unrealengine\engine\source\editor\unrealed\private\editorserver.cpp:2245]
 UE4Editor_UnrealEd!UEditorEngine::HandleMapCommand() + 349 bytes [c:\github\unrealengine\engine\source\editor\unrealed\private\editorserver.cpp:5676]
 UE4Editor_UnrealEd!UEditorEngine::Exec() + 797 bytes [c:\github\unrealengine\engine\source\editor\unrealed\private\editorserver.cpp:5176]
 UE4Editor_UnrealEd!UUnrealEdEngine::Exec() + 273 bytes [c:\github\unrealengine\engine\source\editor\unrealed\private\unrealedsrv.cpp:740]
 UE4Editor_UnrealEd!FEditorFileUtils::LoadMap() + 789 bytes [c:\github\unrealengine\engine\source\editor\unrealed\private\filehelpers.cpp:1910]
 UE4Editor_UnrealEd!FEditorFileUtils::LoadDefaultMapAtStartup() + 216 bytes [c:\github\unrealengine\engine\source\editor\unrealed\private\filehelpers.cpp:3070]
 UE4Editor_UnrealEd!FUnrealEdMisc::OnInit() + 2244 bytes [c:\github\unrealengine\engine\source\editor\unrealed\private\unrealedmisc.cpp:294]
 UE4Editor_UnrealEd!EditorInit() + 3254 bytes [c:\github\unrealengine\engine\source\editor\unrealed\private\unrealed.cpp:86]
 UE4Editor!GuardedMain() + 285 bytes [c:\github\unrealengine\engine\source\runtime\launch\private\launch.cpp:123]
 UE4Editor!GuardedMainWrapper() + 26 bytes [c:\github\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
 UE4Editor!WinMain() + 249 bytes [c:\github\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
 UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]
Product Version: Not Selected
Tags:
more ▼

asked Feb 04 '15 at 12:40 PM in Bug Reports

avatar image

druidsbane
187 11 21 171

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi hesham,

I have used the crash report you submitted and the callstack that you've provided here to generate the following bug report: JIRA [UE 9083]. If our developers can pinpoint the issue with this data, an update will be added to this post. (*Additional logs may be requested.)

Thanks

more ▼

answered Feb 04 '15 at 03:42 PM

avatar image druidsbane Feb 05 '15 at 04:27 AM

This is fixed with commit 5e2c37e695f24615d6bc9c5afecab557fe32e851. Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question