x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unable to package project 4.6

This is the message I'm getting when i try to package for 32 bit. Packaging also fails on 64 bit :s I've installed visual studio 2013 as some users suggested however with no effect. Any ideas what this could be?

http://pastebin.com/eWWaqaYv

Thanks

Joel

Product Version: Not Selected
Tags:
more ▼

asked Feb 05 '15 at 10:08 PM in Packaging & Deployment

avatar image

trias1995
40 8 6 10

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

I have no idea what platform are you trying to package? With the detail you provided seems like you want to pack for window only and play it from your desktop.

I finally can package with distribution. This software have a few platform can be pack. Development is for testing , Distribution is for sale in Apple or Google.

Before you do package it require to fill out the require detail. Take a look of below link. https://docs.unrealengine.com/latest/INT/Platforms/index.html

https://docs.unrealengine.com/latest/INT/Engine/Basics/Projects/Packaging/index.html#distribution

alt text alt text alt text

1.png (25.0 kB)
2.png (23.6 kB)
12.png (4.4 kB)
more ▼

answered Feb 06 '15 at 02:54 AM

avatar image

William8888
61 3 6 8

avatar image trias1995 Feb 06 '15 at 02:58 AM

Im packaging it for windows, either 32 or 64, it doesnt matter, its just a college project at the moment. I'll give those settings a go tomorrow but as of right now, i downloaded the UE 4.7 and am trying to package it in that, see if it makes any difference but ive looked just now and its failed so im going to shut down for the night but ill look over those settings and try that tomorrow :) Thanks for your help and ill let you know how it goes

avatar image trias1995 Feb 06 '15 at 08:24 PM

Okay ive followed the information you gave me and tried to cook it first and then have all the information filled in ETC but the cook still seems to fail? Any ideas?

avatar image William8888 Feb 06 '15 at 08:28 PM

Did you capture any photo with the way you failed? What i suggest is don't do anything include editing. Before you use the software test it first. You have to try which version is suitable for you and your computer. Many people didn't own good computer have different result. I mean try to open UE4.7 and use the original and package with it first and after it successful packaged it then do your project later. Otherwise it will wasting too many time. I just finish packaged with 32 bit here is the photo after you successful.

alt text alt text alt text

1.png (290.8 kB)
2.png (2.4 kB)
3.png (6.9 kB)
avatar image trias1995 Feb 06 '15 at 08:41 PM

alt text

avatar image William8888 Feb 06 '15 at 08:50 PM

You try again cook with stuff. Like the photo below if map 0 error. The screen will have similar like this below.

alt text alt text

2.png (437.8 kB)
1.png (272.9 kB)
avatar image trias1995 Feb 06 '15 at 08:59 PM

Same deal, ive' just cooked it and its still build failed :s

avatar image William8888 Feb 06 '15 at 09:07 PM

Did you start a new project and build it and pack it first ? if the base scene come with the software fail then reinstall the software. Otherwise would be something else. Sometime i keep verifiy the software. Preview 5 is a little bit worst then preview 4. Coz the provision file will disappear itself and some file i save it and it disappear. I recommended you use 4.6.1 and if you really need 4.7. edit it in 4.6 and make a copy in 4.7.

avatar image trias1995 Feb 06 '15 at 09:16 PM

No ive not moved it all over to a new project. there is a LOT to move over and moving it all over doesnt seem like the solution because, ive been speaking with some devs on a UE4 Group, and it seems like its a problem with some of my content. im going through it removing it now and then building then removing and repeating until i think its fixed

avatar image William8888 Feb 06 '15 at 09:21 PM

Your content don't make any sense. I mean just pack a new project with nothing adding into it. Not put anything you build and move it all inside. Just pack a brand new one and see if any error come out. You don't have to moved anything yet. If a brand new one have any error. You should know what to do.

avatar image trias1995 Feb 06 '15 at 09:26 PM

OH! i see what you mean! Just a moment then, sorry, i misunderstood you

avatar image trias1995 Feb 06 '15 at 09:29 PM

Its totally fine on a blank project so its the project and not the engine

avatar image William8888 Feb 06 '15 at 09:33 PM

pack it and see if it can be packed. Because if any content error which made by you. For example if the light problem. Once it builded packed and it failed it will show up map error or object error but it still can be packed in some case. Did you click the build button build it first before you packed?

avatar image trias1995 Feb 06 '15 at 09:58 PM

Ive packaged it and its all there fine! Thank you very much for your support! :)

avatar image trias1995 Feb 07 '15 at 07:40 PM

Ive managed to get it to cook properly. i had a bunch of crap in there that i had from like, downloading free .FBX models etc. i removed all instances of them from the world and then from the content folder one by one and built removing each one that it listed as being a problem and the cook was successful! Now to try package it :)

(comments are locked)
10|2000 characters needed characters left

what did you pack? Distribution or just development? I can't pack the distribution. But for development is ok. Did you fill out all the stuff and run the cook before you pack the stuff?. if not it could be happen.

more ▼

answered Feb 06 '15 at 01:41 AM

avatar image

William8888
61 3 6 8

avatar image trias1995 Feb 06 '15 at 01:45 AM

Ive tried both dev and dist. Fill out all the stuff and run the cook? Im sorry i dont quite know what you mean by that, could you elaborate a little please?

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question