Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.8 Promoted Build, Unable to Hot Reload

I haven't been able to use hot reload in the promoted build, not exactly sure why that is so I can't provide much information about what I may be doing wrong, but here is the output log that I get, note the line about the file not being found, unsure of what is causing the disconnect between the Unreal editor and Visual studio.

 Recompiling TurnBasedStrategy...
 Building UnrealBuildTool...
 Building UnrealBuildTool in E:/Engine Versions/UnrealEngine-promoted/...
 Running: C:\Windows\system32\cmd.exe /c "E:\Engine Versions\UnrealEngine-promoted\Engine\Intermediate\Build\UnrealBuildTool\BuildUBT.bat"
 Launching UnrealBuildTool... [E:/Engine Versions/UnrealEngine-promoted/Engine/Binaries/DotNET/UnrealBuildTool.exe TurnBasedStrategy -ModuleWithSuffix TurnBasedStrategy 5483 Win64 Debug -editorrecompile -canskiplink "E:/Unreal Projects/TurnBasedStrategy/TurnBasedStrategy.uproject" ]
 Warning: Starting HotReload took 12.5s.
 CompilerResultsLog: New page: Compilation - Feb 5, 2015, 1:49:11 PM
 CompilerResultsLog: Info Compiling game modules for hot reload
 CompilerResultsLog: Info Target is up to date.
 LogMainFrame: MainFrame: Module compiling took 13.414 seconds
 LogModuleManager:Warning: ModuleManager: Unable to load module 'TurnBasedStrategy' because the file 'E:/Unreal Projects/TurnBasedStrategy/Binaries/Win64/UE4Editor-TurnBasedStrategy-5483-Win64-Debug.dll' was not found.
 Warning: HotReload failed, reload failed /Script/TurnBasedStrategy.
 LogContentBrowser: Native class hierarchy populated in 0.0322 seconds. Added 1799 classes and 281 folders.
Product Version: Not Selected
more ▼

asked Feb 05 '15 at 11:55 PM in Bug Reports

avatar image

61 7 12 17

avatar image Cidubic Feb 10 '15 at 12:05 AM

Is this an uncommon error, a common error? Seems odd that the system working to create the new compiled version can't find the version it just compiled.

avatar image Byte1 Feb 10 '15 at 12:17 AM

Does the DLL it is looking for, actually exist where it is located?

Is that 5483 number something that you specified somewhere or engine generate that?

avatar image Cidubic Feb 10 '15 at 12:30 AM

That's engine generated, I'll try removing the list of current files in the directory its looking in and see if its just a duplication issue.

avatar image Cidubic Feb 10 '15 at 12:52 AM

Alright, so when I try to recompile using the editor, which is where I get the failed hot-reload message its looking for a file that doesn't get created, not sure if that means the compiler isn't getting connected to, or what-not, and when I compile in VS it is creating a .dll in the file link:

Vs Library File: E:\Unreal Projects\TurnBasedStrategy\Intermediate\Build\Win64\ TurnBasedStrategyEditor\Debug\UE4Editor-TurnBasedStrategy-3940-Win64-Debug-4966.lib

Vs Object File: E:\Unreal Projects\TurnBasedStrategy\Intermediate\Build\Win64\ TurnBasedStrategyEditor\Debug\UE4Editor-TurnBasedStrategy-3940-Win64-Debug-4966.exp

That is different from the file location that the in-editor compiler is looking at:

E:/Unreal Projects/TurnBasedStrategy/Binaries/Win64/ UE4Editor-TurnBasedStrategy-1488-Win64-Debug.dll

avatar image Martin Egger Feb 10 '15 at 01:00 AM

I work also on the current Promoted Build and with my project everything works fine.

I have one question, is your intention to work in the Debug Build correct? Or did you Build your Editor with Development and now somehow things in VS are in Debug Build?


avatar image Cidubic Feb 10 '15 at 01:05 AM

My intention was to work in the Debug version, so that when I make mistakes I have the engine to walk through, I find it easier to tell what I did wrong in many cases when I do that. Does Debug Editor not work with HotReload?

I've built both my editor and my game project using the Debug Editor profile.

avatar image Martin Egger Feb 10 '15 at 01:10 AM

I personally don't know if that is the case. I will give it a try since I never work in Debug Editor. In DebugGame Editor works fine. Need about 30 mins until it compiles my Debug Editor and than I will give a short feedback if Hot Reload worked allright.

avatar image Cidubic Feb 10 '15 at 01:14 AM

Alright, thank you very much, sort of hope that it doesn't work for you so that my editor isn't just incompetent and that there actually is an issue :P

avatar image Martin Egger Feb 10 '15 at 01:35 AM

Need to disappoint you works fine with me. I assume you did a full recompile etc.?

avatar image Cidubic Feb 10 '15 at 01:40 AM

Multiple times, on multiple drives, with multiple different engine versions. :/

avatar image Martin Egger Feb 10 '15 at 02:13 AM

Its a bit late here (3 am) but if you could provide your project somehow than I will take a look when I got some sleep, perhabs someone else might jump in but if you can wait I will try to see how it works at my end, but would like to do that after some good night sleep

avatar image Cidubic Feb 10 '15 at 02:21 AM

Alright thank you, I'll set something up and send you a message to a link.

avatar image Cidubic Feb 10 '15 at 03:57 AM


Hopefully that should work, if you can't use the link, just tell me

avatar image Byte1 Feb 10 '15 at 04:11 AM

Remove the SDF file and the Intermediate Folder, itll shrink the whole thing by a large amount of space

avatar image Cidubic Feb 10 '15 at 03:35 PM

Alright, thank you for the advice, I removed both of those files/folders.

avatar image Tim C ♦♦ STAFF Feb 27 '15 at 04:57 PM

Hi Cidubic,

Sorry for taking so long to respond to your post. I just tried to reproduce this issue in the latest promoted version (from changelist 2455917) and actually ran into some breakpoints instead of the issue that you described. Do you recall at what point you synced to the promoted branch on GitHub?

Also, does this happen only with your project, or are you able to see the same results in a new project?

The promoted branch on GitHub receives only minimal testing, so it should not be considered a stable build for project development. It is generally more stable than the master branch, but it can still be prone to errors and crashes.

avatar image Cidubic Feb 27 '15 at 10:00 PM

[Promoted CL 2446589 in Main branch] Was the promoted built that I was working with at the time, I believe I tried hot reload with the build before that as well. I was able to create the issue from a blank project after adding in some code as well.

I do understand that the promoted branch isn't meant to be used as a stable build.

avatar image Tim C ♦♦ STAFF Mar 02 '15 at 09:40 PM

I tried again on our internal Promoted build from CL 2446589 (which, in theory, is the same as what you pulled from GitHub). When I built the project using Debug Editor configuration, I was not able to open the project in Visual Studio's debug environment. I hit a critical error break point when trying to load.

I also completely built the project using Debug Editor configuration and opened it outside of Visual Studio. I added several lines of code to a project and performed a Hot Reload and the reload completed successfully. Would you be able to clarify exactly how you are setting up your test project where you are seeing these results?


avatar image Cidubic Mar 03 '15 at 06:43 PM

If you look at the comments below I managed to get the hot-reload to work once at the start of opening the editor too, the problem then became that it would fail on the second attempt to use the hot-reload feature.

avatar image Tim C ♦♦ STAFF Mar 09 '15 at 07:01 PM

I still have not been able to reproduce this issue. However, I ran my test again today using our latest promoted version (from CL 2471062) and did not see any of the crashes or breakpoints that I had been running into previously. I am curious to find out if this version also resolves the issues that you were experiencing.

If not, could you provide some additional clarification for this issue?

  • From reading the rest of the post, I have gathered that you are using a modified version of the Turn Based Strategy sample project. How extensively have you altered it?

  • Does this issue occur regardless of what kind of changes you are making to the source code?

  • Are you always initiating the hot reload by clicking the Compile button in the Editor?


avatar image Martin Egger Feb 27 '15 at 10:04 PM

I am also a bit confused as it was promoted us such:

 > The promoted branch is updated with
 > builds for our artists and designers
 > to use. We try to update it daily
 > (though we often catch things that
 > prevent us from doing so) and it's a
 > good balance between getting the
 > latest cool stuff and knowing most
 > things work.

I was assuming this would be the case. Now I don't experience a lot of breaking stuff and as stated before it worked for me.

Sorry for the offtopic.

avatar image Tim C ♦♦ STAFF Mar 02 '15 at 09:58 PM

Hi Martin,

The Promoted build is what our development teams use internally. However, it only receives a basic test pass before being marked as Promoted. It is nowhere close to the in-depth testing that our release versions go through. Because of this difference, we expect the Promoted builds to occasionally have issues. It is certainly possible to develop a project using the Promoted build, but the most recent release version will generally be much more stable.


avatar image Martin Egger Mar 02 '15 at 10:01 PM

Hey TIm thanks for clarifying. I will remain for my project on Promoted as I really don't have a lot of issues and works smooth and I always can go back to a stable changelist (from my perspective) since I always backup and push to github when a new changelist comes along.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Cidubic,

We have not heard back from you for a few days. Do you still need help with this issue? I will be marking this issue as resolved for tracking purposes, but please feel free to re-open this issue at any time if you need any additional help.


more ▼

answered Mar 16 '15 at 06:40 PM

avatar image Cidubic Mar 16 '15 at 07:29 PM

Sorry about not responding, since the 4.7 release I just decided to start working with the stable 4.7 binary and I haven't had any of these issues. Hot-reload is working properly for me, the major difference is that I'm using the binary build at this point in time, rather than compiling off of the github source. I feel no need to cause myself unnecessary grief by trying to mess with that version anymore, so I dropped off this conversation, sorry for not closing it up. I'm happy with the binary build since it now supports proper debugging.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey Cidubic

Sorry it took so long. I quickly made a test and it worked out for me.

I first regenerated the Project and than did a Build from the Debug Editor. I created a Shortcut to start the Debug in standalone, changed some of the Source Code and than did a Hot Reload.

alt text

more ▼

answered Feb 10 '15 at 09:10 PM

avatar image

Martin Egger
388 17 10 29

avatar image Cidubic Feb 10 '15 at 09:52 PM

Huh, okay very lost, I followed the steps you wrote about above, and I got it to work (yay). But then I changed something else and tested the hot-reload again, the second time it failed.

I then closed UE4 and VS, opened UE4 (only ue4 open at this point) tried to hot-reload, still failed, then I close UE4, reopened UE4 rebuilt VS files, tried hot-reload (only ue4), it failed.

Then I closed everything, opened UE4 refreshed VS files, opened VS, tried the hot-load, it worked again, like the first time, then I changed some stuff and it failed on the second try.

Now I closed both, reopened UE4, refreshed the files, opened VS, tried the hot-reload and it failed.

Very unsure of what exactly is going on, each failure results in a Warning like the one above about being Unable to load the module because the file was not found.

avatar image Cidubic Feb 10 '15 at 10:03 PM

Also after that process when I went to go recompile in VS instead of my standard output I got the following: http://pastebin.com/A22uTkQW

avatar image Martin Egger Feb 10 '15 at 09:54 PM

Even though I don't know if its going to help but what about deleting Intermediate and Saved and than re-generate the Project? Don't to forget to save away in the Saved Folder things you would like to keep such as ogs.

avatar image Cidubic Feb 10 '15 at 10:02 PM

Just to make sure when you say re-generate the project you are referring to regenerating the VS project files, no?

avatar image Martin Egger Feb 10 '15 at 10:05 PM

yeah right click and generate project files which also creates saved and intermediate. Since those two are always created I would delete them to see if it fixes the problem. And as said if you ave some of the Saved Backups and Logs you want to keep than just move those two folder for testing if it works out.

avatar image Cidubic Feb 10 '15 at 10:08 PM

Alright, I've recreated the solution, going to do a solution recompile and then test to see if deleting saved, intermediate and the SDF make any difference.

avatar image Cidubic Feb 10 '15 at 10:26 PM

Nope, Just followed through and once again, the first hot-reload works but then the second fails. In the case that anyone knowledgeable / a developer stumbles upon this question i'm posting the entirety of the output log below:


Thank you for trying to help Martin, sorry my configuration is being unruly.

avatar image Martin Egger Feb 10 '15 at 10:28 PM

Hey oh man... I am really sorry I can't be more of a help. I might test it tomorrow again but I hope maybe a Staff Member will hopefully step in and might be of support.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question