x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

packaging project results in black screen

So I'm trying to export a test scene using file>package project>windows. This file works great when I play in the editor or click the launch button, but packaging the project results in a black screen. Any reason why it's doing this?

Also, how do I package a project for 64bit, rather than 32bit? Right now the only folder in the Binaries is win32. Any help would be appreciated, Thanks!

Product Version: Not Selected
Tags:
more ▼

asked Mar 24 '14 at 05:29 AM in Packaging & Deployment

avatar image

actual
51 9 16 14

avatar image LordMorin Jun 15 '15 at 06:49 AM

For anyone else banging their head against the wall, maybe you had the same problem I had. It appears that naming your custom entry map Entry, even if it's your content browser, will cause this issue. I'm guessing this is because Epic already has a map named Entry and it somehow conflicts.

I ended up changing my entry map name to MainMenuLevel to avoid this project.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

When you say 'packaging project results in black screen', I assume you mean that when you launch the packaged project, it opens in a black screen. If that is the case, it sounds like you might not have a startup map configured in your project settings, and what you are seeing is the empty Entry.umap, which is the default map that has nothing in it.

You can verify this by activating the in-game command console (bound to Tilde '~' by default). If the console opens, you can type the following to load your new map: open name_of_your_map

To change the default map that is loaded on startup, go to Edit -> Project Settings -> Maps & Modes (I believe), and change your Default Maps. Also make sure to hit the 'Save as Default' button when done, so that these settings are applied to packaged projects as well.

more ▼

answered Mar 24 '14 at 05:41 AM

avatar image actual Mar 24 '14 at 07:44 AM

Thanks for the help.

btw, there's no console in the packaged game(tilde doesn't do anything). Is there a way to access it?

avatar image Ben Halliday STAFF Mar 24 '14 at 06:04 PM

Hey actual,

The tilde key should open the console in a packaged game. Have you tried packaging one of our sample projects, or a new project, and pressing tilde in game?

avatar image actual Mar 25 '14 at 10:00 AM

Yep. I had the game on ship :\ thanks

avatar image Arthur Khusnutdinov May 31 '15 at 09:01 AM

Thank you!

avatar image UsdBookstore Feb 22 '18 at 12:28 PM

Problem solved - Thank you so much! :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question