x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Textures look washed out in viewport but not in material editor

Textures on all my assets look washed out for some reason.

Here is the original texture:alt text

and here is the in viewport asset with the texture on it: alt text

The Material is just the diffuse with an alpha mask and nothing else plugged in. Its the default 3rd person template with no added post process stuff or lighting.

Product Version: Not Selected
Tags:
texture.jpg (24.3 kB)
washedout.jpg (47.9 kB)
more ▼

asked Feb 07 '15 at 10:00 AM in Using UE4

avatar image

KrunkFu
218 13 12 24

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hello KrunkFu,

If you are using Lightmass, try changing the 'Environment Color' to Black instead of White. This could be what is washing out your material in the world.

Cheers,

Andrew Hurley

more ▼

answered Feb 07 '15 at 08:38 PM

avatar image KrunkFu Feb 07 '15 at 09:23 PM

It was set to white so I reset all lightmass settings and rebuilt lighting but it made no difference at first. I started a new project in the newest preview build and reimported some stuff to see if there would be a difference and there was.

There was and it looks better. I went back to the old version and everything was fine in there too. It must have been the lightmass settings but I don't know why it didn't show up properly after building lights.

alt text

Thanks for the help!

better.jpg (62.6 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You need to play with the roughness input, try a full black (vector 1 set to 0) which will make it look way less washed out. Dont forget that on import the texture might have been set to SRGB so double click on the texture (not the material) and see if that changes anything.

Let me know if you need more help.

more ▼

answered Feb 07 '15 at 06:30 PM

avatar image

Luos
9.3k 286 64 330

avatar image KrunkFu Feb 07 '15 at 08:15 PM

It isn't as washed out with a value of 0 in roughness but it is very reflective and thats not what I need for this. SRGB is unchecked and in the material its set to linear color but that made it just as washed out in the material editor as it is in the viewport.

avatar image Jargon Feb 07 '15 at 10:11 PM

You may also want to make sure it has a reflection capture actor near it, that helps to remove the blueish sheen on materials.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question