x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Realtime compilation fails

Hi I have problem with realtime compilation, I use compile button in editor. I can successfully compile engine from source code, I can successfully compile my project, but every attempt of realtime compilation within editor fails.

Also during compilation there comes popup saying: MSVCP120.dll is missing from your computer. I have visual studio 2013 installed and even tried to manually install Visual Studio 2013 redistributables. None of this works for me.

I do not change header files and i do not add any additional functions. I just comment one line and click on compile, still does not works for me :(

I offer my eternal gratitude for any advice ;)

I am using Windows7 64x

This is what compile log says:

 Info rc.exe TestProject.rc
 Error D:\dev\workspace\UnrealProjects\TestProject\Source\TestProject\Resources\Windows\TestProject.rc(11)  : fatal error RC1015: cannot open include file 'windows.h'.
 Info -------- End Detailed Actions Stats -----------------------------------------------------------
 Info ERROR: UBT ERROR: Failed to produce item: D:\dev\workspace\UnrealProjects\TestProject\Binaries\Win64\UE4Editor-TestProject-3492.dll
 Error Cumulative action seconds (4 processors) : 0,00 building projects, 7,04 compiling, 0,00 creating app bundles, 0,00 generating debug info, 0,00 linking, 0,00 other
 Info UBT execution time: 29,59 seconds
 
Product Version: Not Selected
Tags:
more ▼

asked Mar 24 '14 at 09:40 AM in C++ Programming

avatar image

Ypsylon
96 2 6 4

avatar image dreamhole May 28 '14 at 02:11 PM

Hi, I have same error on VS Express 2013:

1>------ Build started: Project: CTestFly, Configuration: Development_RocketGame x64 ------ 1> rc.exe CTestFly.rc 1>D:\Progs\Unreal Engine\MyProjects41\CTestFly\Source\CTestFly\Resources\Windows\CTestFly.rc(11): fatal error RC1015: cannot open include file 'windows.h'. 1>
1> PCH.CTestFly.CTestFly.h.cpp 1>D:\Progs\Unreal Engine\4.1\Engine\Source\Runtime\Core\Public\HAL\PlatformIncludes.h(8): fatal error C1083: Cannot open include file: 'new': No such file or directory 1> -------- End Detailed Actions Stats ----------------------------------------------------------- 1>ERROR : UBT error : Failed to produce item: D:\Progs\Unreal Engine\MyProjects41\CTestFly\Binaries\Win64\CTestFly.exe 1> Cumulative action seconds (8 processors): 0,00 building projects, 0,25 compiling, 0,00 creating app bundles, 0,00 generating debug info, 0,00 linking, 0,00 other 1> UBT execution time: 7,16 seconds 1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command ""D:\Progs\Unreal Engine\4.1\Engine\Build\BatchFiles\Build.bat" CTestFly Win64 Development "D:\Progs\Unreal Engine\MyProjects41\CTestFly\CTestFly.uproject" -rocket" exited with code -1. ========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You can't build your project via Visual Studio while it's loaded in engine, either close editor and build it, or click Compile in editor. But there's a huge limitation in current hot-reload functionality, you would need to close editor if you've changed something in header files. For more information about it check forums, it was discussed somewhere, can't give link, sorry.

more ▼

answered Mar 24 '14 at 09:54 AM

avatar image

BiggestSmile
1.6k 54 38 105

avatar image Ypsylon Mar 24 '14 at 10:05 AM

Thanks for answer, i am using compile button in editor, i do not change header files, do not add any new functions as i come across similar problem, where this malfunction was caused by changing header file or adding additional functions, but even when i just comment one line in already existing function it fails. I hope realtime compilation is possible cause it will be much more easier to tweak code and values using it :-)

avatar image BiggestSmile Mar 24 '14 at 10:11 AM

Hm, strange, it works fine for me. Though i can't open project VS solution via editor while others can, seems like everybody experiencing various problems :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question