x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Bug? Source Control button is green despite failing to connect

The Source Control icon (top right corner <4.7, above viewport in 4.7) will display as green when running with source control but it hasn't successfully connected to it and red when not running with Source Control.

Is this the expected behaviour? If so, we could get a third icon that indicates that Source Control is being run but hasn't connected, maybe in yellow.

Product Version: Not Selected
Tags:
more ▼

asked Feb 09 '15 at 12:40 PM in Everything Else

avatar image

Jimmy_Jazz
66 11 16 23

avatar image Tom Sarkanen STAFF Feb 09 '15 at 01:25 PM

Hi,

This should be the case already - there is a yellow icon that does just this. What situation are you encountering this with?

avatar image Jimmy_Jazz Feb 09 '15 at 01:43 PM

I've never seen that option before.

I connect to a P4 server via the internet on a daily basis and always get a green icon for Source Control, even when the IP address for the P4 server is no longer valid and a connection is not made when the editor is first opened.

I'm currently using 4.7p5, but have had this probelm on 4.5 & 4.6.

avatar image Tom Sarkanen STAFF Feb 09 '15 at 02:00 PM

Thanks for the info, I've logged an issue to take a look. For reference the issue number is UE-9435.

If you can provide a log of your editor startup when this situation occurs it would be most helpful to us when we investigate it. We tested the yellow icon's behavior for regressions when the icon moved to the main toolbar but did not find any issues internally.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I've not had this issue since moving to 4.7p6 and onwards.

more ▼

answered Feb 19 '15 at 12:35 PM

avatar image

Jimmy_Jazz
66 11 16 23

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question