x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7.2] Editor Crashes on Converted Project With Instanced Static Meshes

Branch:

inary/Launcher


Build version:

ersion 4.7.2


Detailed description of the issue:

When opening my project in 4.7 - the splash screen gets to 95% Initializing before crashing.


Repro Steps

Action 1: Create a content-only project in 4.6.1

Action 2: Create a blueprint which adds instanced static meshes via the construction script.

Action 3: Place Blueprint in a specific map

Action 4: Build Lightmass

Action 5: Convert project to 4.7

Action 6: Open map with previously created Blueprint

Action 7: Witness Crash


System Specs:

  • Windows 8.1

  • AMD FX 8350

  • AMD 2x 7970 Crossfire

  • 16GB DDR3 RAM

  • 2x 7200RPM HDDs in Raid-0


Product Version: Not Selected
Tags:
more ▼

asked Feb 09 '15 at 03:07 PM in Bug Reports

avatar image

Kenomica
434 40 40 46

avatar image TJ V ♦♦ STAFF Feb 11 '15 at 04:50 PM

Hi Kenomica,

I attempted to reproduce this but so far my projects have converted correctly. You said to create a 4.6.1 project 'with content' but are you using a template or just a blank project?

avatar image Kenomica Feb 11 '15 at 05:06 PM

By content only - I mean a blueprint-based project. This is my main project that I've been working on for several months. This project was originally the TPP Template, but over several months has been completely changed.

It seems to be isolated to this project only, as I can convert other projects fine.

I wish I could provide a crash callstack to see what's going on, but sadly none is provided.

avatar image TJ V ♦♦ STAFF Feb 11 '15 at 05:19 PM

I'll continue to try to reproduce the error, but please keep in mind that we do not recommend upgrading a project to the 4.7.0 Preview unless it is just for testing/feedback purposes. Until it's official release the preview build is considered unstable for development.

avatar image Kenomica Feb 11 '15 at 05:30 PM

Thank you. I haven't converted my project in place, it has always been as a copy. So I still have the original 4.6.1 version as I'm aware of this - I am purely doing this for testing new features / reporting bugs.

avatar image TJ V ♦♦ STAFF Feb 11 '15 at 06:04 PM

I'm glad to hear it, I just wanted to be sure. :)

avatar image TJ V ♦♦ STAFF Feb 11 '15 at 07:33 PM

Hi Kenomica,

I attempted to reproduce this with some of my older projects that have been converted multiple times but without luck. So this seem to be confined to your main project and it could be caused by the general instability of the Preview build.

Preview 7 will be out soon. Once it is you could try retesting your project then.

If it still crashes, would you be willing to send me your project? If I can get a repro internally I can then make a report. If you are comfortable with that, you could send it by private message over the Forums.

Cheers,

TJ

avatar image Kenomica Feb 11 '15 at 07:40 PM

Yeah, this project has been converted from every iteration since 4.1.

I will certainly try preview 7 when released, and if it's still crashing I'll send you a portion of the project.

I think if I were to send the full thing you'd be waiting until 4.9, my net is that slow haha.

Thanks for the support.

avatar image Kenomica Feb 12 '15 at 06:44 PM

I gave Preview 7 a try - and almost the same thing happened - however this time it reaches 95% before the crash occurs, and even better - a callstack was generated!

Callstack

callstack.txt (5.5 kB)
avatar image TJ V ♦♦ STAFF Feb 12 '15 at 08:39 PM

Anything extra is good. Could you post the Log and Dmp files that generated with the new crash?

https://wiki.unrealengine.com/Locating_Project_Logs

avatar image Kenomica Feb 12 '15 at 10:10 PM

Sadly I no longer get a callstack or a DMP file. It seems it hard crashes before having the chance to generate either.

The callstack only appeared the first time after installing preview 7 (and I've tried multiple times since then by deleting the cloned project and trying again)

Even the log file seems incomplete, but here it is : LOG

I will uninstall and reinstall 4.7 Preview 7 in the hopes I can get a DMP file

dinosaurrun.txt (8.2 kB)
avatar image Kenomica Feb 18 '15 at 03:26 AM

Same exact behaviour in preview 8

avatar image TJ V ♦♦ STAFF Feb 19 '15 at 09:22 PM

Hi Kenomica,

I'm sorry that it's been a few days. I have entered this as JIRA UE-10157 in our tracking software and our developers will be investigating the issue further.

We will post back here as soon as we have an update.

Cheers,

TJ

avatar image Kenomica Feb 24 '15 at 07:37 PM

Gave it a try with the RC of 4.7 - exact same situation.

though I have a callstack, log and DMP to show which will hopefully help.

Callstack

Log and DMP

callstack.txt (5.5 kB)
log&dmp.zip (49.8 kB)
avatar image Kenomica Feb 27 '15 at 05:55 PM

Happens still with 4.7.1

avatar image Kenomica Mar 04 '15 at 11:53 PM

I have updated the original question with more information after some users on the forum found what could be the cause.

avatar image VSZ Mar 11 '15 at 10:34 AM

Hi. can someone from Epic comment if there's already a UE JIRA logged for this?

This is a pretty major issue IMO as it effectively prevents any use of static instanced meshes in a map.

Also, to add to Kenomica's reproduction steps I want to clarify that the issue manifests only if lighting has been built. i.e. if you spawn instanced static meshes in your construction script but do not build lighting your level will load fine in 4.7. However, once you build lighting you will no longer be able to open the map the again.

I suspect InstancedStaticMeshComponentInstanceData/FLightMapInstanceData related code in InstancedStaticMesh.cpp is causing this crash (although admittedly I'm not familiar enough with these engine classes to be sure)

avatar image TJ V ♦♦ STAFF Mar 13 '15 at 01:13 PM

Hi VSZ,

I entered JIRA UE-10157 for this issue but we haven't been able to reproduce this in-house. I will try to see if I can get a repro with your additional steps. If I'm unable to, would you be willing to send a stripped down test project that has the issue?

avatar image VSZ Mar 13 '15 at 04:08 PM

Hi TJ Ballard, the project which I shared with you for an unrelated bug during 4.7 preview should also come handy in reproducing this You just need to turn 'Force Precomputed lighting' off in that level, build lighting once and try to restart the editor. In fact I had disabled lighting back then to circumvent this very issue.

Let me know if that doesn't work out in which case I'll try preparing a repro project.

avatar image TJ V ♦♦ STAFF Mar 13 '15 at 07:18 PM

Your other project that you sent awhile ago has the compile errors that we discussed as well as being a much more complex project. If you could try creating a new project that repro's the issue, that would help a lot. I tried it again with your steps added but so far no luck.

avatar image VSZ Mar 13 '15 at 09:35 PM

Hmmm thought it wouldn't have had any compiler errors after 4.7.1 fixes, but no matter. I'll post an update tomorrow (it's pretty late where I live now).

Kenomica - feel free to upload a repro project as well if you have a suitable one.

avatar image Kenomica Mar 14 '15 at 05:41 AM

Uploading a repro project now. Very lightweight and simple,

Two maps : a blank one and one containing a BP that creates instances via the construction script.

It will crash when you open the InstanceMap.

Repro Project


Steps to reproduce :


Action 1 : Create a new map

Action 2 : Place the "Floor" blueprint in the map,

Action 3 : Build lighting on the newly created map

Action 4 : Open a blank map, or restart the engine,

Action 5 : Reopen the map with the Floor BP that you just built lighting for.


avatar image TJ V ♦♦ STAFF Mar 14 '15 at 05:35 PM

Thanks for all the help VSZ and thank you Kenomica for the test project! I was easily able to reproduce the issue. I've entered this as a different report (JIRA UE-11865) instead of reopening the previous one. The reason being is the old JIRA was more about the conversion process. I did however reference it in the new report.

We will investigate the issue further and post back here with updates.

Cheers,

TJ

avatar image Kenomica Mar 14 '15 at 05:42 PM

Not a problem, I'm glad you were able to reproduce it and that we could help get this fixed :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi VSZ and Kenomica,

I just submitted a fix for this crash, but unfortunately it just missed the deadline for the 4.7.3. Something seems to have changed with the way we fixed up components after re-running a construction script and it's affected the way lighting is reapplied to InstancedStaticMeshComponents.

The fix will be in 4.8, and a 4.7.4 update if we end up making one. I think this fix is pretty important so I'll push for it.

If you're using source code you can apply the fix directly yourself:

https://github.com/EpicGames/UnrealEngine/commit/67b10c1e844c78692caf08bfa419aba795b4f999

Thanks for your patience and help reproducing this bug.

  • Jack

more ▼

answered Mar 17 '15 at 06:06 AM

avatar image

JackP_oldaccount
1.3k 37 11 48

avatar image Kenomica Mar 17 '15 at 12:51 PM

Thank you for keeping me informed, I really appreciate it.

I'm not using the source so I'll continue to use 4.6 for the time being - but I'm glad to hear It will be fixed in the upcoming release (whichever one it may be) and look forward to being able to use all the great new features in 4.7/4.8!

avatar image VSZ Mar 17 '15 at 01:20 PM

Thanks everyone for fixing this!

I too am using the binary version right now (especially now that engine debug symbols are available in binary itself) but if I do happen to build from source I'll check out the fix.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Is it possible you are using content from an old sample? There are some known issues with opening very old assets with 4.7, please see this post: https://forums.unrealengine.com/showthread.php?57455-Old-Sample-Content-in-UE-4-7-IMPORTANT

more ▼

answered Feb 20 '15 at 09:24 AM

avatar image

JamesG STAFF
1.3k 8 8 32

avatar image Kenomica Feb 20 '15 at 10:08 AM

I'm pretty sure I'm not, but I'll certainly give those fixes a try, thank you.

avatar image Kenomica Feb 25 '15 at 01:49 PM

I used the Command Prompt to re-save everything and sadly it didn't solve the crash.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question