x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[UE 4.7P6] Only seeing 1/4 of the screen while playing

When using the Play In (Selected Viewport, New Editor Window, Standalone Game) I am only seeing the top left 1/4 of the game. The rest is all solid black. The game functions, but doesn't display properly.

I'm seeing the same issue on both of my Win7 machines.

Using the Launch option seems to work alright, so there's that.

I searched a bit, but couldn't find this being reported. I'm surprised if I'm the only person seeing this, though, since it is the same on two different machines.

Screenshot of the Editor Window:

alt text

Product Version: Not Selected
Tags:
more ▼

asked Feb 11 '15 at 06:06 PM in Bug Reports

avatar image

krillin6
123 10 10 17

avatar image Guilherme_gfx Feb 11 '15 at 06:14 PM

My engine does it too D:

avatar image krillin6 Feb 11 '15 at 06:53 PM

Good to know it isn't me doing something stupid, like it normally is :)

avatar image Guilherme_gfx Feb 11 '15 at 07:11 PM

lol, yes, im thinking the same, but I think it's a bug from UE4, cuz before the att it's started happen.

avatar image Ben Halliday STAFF Feb 11 '15 at 07:41 PM

Hi all,

I haven't been able to reproduce this in Preview 6, so I have a few questions.

  1. What type of project is this happening in?

  2. Does it happen in every new project you make? Does it happen in projects created in Preview 5?

  3. Go to Settings > Scalability > Engine Scalability Settings. What are the settings at? Please post a screenshot if possible. Are these the same settings you used previously, or did they change after the update? Does the issue persist if they are brought up to 100%?

  4. Are there any Engine settings that you changed after the upgrade? Do any seem different to you (particularly those in Editor Preferences > Play? A screenshot of those settings may be helpful as well.

Any additional details you can provide may be helpful. Thanks!

avatar image Guilherme_gfx Feb 11 '15 at 08:37 PM

To me it's work: Changing the Engine Scalability Settings: High > Epic. Changing resolutions: 720pi > 1080pi. Works fine.

avatar image Ben Halliday STAFF Feb 11 '15 at 09:07 PM

Glad that worked! I suspect there's something happening with the Editor Performance Monitor that's causing this in Preview 6. Can you tell me where you changed the resolution in the editor? Thanks!

avatar image Guilherme_gfx Feb 11 '15 at 09:42 PM

Okay let's go: First you can: click on the Edit>Editor Preferences>Play. There u can change the resolutions. To do the fullscreen you can take a note into your project as: C:\Users\Youruser\projectname\Saved\Config\Windows > GameUserSettings, (OPEN AS A NOTE) change this values: FullscreenMode=(maybe your value is 1) to 0 LastConfirmedFullscreenMode=(maybe your value is 1) to 0 Enjoy it.

avatar image krillin6 Feb 11 '15 at 09:16 PM

The only thing I normally change for a new project is the Scalable graphics instead of Max Quality or whatever it says. Screenshot attached. I also changed no settings post-upgrade. This issue occurs on my current projects, and new blank projects (Blueprint).

alt text

I did some testing with the settings you mentioned, and it appears to correlate with the Resolution Scale. If I set it to 50%, I see half of the screen, if I set it to 100%, I see the whole screen. It's a bug, but it has a workaround. Yay!

avatar image Guilherme_gfx Feb 11 '15 at 09:43 PM

Yes, but in some cases those changes doen't work as well, I test in two PC'S one resolve an other I have to change resolutions. xD

avatar image Ben Halliday STAFF Feb 11 '15 at 09:45 PM

Thanks for that info! I still can't reproduce this, but it's nice to see what's fixing it for you. I'm going to check in with the developers to see if they can tell what's going on. I'll keep this thread open while I continue investigating. Please feel free to add to this post if you have any more details. Thanks!

avatar image Guilherme_gfx Feb 11 '15 at 09:46 PM

Enjoy man! It's working fine! :D see ya!

avatar image Ben Halliday STAFF Feb 12 '15 at 10:56 PM

Hey Guilherme_gfx,

Can you attach your dxdiag, please? Thanks!

avatar image Ben Halliday STAFF Feb 12 '15 at 10:55 PM

Hey krillin6,

Can you attach your dxdiag, please? Thanks!

avatar image Ben Halliday STAFF Feb 11 '15 at 10:25 PM

Hey, could you guys give me your dxdiag? We want to see if this is somehow hardware related.

avatar image kamrann Feb 11 '15 at 11:16 PM

Hi Ben. Here's what I can add. - Confirm doesn't appear related to version in which project was created. - Confirm what krillin6 said above, the amount of viewport rendered to is directly proportional to the Resolution Scale settting. - I didn't knowingly change any settings, however I am running on an ultrabook so rather low powered. I've had the performance warning message pop up a few times and sometimes didn't react in time to cancel the auto changes, nor had I got around to finding out what settings get changed and where to reset them. - When the resolution scale is lower it also causes an issue in Simulate mode, where the 3D widget becomes unusable. Not sure if this is related in any way.

Also, I haven't downloaded preview 6, I'm building from source 4.7 branch, currently this commit. So the issue was introduced sometime between P5 and then.

Here's my dxdiag

kamrann_dxdiag.txt (78.9 kB)
avatar image BeeHive Feb 12 '15 at 01:45 AM

Same problem here on mac and win 8.1 if i go set the scalability settings below epic on mac and on low with the win 8.1 machine

avatar image Ben Halliday STAFF Feb 12 '15 at 10:54 PM

Can you give me your dxdiag for the windows machine and your system specs for the mac?

avatar image Ben Halliday STAFF Feb 12 '15 at 11:03 PM

Hi all,

I heard back from one of our developers who had noticed this in an earlier build of 4.7, but it was fixed for him in a later build. When you get the chance to upgrade to 4.7, see if lowering the scalability settings causes the same issue for you and let me know. Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi all,

I haven't heard back from you in a while, and I believe this issue has been fixed in 4.7 Preview 8. I'm going to mark this post as resolved, but if you are still experiencing this issue in Preview 8, please comment here with as many details as you can and we'll continue investigating. Thanks!

more ▼

answered Feb 23 '15 at 10:52 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question