x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Solved] - Blueprint JoinSession loading to incorrect map

Unreal 4.7.0 Preview 7 - Steam

We have a bare bones test case project derrived from the First Person Sample, and uses blueprints to Host and Join. We have a simple level with two buttons, Host and Join.

Host appears to work. You click Host and create a session and then go to the game map.

The client clicks Join and the FindSession works great, then we JoinSession on the first session found. (Very Verbose logging turned on) In the log we see the lobby join just fine, and then the client appears to get direct to join the in-progress game, but is told to Travel to the incorrect map.

 [2015.02.12-22.32.06:296][120]LogOnline: Join session: traveling to steam.76561198108265628:7777
 [2015.02.12-22.32.06:296][120]LogBlueprintUserMessages: joined ok
 [2015.02.12-22.32.06:296][120]LogNet: Browse: steam.76561198108265628//Game/FirstPersonBP/Maps/Entry
 [2015.02.12-22.32.06:297][120]LogNet:Display: SteamNetDriver_0 bound to port 7777
 [2015.02.12-22.32.06:298][120]LogNet: Game client on port 7777, rate 10000

Notice that the map is Entry intead of the expected map FirstPersonExampleMap. So the client joins but gets stuck in our Entry map.

The blueprint is... alt text

Any ideas as to why this is?

------- Later --------- Turns out we were missing the listen word in the OpenLevel options field.

This viedo has a great tutorial example at about 15 mnutes in. A COMPLETE blueprint session setup, join, leave, etc. https://www.youtube.com/watch?v=4LV7KKtzKs8#t=973

Product Version: Not Selected
Tags:
sessionbp.png (382.8 kB)
more ▼

asked Feb 12 '15 at 10:47 PM in Blueprint Scripting

avatar image

SND R Keene
933 29 118 112

avatar image Hitsugen Mar 16 '15 at 02:58 AM

Thanks for posting this, I've been trying to get this to work for a while now. Finally I got my buddy to join me through steam.

avatar image HuntaKiller Jun 19 '15 at 08:22 AM

I am having this problem, but the listen keyword is indeed in my openLevel node. My client is opening to the mainmenu instead of the level in progress

Edit: Solved: The problem was I was using the client window to host the game, not the server window. I discovered that this is a bug in play-in-editor and i was able to join the game properly.

avatar image Mesket Mar 08 '17 at 05:23 PM

Same problem, but with built versions.

Computer 1 with Steam account 1: Session created OK, player is on the map waiting for second player to join.

Computer 2 with Steam account 2: Search sessions OK, joins OK but is stuck on mainmenu.

Open level has listen but the second player won't load that map for some reason.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

option in open level node,add listen!

more ▼

answered Sep 19 '17 at 02:34 AM

avatar image

lcq1992
1 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question