Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

I cannot attach a weapon to a hand socket in a first person controller

I've tried putting a weapon(skeletal mesh) onto a socket I have in the hand of the skeleton, but it doesn't work on the first person controller. I've followed some tutorials and they all work great for third person controllers, but they all break when it goes to first person. It has been asked before here but I don't understand the question at all.

I attach a socket to a finger bone like normal, and attach a statue to it. It looks fine in the preview.

alt text

It gets attached at the feet of the character when I play it.

alt text

Here's my level blueprint, I've seen this exact script in many different tutorials.

alt text

I am completely stuck, and I would love any ideas on how to fix this.

Product Version: Not Selected
more ▼

asked Feb 13 '15 at 02:16 AM in Blueprint Scripting

avatar image

8 1 2 4

avatar image TriviusAkakous Feb 24 '15 at 02:58 AM

Ive got the same problem =(. Looks like your issue is that your trying to attach to the third person mesh in ur BP. The mesh for first person is "Mesh 1P" that should plug into "In Parent"

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Worked it out =)

I was following this tutorial: http://creategamesfromscratch.blogspot.co.at/2014/05/prototype-adding-hands-and-weapon.html

There are a few things missed out and these are:

Variable Weapon needs to be Static Mesh Component not static mesh

Most importantly the component 'Weapon' isnt mentioned which is what fixes the issue: weapon component

I have mine set as so:

weapon component details

And this is what my function looks like

alt text

Havent touched collision or set owner only see yet

animbp.jpg (121.2 kB)
changeweapon.png (191.1 kB)
more ▼

answered Feb 25 '15 at 07:21 AM

avatar image

28 2 3 4

avatar image danwardvs Feb 26 '15 at 03:09 AM

Thank you so much! I was going at this all wrong, but I got it now. Much appreciated!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

It seems that you've mismatched your meshes. Judging by the look of the picture, the statue is being attached to the root, which usualy happens when you specify "wrong" socket (in this case the non-existing one). So I would recommend checking what mesh exactly you're getting out of your character.

more ▼

answered Feb 24 '15 at 07:56 AM

avatar image

326 9 7 23

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question