x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

FBX Animation Freezing on Import

Having a really hard time taking my animation from Maya to Unreal 4. Whenever I try to import this animation / skeletal mesh, Unreal just gets stuck at the "Processing Chunks" message and freezes up. The mesh itself isn't that large (about 15k tris) so I don't think that's the culprit.

The odd thing is, I can get it in engine depending on my export settings. When exporting from Maya, if I let the FBX editor bake the animation, the file imports just fine. However, doing it this way doesn't seem to pick up any of the leg animations (even when testing the fbx back in Maya). And so instead I need to manually bake the animation before export (using Keys > Bake Simulation in Maya). When importing this new fbx back into Maya, it works perfectly and it picks up the leg movements. However, when I attempt to take it into Unreal, it just locks up the editor during import.

Literally the only difference between the fbx that can import and the one that freezes the editor is the way I bake the animation. I've tried multiple versions of the fbx exporter but still no dice. Any ideas? Thanks!

EDIT: I've narrowed down the issue a bit more. If I uncheck the "Import Morph Targets" option, I'm able to get the mesh to import (albeit without my blend shape expressions, obviously). I've been dealing with blend shape troubles all night, so I'm somehow not surprised. But I seemingly solved all of those problems so I'm kind of at a dead end here. Still seems super odd that I can import WITH morph targets if I let the fbx exporter bake my animations.

Product Version: Not Selected
Tags:
more ▼

asked Feb 13 '15 at 07:30 AM in Using UE4

avatar image

nimbusstev
26 5 6 21

avatar image nimbusstev Feb 19 '15 at 03:17 AM

After many trials and tribulations, I got my character working in the engine. Unfortunately, I had to abandon the morph target approach altogether since I couldn't seem to figure out how to fix the issue described above. Instead I ended up using a joint-based facial rig and the file now imports just fine.

Not really a solution to the problem, but I just wanted to report that this workaround solved my issues, and if you experience a similar problem it might be a valid course of action.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

In addition to baking out the joints before exporting, it might be worth a shot to bake the blendshape node's channels. I've had issues where the blendshapes were being driven by some heavy math nodes and would not import properly (would always get stuck at 75%). Doing a Bake Simulation on the blendshape node channels fixed this and import only took a second or so.

Also just a heads up, the import dialog for 4.8 is a lot more verbose than 4.7 which helps when debugging stuff like this.

more ▼

answered Jul 08 '15 at 01:19 PM

avatar image

jmalaska
732 41 38 60

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question