x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Map won't build lighting

Hello. I tried to build lighting but it just won't work. I also tried to build the whole scene but the editor will stop working and starts running on background. It doesn't respond anymore, and I think it is not even using my cpu to render.

It's Unreal Engine 4.6.1. The "DefaultEngine.ini" looks fine, "Static Lighting" flag it's set to "True", I tried to delete my intermediate and saved folder and nothing worked.

Product Version: Not Selected
Tags:
01.jpg (618.1 kB)
more ▼

asked Feb 13 '15 at 03:18 PM in Bug Reports

avatar image

0j
8 1 2 5

avatar image Jacky Feb 13 '15 at 05:42 PM

Do you have a lightmass importance volume in the level?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Before trying the following please try Jacky's suggestion and open SwarmAgent and check the Logs tab to make sure that there is some processes going on. If that doesn't appear to be doing anything try the next steps.

There are a couple of things I'll suggest to start with that may help.

Open SwarmAgent.exe (Unreal Engine > [Engine Version] > Engine > Binaries > DotNET )

When you double click to open this it will place an icon in your task manager. Open that. Go to the CACHE drop down in the menu bar. Click CLEAN and then VALIDATE.

Also, Go to this folder location (may be a hidden folder on your computer so you'll need rectify that before you can see it) C: > Users > [ Computer Name ] > AppData > Local > UnrealEngine >

Delete everything in this folder. Make sure to have the editor is closed otherwise some errors will be thrown that you cannot delete some files.

Let me know if these work for you.

more ▼

answered Feb 13 '15 at 06:19 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 888 103 878

avatar image Kagamusha Feb 21 '15 at 10:14 PM

I had a similar error where I would try to build my lighting but it would say lots of objects needed to be rebuilt immediately after. I followed your steps Tim and it resolved my issue. Hope it worked out for you too 0j!

avatar image 0j Feb 21 '15 at 11:16 PM

Worked! Thanks for the help Tim, it seems that the problem really was with the SwarmAgent.

avatar image ItsCodyDayo Apr 12 '16 at 03:37 PM

Worked for me as well, but I had to do a computer restart before Tim's steps in order for it to work. I've come back to this 3 times in the past to re-read the steps and I always end up having to do a restart before these work. No idea why.

avatar image mhnoni Aug 23 '16 at 08:03 PM

Thanks a lot Tim it worked , i believe most of the problem can be fixed by only deleting the catch on the C driver you mentioned .

avatar image neighborlee Sep 27 '16 at 12:12 AM

This didn't work for me, though I saved me a lot of space ;) I still can't get lighting to build, as its been five minutes and I"m still stuck at 5%.

Any idea why ?

I went for a much higher res terrain because I can't deal with blocky terrain, so is that causing this to take such a long time to get past 0% ?

ty

avatar image David Svoboda Sep 30 '16 at 07:21 AM

I had similar problem. None of the solutions I found worked. Then I have found out, that firewall was blocking swarmAgent, so it can be solution for someone.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

This problem still exists in 4.21.1, and I'm happy to report that for my "Lightning Build Failed" issue it was easy to solve:

Save and Quit you project. Navigate to your project's root and delete the "Intermediate" folder. Open your project.

A new Intermediate folder is automatically generated and this time I was able to build lightning again.

YMMV, good luck!

Note: When I was facing this issue there's no report of "why" the lightning build failed in the log, just that little popup in the bottom right that fades out.

more ▼

answered Jan 20 '19 at 06:00 PM

avatar image

gigapede
1 2 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi guys, I tried exactly that process, it works for the moment but suddenly when I change lights values it breaks again, light stops working, any help please? :( I've got the 4.22 version

more ▼

answered Jul 03 '19 at 08:22 PM

avatar image

Nathaniel_Murphy
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question